USN-4973-1

See a problem?
Source
https://ubuntu.com/security/notices/USN-4973-1
Import Source
https://github.com/canonical/ubuntu-security-notices/blob/main/osv/USN-4973-1.json
JSON Data
https://api.osv.dev/v1/vulns/USN-4973-1
Related
Published
2021-06-01T11:56:16.367459Z
Modified
2021-06-01T11:56:16.367459Z
Summary
python3.8 vulnerability
Details

It was discovered that the Python stdlib ipaddress API incorrectly handled octal strings. A remote attacker could possibly use this issue to perform a wide variety of attacks, including bypassing certain access restrictions.

References

Affected packages

Ubuntu:20.04:LTS / python3.8

Package

Name
python3.8

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
3.8.5-1~20.04.3

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "python3.8-minimal": "3.8.5-1~20.04.3",
            "libpython3.8-testsuite": "3.8.5-1~20.04.3",
            "libpython3.8": "3.8.5-1~20.04.3",
            "libpython3.8-minimal": "3.8.5-1~20.04.3",
            "idle-python3.8": "3.8.5-1~20.04.3",
            "python3.8": "3.8.5-1~20.04.3",
            "python3.8-venv": "3.8.5-1~20.04.3",
            "python3.8-doc": "3.8.5-1~20.04.3",
            "python3.8-examples": "3.8.5-1~20.04.3",
            "python3.8-dev": "3.8.5-1~20.04.3",
            "libpython3.8-stdlib": "3.8.5-1~20.04.3",
            "libpython3.8-dev": "3.8.5-1~20.04.3"
        }
    ]
}