USN-4990-1

See a problem?
Source
https://ubuntu.com/security/notices/USN-4990-1
Import Source
https://github.com/canonical/ubuntu-security-notices/blob/main/osv/USN-4990-1.json
JSON Data
https://api.osv.dev/v1/vulns/USN-4990-1
Related
Published
2021-06-17T11:01:57.787718Z
Modified
2021-06-17T11:01:57.787718Z
Summary
nettle vulnerabilities
Details

It was discovered that Nettle incorrectly handled RSA decryption. A remote attacker could possibly use this issue to cause Nettle to crash, resulting in a denial of service. (CVE-2021-3580)

It was discovered that Nettle incorrectly handled certain padding oracles. A remote attacker could possibly use this issue to perform a variant of the Bleichenbacher attack. This issue only affected Ubuntu 18.04 LTS. (CVE-2018-16869)

References

Affected packages

Ubuntu:18.04:LTS / nettle

Package

Name
nettle

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
3.4.1-0ubuntu0.18.04.1

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "nettle-dev": "3.4.1-0ubuntu0.18.04.1",
            "libhogweed4": "3.4.1-0ubuntu0.18.04.1",
            "nettle-bin": "3.4.1-0ubuntu0.18.04.1",
            "libnettle6": "3.4.1-0ubuntu0.18.04.1"
        }
    ]
}

Ubuntu:20.04:LTS / nettle

Package

Name
nettle

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
3.5.1+really3.5.1-2ubuntu0.2

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "nettle-dev": "3.5.1+really3.5.1-2ubuntu0.2",
            "libnettle7": "3.5.1+really3.5.1-2ubuntu0.2",
            "libhogweed5": "3.5.1+really3.5.1-2ubuntu0.2",
            "nettle-bin": "3.5.1+really3.5.1-2ubuntu0.2"
        }
    ]
}