USN-5006-1

See a problem?
Source
https://ubuntu.com/security/notices/USN-5006-1
Import Source
https://github.com/canonical/ubuntu-security-notices/blob/main/osv/USN-5006-1.json
JSON Data
https://api.osv.dev/v1/vulns/USN-5006-1
Related
Published
2021-07-07T12:11:57.985067Z
Modified
2021-07-07T12:11:57.985067Z
Summary
php7.2, php7.4 vulnerabilities
Details

It was discovered that PHP incorrectly handled certain PHAR files. A remote attacker could possibly use this issue to cause PHP to crash, resulting in a denial of service, or possibly obtain sensitive information. This issue only affected Ubuntu 18.04 LTS and Ubuntu 20.04 LTS. (CVE-2020-7068)

It was discovered that PHP incorrectly handled parsing URLs with passwords. A remote attacker could possibly use this issue to cause PHP to mis-parse the URL and produce wrong data. This issue only affected Ubuntu 18.04 LTS, Ubuntu 20.04 LTS, and Ubuntu 20.10. (CVE-2020-7071)

It was discovered that PHP incorrectly handled certain malformed XML data when being parsed by the SOAP extension. A remote attacker could possibly use this issue to cause PHP to crash, resulting in a denial of service. This issue only affected Ubuntu 18.04 LTS, Ubuntu 20.04 LTS, and Ubuntu 20.10. (CVE-2021-21702)

It was discovered that PHP incorrectly handled the pdo_firebase module. A remote attacker could possibly use this issue to cause PHP to crash, resulting in a denial of service. (CVE-2021-21704)

It was discovered that PHP incorrectly handled the FILTERVALIDATEURL check. A remote attacker could possibly use this issue to perform a server- side request forgery attack. (CVE-2021-21705)

References

Affected packages

Ubuntu:18.04:LTS / php7.2

Package

Name
php7.2

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
7.2.24-0ubuntu0.18.04.8

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "php7.2-ldap": "7.2.24-0ubuntu0.18.04.8",
            "php7.2-mbstring": "7.2.24-0ubuntu0.18.04.8",
            "libapache2-mod-php7.2": "7.2.24-0ubuntu0.18.04.8",
            "php7.2-opcache": "7.2.24-0ubuntu0.18.04.8",
            "php7.2-intl": "7.2.24-0ubuntu0.18.04.8",
            "php7.2-bz2": "7.2.24-0ubuntu0.18.04.8",
            "php7.2-gmp": "7.2.24-0ubuntu0.18.04.8",
            "php7.2-sybase": "7.2.24-0ubuntu0.18.04.8",
            "php7.2-bcmath": "7.2.24-0ubuntu0.18.04.8",
            "php7.2-odbc": "7.2.24-0ubuntu0.18.04.8",
            "php7.2-snmp": "7.2.24-0ubuntu0.18.04.8",
            "php7.2-pgsql": "7.2.24-0ubuntu0.18.04.8",
            "php7.2-recode": "7.2.24-0ubuntu0.18.04.8",
            "php7.2-phpdbg": "7.2.24-0ubuntu0.18.04.8",
            "php7.2-interbase": "7.2.24-0ubuntu0.18.04.8",
            "php7.2-cgi": "7.2.24-0ubuntu0.18.04.8",
            "php7.2-sqlite3": "7.2.24-0ubuntu0.18.04.8",
            "php7.2-tidy": "7.2.24-0ubuntu0.18.04.8",
            "php7.2-json": "7.2.24-0ubuntu0.18.04.8",
            "php7.2-xmlrpc": "7.2.24-0ubuntu0.18.04.8",
            "php7.2-fpm": "7.2.24-0ubuntu0.18.04.8",
            "php7.2-curl": "7.2.24-0ubuntu0.18.04.8",
            "php7.2-cli": "7.2.24-0ubuntu0.18.04.8",
            "php7.2": "7.2.24-0ubuntu0.18.04.8",
            "php7.2-xsl": "7.2.24-0ubuntu0.18.04.8",
            "php7.2-zip": "7.2.24-0ubuntu0.18.04.8",
            "php7.2-xml": "7.2.24-0ubuntu0.18.04.8",
            "php7.2-common": "7.2.24-0ubuntu0.18.04.8",
            "php7.2-dba": "7.2.24-0ubuntu0.18.04.8",
            "php7.2-readline": "7.2.24-0ubuntu0.18.04.8",
            "php7.2-mysql": "7.2.24-0ubuntu0.18.04.8",
            "php7.2-imap": "7.2.24-0ubuntu0.18.04.8",
            "php7.2-enchant": "7.2.24-0ubuntu0.18.04.8",
            "libphp7.2-embed": "7.2.24-0ubuntu0.18.04.8",
            "php7.2-gd": "7.2.24-0ubuntu0.18.04.8",
            "php7.2-pspell": "7.2.24-0ubuntu0.18.04.8",
            "php7.2-soap": "7.2.24-0ubuntu0.18.04.8",
            "php7.2-dev": "7.2.24-0ubuntu0.18.04.8"
        }
    ]
}

Ubuntu:20.04:LTS / php7.4

Package

Name
php7.4

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
7.4.3-4ubuntu2.5

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "php7.4-cgi": "7.4.3-4ubuntu2.5",
            "php7.4-sqlite3": "7.4.3-4ubuntu2.5",
            "php7.4-interbase": "7.4.3-4ubuntu2.5",
            "php7.4-intl": "7.4.3-4ubuntu2.5",
            "php7.4-mysql": "7.4.3-4ubuntu2.5",
            "php7.4-dba": "7.4.3-4ubuntu2.5",
            "php7.4-xsl": "7.4.3-4ubuntu2.5",
            "php7.4-gd": "7.4.3-4ubuntu2.5",
            "php7.4-curl": "7.4.3-4ubuntu2.5",
            "php7.4-bz2": "7.4.3-4ubuntu2.5",
            "php7.4-gmp": "7.4.3-4ubuntu2.5",
            "libphp7.4-embed": "7.4.3-4ubuntu2.5",
            "php7.4-tidy": "7.4.3-4ubuntu2.5",
            "php7.4-dev": "7.4.3-4ubuntu2.5",
            "php7.4-snmp": "7.4.3-4ubuntu2.5",
            "php7.4-phpdbg": "7.4.3-4ubuntu2.5",
            "php7.4-imap": "7.4.3-4ubuntu2.5",
            "php7.4-pgsql": "7.4.3-4ubuntu2.5",
            "php7.4": "7.4.3-4ubuntu2.5",
            "php7.4-odbc": "7.4.3-4ubuntu2.5",
            "php7.4-bcmath": "7.4.3-4ubuntu2.5",
            "php7.4-mbstring": "7.4.3-4ubuntu2.5",
            "php7.4-pspell": "7.4.3-4ubuntu2.5",
            "php7.4-json": "7.4.3-4ubuntu2.5",
            "php7.4-xml": "7.4.3-4ubuntu2.5",
            "php7.4-enchant": "7.4.3-4ubuntu2.5",
            "php7.4-opcache": "7.4.3-4ubuntu2.5",
            "php7.4-sybase": "7.4.3-4ubuntu2.5",
            "php7.4-ldap": "7.4.3-4ubuntu2.5",
            "php7.4-zip": "7.4.3-4ubuntu2.5",
            "php7.4-fpm": "7.4.3-4ubuntu2.5",
            "libapache2-mod-php7.4": "7.4.3-4ubuntu2.5",
            "php7.4-readline": "7.4.3-4ubuntu2.5",
            "php7.4-common": "7.4.3-4ubuntu2.5",
            "php7.4-cli": "7.4.3-4ubuntu2.5",
            "php7.4-soap": "7.4.3-4ubuntu2.5",
            "php7.4-xmlrpc": "7.4.3-4ubuntu2.5"
        }
    ]
}