USN-5021-1

See a problem?
Source
https://ubuntu.com/security/notices/USN-5021-1
Import Source
https://github.com/canonical/ubuntu-security-notices/blob/main/osv/USN-5021-1.json
JSON Data
https://api.osv.dev/v1/vulns/USN-5021-1
Related
Published
2021-07-22T18:17:55.946470Z
Modified
2021-07-22T18:17:55.946470Z
Summary
curl vulnerabilities
Details

Harry Sintonen and Tomas Hoger discovered that curl incorrectly handled TELNET connections when the -t option was used on the command line. Uninitialized data possibly containing sensitive information could be sent to the remote server, contrary to expectations. (CVE-2021-22898, CVE-2021-22925)

Harry Sintonen discovered that curl incorrectly reused connections in the connection pool. This could result in curl reusing the wrong connections. (CVE-2021-22924)

References

Affected packages

Ubuntu:20.04:LTS / curl

Package

Name
curl

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
7.68.0-1ubuntu2.6

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "curl": "7.68.0-1ubuntu2.6",
            "libcurl4": "7.68.0-1ubuntu2.6",
            "libcurl4-gnutls-dev": "7.68.0-1ubuntu2.6",
            "libcurl3-gnutls": "7.68.0-1ubuntu2.6",
            "libcurl4-doc": "7.68.0-1ubuntu2.6",
            "libcurl3-nss": "7.68.0-1ubuntu2.6",
            "libcurl4-nss-dev": "7.68.0-1ubuntu2.6",
            "libcurl4-openssl-dev": "7.68.0-1ubuntu2.6"
        }
    ]
}

Ubuntu:18.04:LTS / curl

Package

Name
curl

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
7.58.0-2ubuntu3.14

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "curl": "7.58.0-2ubuntu3.14",
            "libcurl4": "7.58.0-2ubuntu3.14",
            "libcurl4-gnutls-dev": "7.58.0-2ubuntu3.14",
            "libcurl3-gnutls": "7.58.0-2ubuntu3.14",
            "libcurl4-doc": "7.58.0-2ubuntu3.14",
            "libcurl3-nss": "7.58.0-2ubuntu3.14",
            "libcurl4-nss-dev": "7.58.0-2ubuntu3.14",
            "libcurl4-openssl-dev": "7.58.0-2ubuntu3.14"
        }
    ]
}