USN-5036-1

See a problem?
Source
https://ubuntu.com/security/notices/USN-5036-1
Import Source
https://github.com/canonical/ubuntu-security-notices/blob/main/osv/USN-5036-1.json
JSON Data
https://api.osv.dev/v1/vulns/USN-5036-1
Related
Published
2022-10-04T11:04:57.645398Z
Modified
2022-10-04T11:04:57.645398Z
Summary
tor vulnerabilities
Details

It was discovered that Tor incorrectly handled certain memory operations. A remote attacker could use this issue to cause a denial of service. This issue only affected Ubuntu 18.04 ESM. (CVE-2019-8955)

It was discovered that Tor did not properly handle the input length to dump_desc() function. A remote attacker could use this issue to cause a denial of service. This issue only affected Ubuntu 16.04 ESM, Ubuntu 18.04 ESM and Ubuntu 20.04 ESM. (CVE-2021-28089)

It was discovered that Tor did not properly sanitize the relay nickname in dirvoteaddsignaturestopending_consensus() function. An attacker could possibly use this issue to cause an assertion failure and then cause a denial of service. (CVE-2021-28090)

It was discovered that Tor did not properly validate the layer hint on half-open streams. A remote attacker could possibly use this issue to bypass the access control, leading to remote code execution. This issue only affected Ubuntu 20.04 ESM. (CVE-2021-34548)

It was discovered that Tor was using an insecure hash function. A remote attacker could use this issue to cause a denial of service. This issue only affected Ubuntu 16.04 ESM, Ubuntu 18.04 ESM and Ubuntu 20.04 ESM. (CVE-2021-34549)

It was discovered that Tor did not properly manage memory under certain circumstances. If a user were tricked into opening a specially crafted request, a remote attacker could possibly use this issue to cause a crash, resulting in a denial of service, or possibly reading sensitive data. This issue only affected Ubuntu 18.04 ESM and Ubuntu 20.04 ESM. (CVE-2021-34550)

It was discovered that Tor mishandles the relationship between batch-signature verification and single-signature verification. An attacker could possibly use this issue to cause an assertion failure and then cause a denial of service. This issue only affected Ubuntu 16.04 ESM, Ubuntu 18.04 ESM and Ubuntu 20.04 ESM. (CVE-2021-38385)

References

Affected packages

Ubuntu:Pro:20.04:LTS / tor

Package

Name
tor

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
0.4.2.7-1ubuntu0.1~esm1

Ecosystem specific

{
    "availability": "Available with Ubuntu Pro: https://ubuntu.com/pro",
    "binaries": [
        {
            "tor": "0.4.2.7-1ubuntu0.1~esm1",
            "tor-geoipdb": "0.4.2.7-1ubuntu0.1~esm1"
        }
    ]
}

Ubuntu:Pro:14.04:LTS / tor

Package

Name
tor

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
0.2.4.27-1ubuntu0.1+esm2

Ecosystem specific

{
    "availability": "Available with Ubuntu Pro: https://ubuntu.com/pro",
    "binaries": [
        {
            "tor": "0.2.4.27-1ubuntu0.1+esm2",
            "tor-geoipdb": "0.2.4.27-1ubuntu0.1+esm2"
        }
    ]
}

Ubuntu:Pro:18.04:LTS / tor

Package

Name
tor

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
0.3.2.10-1ubuntu0.2~esm2

Ecosystem specific

{
    "availability": "Available with Ubuntu Pro: https://ubuntu.com/pro",
    "binaries": [
        {
            "tor": "0.3.2.10-1ubuntu0.2~esm2",
            "tor-geoipdb": "0.3.2.10-1ubuntu0.2~esm2"
        }
    ]
}

Ubuntu:Pro:16.04:LTS / tor

Package

Name
tor

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
0.2.9.14-1ubuntu1~16.04.3+esm1

Ecosystem specific

{
    "availability": "Available with Ubuntu Pro: https://ubuntu.com/pro",
    "binaries": [
        {
            "tor": "0.2.9.14-1ubuntu1~16.04.3+esm1",
            "tor-geoipdb": "0.2.9.14-1ubuntu1~16.04.3+esm1"
        }
    ]
}