USN-5041-1

See a problem?
Source
https://ubuntu.com/security/notices/USN-5041-1
Import Source
https://github.com/canonical/ubuntu-security-notices/blob/main/osv/USN-5041-1.json
JSON Data
https://api.osv.dev/v1/vulns/USN-5041-1
Related
  • CVE-2019-12412
Published
2021-08-17T14:07:24.394998Z
Modified
2021-08-17T14:07:24.394998Z
Summary
libapreq2 vulnerability
Details

It was discovered that libapreq2 did not properly sanitize the Content-Type field in certain crafted HTTP requests. An attacker could possibly use the vulnerability to cause libapreq2 to crash.

References

Affected packages

Ubuntu:Pro:14.04:LTS / libapreq2

Package

Name
libapreq2

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
2.13-3ubuntu2+esm1

Ecosystem specific

{
    "availability": "Available with Ubuntu Pro: https://ubuntu.com/pro",
    "binaries": [
        {
            "libapreq2-dev": "2.13-3ubuntu2+esm1",
            "libapache2-request-perl": "2.13-3ubuntu2+esm1",
            "libapreq2-3": "2.13-3ubuntu2+esm1",
            "libapreq2-doc": "2.13-3ubuntu2+esm1",
            "libapache2-mod-apreq2": "2.13-3ubuntu2+esm1"
        }
    ]
}

Ubuntu:Pro:16.04:LTS / libapreq2

Package

Name
libapreq2

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
2.13-4ubuntu2+esm1

Ecosystem specific

{
    "availability": "Available with Ubuntu Pro: https://ubuntu.com/pro",
    "binaries": [
        {
            "libapreq2-dev": "2.13-4ubuntu2+esm1",
            "libapache2-request-perl": "2.13-4ubuntu2+esm1",
            "libapreq2-3": "2.13-4ubuntu2+esm1",
            "libapreq2-doc": "2.13-4ubuntu2+esm1",
            "libapache2-mod-apreq2": "2.13-4ubuntu2+esm1"
        }
    ]
}