USN-5057-1

See a problem?
Source
https://ubuntu.com/security/notices/USN-5057-1
Import Source
https://github.com/canonical/ubuntu-security-notices/blob/main/osv/USN-5057-1.json
JSON Data
https://api.osv.dev/v1/vulns/USN-5057-1
Related
Published
2021-08-31T00:34:13.288005Z
Modified
2021-08-31T00:34:13.288005Z
Summary
squashfs-tools vulnerability
Details

Etienne Stalmans discovered that Squashfs-Tools mishandled certain malformed SQUASHFS files. An attacker could use this vulnerability to write arbitrary files to the filesystem.

References

Affected packages

Ubuntu:18.04:LTS / squashfs-tools

Package

Name
squashfs-tools

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
1:4.3-6ubuntu0.18.04.3

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "squashfs-tools": "1:4.3-6ubuntu0.18.04.3"
        }
    ]
}

Ubuntu:20.04:LTS / squashfs-tools

Package

Name
squashfs-tools

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
1:4.4-1ubuntu0.1

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "squashfs-tools": "1:4.4-1ubuntu0.1"
        }
    ]
}