USN-5076-1

See a problem?
Source
https://ubuntu.com/security/notices/USN-5076-1
Import Source
https://github.com/canonical/ubuntu-security-notices/blob/main/osv/USN-5076-1.json
JSON Data
https://api.osv.dev/v1/vulns/USN-5076-1
Related
Published
2021-09-13T14:49:00.977893Z
Modified
2021-09-13T14:49:00.977893Z
Summary
git vulnerability
Details

It was discovered that Git allowed newline characters in certain repository paths. An attacker could potentially use this issue to perform cross-protocol requests.

References

Affected packages

Ubuntu:20.04:LTS / git

Package

Name
git

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
1:2.25.1-1ubuntu3.2

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "git-daemon-run": "1:2.25.1-1ubuntu3.2",
            "git-email": "1:2.25.1-1ubuntu3.2",
            "git-mediawiki": "1:2.25.1-1ubuntu3.2",
            "git": "1:2.25.1-1ubuntu3.2",
            "git-el": "1:2.25.1-1ubuntu3.2",
            "git-cvs": "1:2.25.1-1ubuntu3.2",
            "git-doc": "1:2.25.1-1ubuntu3.2",
            "gitk": "1:2.25.1-1ubuntu3.2",
            "git-daemon-sysvinit": "1:2.25.1-1ubuntu3.2",
            "git-svn": "1:2.25.1-1ubuntu3.2",
            "gitweb": "1:2.25.1-1ubuntu3.2",
            "git-man": "1:2.25.1-1ubuntu3.2",
            "git-gui": "1:2.25.1-1ubuntu3.2",
            "git-all": "1:2.25.1-1ubuntu3.2"
        }
    ]
}

Ubuntu:18.04:LTS / git

Package

Name
git

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
1:2.17.1-1ubuntu0.9

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "git-daemon-run": "1:2.17.1-1ubuntu0.9",
            "git-email": "1:2.17.1-1ubuntu0.9",
            "git-mediawiki": "1:2.17.1-1ubuntu0.9",
            "git": "1:2.17.1-1ubuntu0.9",
            "git-el": "1:2.17.1-1ubuntu0.9",
            "git-cvs": "1:2.17.1-1ubuntu0.9",
            "git-doc": "1:2.17.1-1ubuntu0.9",
            "gitk": "1:2.17.1-1ubuntu0.9",
            "git-daemon-sysvinit": "1:2.17.1-1ubuntu0.9",
            "git-svn": "1:2.17.1-1ubuntu0.9",
            "gitweb": "1:2.17.1-1ubuntu0.9",
            "git-man": "1:2.17.1-1ubuntu0.9",
            "git-gui": "1:2.17.1-1ubuntu0.9",
            "git-all": "1:2.17.1-1ubuntu0.9"
        }
    ]
}

Ubuntu:Pro:16.04:LTS / git

Package

Name
git

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
1:2.7.4-0ubuntu1.10+esm1

Ecosystem specific

{
    "availability": "Available with Ubuntu Pro: https://ubuntu.com/pro",
    "binaries": [
        {
            "git-core": "1:2.7.4-0ubuntu1.10+esm1",
            "git-daemon-run": "1:2.7.4-0ubuntu1.10+esm1",
            "git-email": "1:2.7.4-0ubuntu1.10+esm1",
            "git-mediawiki": "1:2.7.4-0ubuntu1.10+esm1",
            "git": "1:2.7.4-0ubuntu1.10+esm1",
            "git-el": "1:2.7.4-0ubuntu1.10+esm1",
            "git-cvs": "1:2.7.4-0ubuntu1.10+esm1",
            "git-doc": "1:2.7.4-0ubuntu1.10+esm1",
            "gitk": "1:2.7.4-0ubuntu1.10+esm1",
            "git-arch": "1:2.7.4-0ubuntu1.10+esm1",
            "git-daemon-sysvinit": "1:2.7.4-0ubuntu1.10+esm1",
            "git-svn": "1:2.7.4-0ubuntu1.10+esm1",
            "gitweb": "1:2.7.4-0ubuntu1.10+esm1",
            "git-man": "1:2.7.4-0ubuntu1.10+esm1",
            "git-gui": "1:2.7.4-0ubuntu1.10+esm1",
            "git-all": "1:2.7.4-0ubuntu1.10+esm1"
        }
    ]
}