USN-5079-4

See a problem?
Source
https://ubuntu.com/security/notices/USN-5079-4
Import Source
https://github.com/canonical/ubuntu-security-notices/blob/main/osv/USN-5079-4.json
JSON Data
https://api.osv.dev/v1/vulns/USN-5079-4
Published
2021-09-21T13:07:33.591500Z
Modified
2021-09-21T13:07:33.591500Z
Summary
curl regression
Details

USN-5079-2 fixed vulnerabilities in curl. One of the fixes introduced a regression. This update fixes the problem.

Original advisory details:

Patrick Monnerat discovered that curl incorrectly handled upgrades to TLS. When receiving certain responses from servers, curl would continue without TLS even when the option to require a successful upgrade to TLS was specified. (CVE-2021-22946)

Patrick Monnerat discovered that curl incorrectly handled responses received before STARTTLS. A remote attacker could possibly use this issue to inject responses and intercept communications. (CVE-2021-22947)

References

Affected packages

Ubuntu:Pro:14.04:LTS / curl

Package

Name
curl

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
7.35.0-1ubuntu2.20+esm9

Ecosystem specific

{
    "availability": "Available with Ubuntu Pro: https://ubuntu.com/pro",
    "binaries": [
        {
            "curl": "7.35.0-1ubuntu2.20+esm9",
            "libcurl3": "7.35.0-1ubuntu2.20+esm9",
            "libcurl4-gnutls-dev": "7.35.0-1ubuntu2.20+esm9",
            "libcurl3-gnutls": "7.35.0-1ubuntu2.20+esm9",
            "libcurl4-doc": "7.35.0-1ubuntu2.20+esm9",
            "libcurl3-nss": "7.35.0-1ubuntu2.20+esm9",
            "libcurl4-nss-dev": "7.35.0-1ubuntu2.20+esm9",
            "libcurl4-openssl-dev": "7.35.0-1ubuntu2.20+esm9"
        }
    ]
}

Ubuntu:Pro:16.04:LTS / curl

Package

Name
curl

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
7.47.0-1ubuntu2.19+esm2

Ecosystem specific

{
    "availability": "Available with Ubuntu Pro: https://ubuntu.com/pro",
    "binaries": [
        {
            "curl": "7.47.0-1ubuntu2.19+esm2",
            "libcurl3": "7.47.0-1ubuntu2.19+esm2",
            "libcurl4-gnutls-dev": "7.47.0-1ubuntu2.19+esm2",
            "libcurl3-gnutls": "7.47.0-1ubuntu2.19+esm2",
            "libcurl4-doc": "7.47.0-1ubuntu2.19+esm2",
            "libcurl3-nss": "7.47.0-1ubuntu2.19+esm2",
            "libcurl4-nss-dev": "7.47.0-1ubuntu2.19+esm2",
            "libcurl4-openssl-dev": "7.47.0-1ubuntu2.19+esm2"
        }
    ]
}