USN-5080-2

See a problem?
Source
https://ubuntu.com/security/notices/USN-5080-2
Import Source
https://github.com/canonical/ubuntu-security-notices/blob/main/osv/USN-5080-2.json
JSON Data
https://api.osv.dev/v1/vulns/USN-5080-2
Related
Published
2021-09-16T16:07:21.304965Z
Modified
2021-09-16T16:07:21.304965Z
Summary
libgcrypt20 vulnerabilities
Details

USN-5080-1 fixed several vulnerabilities in Libgcrypt. This update provides the corresponding update for Ubuntu 16.04 ESM.

Original advisory details:

It was discovered that Libgcrypt incorrectly handled ElGamal encryption. An attacker could possibly use this issue to recover sensitive information.

References

Affected packages

Ubuntu:Pro:16.04:LTS / libgcrypt20

Package

Name
libgcrypt20

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
1.6.5-2ubuntu0.6+esm1

Ecosystem specific

{
    "availability": "Available with Ubuntu Pro: https://ubuntu.com/pro",
    "binaries": [
        {
            "libgcrypt20-doc": "1.6.5-2ubuntu0.6+esm1",
            "libgcrypt20": "1.6.5-2ubuntu0.6+esm1",
            "libgcrypt20-dev": "1.6.5-2ubuntu0.6+esm1",
            "libgcrypt11-dev": "1.5.4-3+really1.6.5-2ubuntu0.6+esm1"
        }
    ]
}