USN-5091-1

See a problem?
Source
https://ubuntu.com/security/notices/USN-5091-1
Import Source
https://github.com/canonical/ubuntu-security-notices/blob/main/osv/USN-5091-1.json
JSON Data
https://api.osv.dev/v1/vulns/USN-5091-1
Related
Published
2021-09-28T02:30:49.898236Z
Modified
2021-09-28T02:30:49.898236Z
Summary
linux, linux-aws, linux-aws-5.4, linux-azure, linux-azure-5.4, linux-gcp, linux-gcp-5.4, linux-gke, linux-gke-5.4, linux-gkeop, linux-gkeop-5.4, linux-hwe-5.4, linux-kvm, linux-oracle, linux-oracle-5.4 vulnerabilities
Details

Ofek Kirzner, Adam Morrison, Benedict Schlueter, and Piotr Krysiuk discovered that the BPF verifier in the Linux kernel missed possible mispredicted branches due to type confusion, allowing a side-channel attack. An attacker could use this to expose sensitive information. (CVE-2021-33624)

It was discovered that the tracing subsystem in the Linux kernel did not properly keep track of per-cpu ring buffer state. A privileged attacker could use this to cause a denial of service. (CVE-2021-3679)

Alexey Kardashevskiy discovered that the KVM implementation for PowerPC systems in the Linux kernel did not properly validate RTAS arguments in some situations. An attacker in a guest vm could use this to cause a denial of service (host OS crash) or possibly execute arbitrary code. (CVE-2021-37576)

It was discovered that the Virtio console implementation in the Linux kernel did not properly validate input lengths in some situations. A local attacker could possibly use this to cause a denial of service (system crash). (CVE-2021-38160)

Michael Wakabayashi discovered that the NFSv4 client implementation in the Linux kernel did not properly order connection setup operations. An attacker controlling a remote NFS server could use this to cause a denial of service on the client. (CVE-2021-38199)

It was discovered that the MAX-3421 host USB device driver in the Linux kernel did not properly handle device removal events. A physically proximate attacker could use this to cause a denial of service (system crash). (CVE-2021-38204)

References

Affected packages

Ubuntu:18.04:LTS / linux-gke-5.4

Package

Name
linux-gke-5.4

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
5.4.0-1053.56~18.04.1

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "linux-modules-5.4.0-1053-gke": "5.4.0-1053.56~18.04.1",
            "linux-buildinfo-5.4.0-1053-gke": "5.4.0-1053.56~18.04.1",
            "linux-gke-5.4-headers-5.4.0-1053": "5.4.0-1053.56~18.04.1",
            "linux-tools-5.4.0-1053-gke": "5.4.0-1053.56~18.04.1",
            "linux-gke-5.4-tools-5.4.0-1053": "5.4.0-1053.56~18.04.1",
            "linux-tools-gke-5.4": "5.4.0.1053.56~18.04.18",
            "linux-gke-5.4": "5.4.0.1053.56~18.04.18",
            "linux-headers-5.4.0-1053-gke": "5.4.0-1053.56~18.04.1",
            "linux-image-unsigned-5.4.0-1053-gke": "5.4.0-1053.56~18.04.1",
            "linux-headers-gke-5.4": "5.4.0.1053.56~18.04.18",
            "linux-image-5.4.0-1053-gke": "5.4.0-1053.56~18.04.1",
            "linux-modules-extra-5.4.0-1053-gke": "5.4.0-1053.56~18.04.1",
            "linux-modules-extra-gke-5.4": "5.4.0.1053.56~18.04.18",
            "linux-image-gke-5.4": "5.4.0.1053.56~18.04.18"
        }
    ]
}

Ubuntu:18.04:LTS / linux-gcp-5.4

Package

Name
linux-gcp-5.4

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
5.4.0-1053.57~18.04.1

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "linux-gcp-5.4-tools-5.4.0-1053": "5.4.0-1053.57~18.04.1",
            "linux-tools-gcp": "5.4.0.1053.39",
            "linux-image-5.4.0-1053-gcp": "5.4.0-1053.57~18.04.1",
            "linux-tools-gcp-edge": "5.4.0.1053.39",
            "linux-headers-5.4.0-1053-gcp": "5.4.0-1053.57~18.04.1",
            "linux-gcp": "5.4.0.1053.39",
            "linux-headers-gcp-edge": "5.4.0.1053.39",
            "linux-image-gcp-edge": "5.4.0.1053.39",
            "linux-image-unsigned-5.4.0-1053-gcp": "5.4.0-1053.57~18.04.1",
            "linux-image-gcp": "5.4.0.1053.39",
            "linux-headers-gcp": "5.4.0.1053.39",
            "linux-modules-extra-gcp": "5.4.0.1053.39",
            "linux-gcp-5.4-headers-5.4.0-1053": "5.4.0-1053.57~18.04.1",
            "linux-tools-5.4.0-1053-gcp": "5.4.0-1053.57~18.04.1",
            "linux-gcp-edge": "5.4.0.1053.39",
            "linux-modules-extra-gcp-edge": "5.4.0.1053.39",
            "linux-modules-5.4.0-1053-gcp": "5.4.0-1053.57~18.04.1",
            "linux-buildinfo-5.4.0-1053-gcp": "5.4.0-1053.57~18.04.1",
            "linux-modules-extra-5.4.0-1053-gcp": "5.4.0-1053.57~18.04.1"
        }
    ]
}

Ubuntu:18.04:LTS / linux-azure-5.4

Package

Name
linux-azure-5.4

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
5.4.0-1059.62~18.04.1

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "linux-azure-5.4-headers-5.4.0-1059": "5.4.0-1059.62~18.04.1",
            "linux-signed-image-azure-edge": "5.4.0.1059.39",
            "linux-azure-5.4-tools-5.4.0-1059": "5.4.0-1059.62~18.04.1",
            "linux-modules-extra-azure": "5.4.0.1059.39",
            "linux-signed-image-azure": "5.4.0.1059.39",
            "linux-image-azure-edge": "5.4.0.1059.39",
            "linux-azure": "5.4.0.1059.39",
            "linux-modules-5.4.0-1059-azure": "5.4.0-1059.62~18.04.1",
            "linux-signed-azure": "5.4.0.1059.39",
            "linux-azure-edge": "5.4.0.1059.39",
            "linux-buildinfo-5.4.0-1059-azure": "5.4.0-1059.62~18.04.1",
            "linux-headers-azure-edge": "5.4.0.1059.39",
            "linux-headers-azure": "5.4.0.1059.39",
            "linux-tools-azure-edge": "5.4.0.1059.39",
            "linux-cloud-tools-azure": "5.4.0.1059.39",
            "linux-tools-azure": "5.4.0.1059.39",
            "linux-modules-extra-5.4.0-1059-azure": "5.4.0-1059.62~18.04.1",
            "linux-tools-5.4.0-1059-azure": "5.4.0-1059.62~18.04.1",
            "linux-image-unsigned-5.4.0-1059-azure": "5.4.0-1059.62~18.04.1",
            "linux-image-azure": "5.4.0.1059.39",
            "linux-image-5.4.0-1059-azure": "5.4.0-1059.62~18.04.1",
            "linux-headers-5.4.0-1059-azure": "5.4.0-1059.62~18.04.1",
            "linux-signed-azure-edge": "5.4.0.1059.39",
            "linux-azure-5.4-cloud-tools-5.4.0-1059": "5.4.0-1059.62~18.04.1",
            "linux-cloud-tools-azure-edge": "5.4.0.1059.39",
            "linux-cloud-tools-5.4.0-1059-azure": "5.4.0-1059.62~18.04.1",
            "linux-modules-extra-azure-edge": "5.4.0.1059.39"
        }
    ]
}

Ubuntu:18.04:LTS / linux-gkeop-5.4

Package

Name
linux-gkeop-5.4

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
5.4.0-1024.25~18.04.1

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "linux-headers-gkeop-5.4": "5.4.0.1024.25~18.04.25",
            "linux-image-gkeop-5.4": "5.4.0.1024.25~18.04.25",
            "linux-gkeop-5.4": "5.4.0.1024.25~18.04.25",
            "linux-tools-5.4.0-1024-gkeop": "5.4.0-1024.25~18.04.1",
            "linux-image-5.4.0-1024-gkeop": "5.4.0-1024.25~18.04.1",
            "linux-headers-5.4.0-1024-gkeop": "5.4.0-1024.25~18.04.1",
            "linux-cloud-tools-5.4.0-1024-gkeop": "5.4.0-1024.25~18.04.1",
            "linux-modules-extra-5.4.0-1024-gkeop": "5.4.0-1024.25~18.04.1",
            "linux-gkeop-5.4-tools-5.4.0-1024": "5.4.0-1024.25~18.04.1",
            "linux-modules-5.4.0-1024-gkeop": "5.4.0-1024.25~18.04.1",
            "linux-cloud-tools-gkeop-5.4": "5.4.0.1024.25~18.04.25",
            "linux-modules-extra-gkeop-5.4": "5.4.0.1024.25~18.04.25",
            "linux-gkeop-5.4-cloud-tools-5.4.0-1024": "5.4.0-1024.25~18.04.1",
            "linux-image-unsigned-5.4.0-1024-gkeop": "5.4.0-1024.25~18.04.1",
            "linux-gkeop-5.4-source-5.4.0": "5.4.0-1024.25~18.04.1",
            "linux-gkeop-5.4-headers-5.4.0-1024": "5.4.0-1024.25~18.04.1",
            "linux-tools-gkeop-5.4": "5.4.0.1024.25~18.04.25",
            "linux-buildinfo-5.4.0-1024-gkeop": "5.4.0-1024.25~18.04.1"
        }
    ]
}

Ubuntu:18.04:LTS / linux-hwe-5.4

Package

Name
linux-hwe-5.4

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
5.4.0-87.98~18.04.1

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "linux-headers-snapdragon-hwe-18.04-edge": "5.4.0.87.98~18.04.78",
            "linux-headers-oem": "5.4.0.87.98~18.04.78",
            "linux-image-snapdragon-hwe-18.04-edge": "5.4.0.87.98~18.04.78",
            "linux-modules-5.4.0-87-generic": "5.4.0-87.98~18.04.1",
            "linux-tools-virtual-hwe-18.04-edge": "5.4.0.87.98~18.04.78",
            "linux-lowlatency-hwe-18.04": "5.4.0.87.98~18.04.78",
            "linux-generic-hwe-18.04": "5.4.0.87.98~18.04.78",
            "linux-lowlatency-hwe-18.04-edge": "5.4.0.87.98~18.04.78",
            "linux-tools-generic-lpae-hwe-18.04": "5.4.0.87.98~18.04.78",
            "linux-snapdragon-hwe-18.04": "5.4.0.87.98~18.04.78",
            "linux-snapdragon-hwe-18.04-edge": "5.4.0.87.98~18.04.78",
            "linux-cloud-tools-5.4.0-87-lowlatency": "5.4.0-87.98~18.04.1",
            "linux-headers-generic-hwe-18.04": "5.4.0.87.98~18.04.78",
            "linux-hwe-5.4-tools-5.4.0-87": "5.4.0-87.98~18.04.1",
            "linux-generic-lpae-hwe-18.04-edge": "5.4.0.87.98~18.04.78",
            "linux-headers-5.4.0-87-generic-lpae": "5.4.0-87.98~18.04.1",
            "linux-tools-snapdragon-hwe-18.04-edge": "5.4.0.87.98~18.04.78",
            "linux-tools-5.4.0-87-generic-lpae": "5.4.0-87.98~18.04.1",
            "linux-cloud-tools-generic-hwe-18.04": "5.4.0.87.98~18.04.78",
            "linux-generic-lpae-hwe-18.04": "5.4.0.87.98~18.04.78",
            "linux-image-5.4.0-87-generic": "5.4.0-87.98~18.04.1",
            "linux-headers-lowlatency-hwe-18.04-edge": "5.4.0.87.98~18.04.78",
            "linux-oem": "5.4.0.87.98~18.04.78",
            "linux-modules-5.4.0-87-generic-lpae": "5.4.0-87.98~18.04.1",
            "linux-headers-5.4.0-87-lowlatency": "5.4.0-87.98~18.04.1",
            "linux-cloud-tools-lowlatency-hwe-18.04-edge": "5.4.0.87.98~18.04.78",
            "linux-hwe-5.4-cloud-tools-common": "5.4.0-87.98~18.04.1",
            "linux-image-generic-hwe-18.04-edge": "5.4.0.87.98~18.04.78",
            "linux-image-generic-lpae-hwe-18.04": "5.4.0.87.98~18.04.78",
            "linux-cloud-tools-lowlatency-hwe-18.04": "5.4.0.87.98~18.04.78",
            "linux-headers-lowlatency-hwe-18.04": "5.4.0.87.98~18.04.78",
            "linux-modules-extra-virtual-hwe-18.04": "5.4.0.87.98~18.04.78",
            "linux-tools-generic-hwe-18.04-edge": "5.4.0.87.98~18.04.78",
            "linux-headers-virtual-hwe-18.04-edge": "5.4.0.87.98~18.04.78",
            "linux-generic-hwe-18.04-edge": "5.4.0.87.98~18.04.78",
            "linux-cloud-tools-5.4.0-87-generic": "5.4.0-87.98~18.04.1",
            "linux-image-5.4.0-87-generic-lpae": "5.4.0-87.98~18.04.1",
            "linux-tools-lowlatency-hwe-18.04-edge": "5.4.0.87.98~18.04.78",
            "linux-headers-snapdragon-hwe-18.04": "5.4.0.87.98~18.04.78",
            "linux-buildinfo-5.4.0-87-generic-lpae": "5.4.0-87.98~18.04.1",
            "linux-headers-5.4.0-87-generic": "5.4.0-87.98~18.04.1",
            "linux-headers-oem-osp1": "5.4.0.87.98~18.04.78",
            "linux-headers-generic-hwe-18.04-edge": "5.4.0.87.98~18.04.78",
            "linux-image-lowlatency-hwe-18.04-edge": "5.4.0.87.98~18.04.78",
            "linux-hwe-5.4-source-5.4.0": "5.4.0-87.98~18.04.1",
            "linux-headers-generic-lpae-hwe-18.04": "5.4.0.87.98~18.04.78",
            "linux-image-virtual-hwe-18.04-edge": "5.4.0.87.98~18.04.78",
            "linux-cloud-tools-generic-hwe-18.04-edge": "5.4.0.87.98~18.04.78",
            "linux-image-lowlatency-hwe-18.04": "5.4.0.87.98~18.04.78",
            "linux-headers-virtual-hwe-18.04": "5.4.0.87.98~18.04.78",
            "linux-tools-oem-osp1": "5.4.0.87.98~18.04.78",
            "linux-modules-extra-virtual-hwe-18.04-edge": "5.4.0.87.98~18.04.78",
            "linux-oem-osp1": "5.4.0.87.98~18.04.78",
            "linux-hwe-5.4-headers-5.4.0-87": "5.4.0-87.98~18.04.1",
            "linux-tools-oem": "5.4.0.87.98~18.04.78",
            "linux-modules-extra-5.4.0-87-generic": "5.4.0-87.98~18.04.1",
            "linux-tools-generic-lpae-hwe-18.04-edge": "5.4.0.87.98~18.04.78",
            "linux-hwe-5.4-tools-common": "5.4.0-87.98~18.04.1",
            "linux-virtual-hwe-18.04": "5.4.0.87.98~18.04.78",
            "linux-image-oem": "5.4.0.87.98~18.04.78",
            "linux-cloud-tools-virtual-hwe-18.04-edge": "5.4.0.87.98~18.04.78",
            "linux-image-5.4.0-87-lowlatency": "5.4.0-87.98~18.04.1",
            "linux-image-unsigned-5.4.0-87-generic": "5.4.0-87.98~18.04.1",
            "linux-tools-5.4.0-87-generic": "5.4.0-87.98~18.04.1",
            "linux-modules-5.4.0-87-lowlatency": "5.4.0-87.98~18.04.1",
            "linux-virtual-hwe-18.04-edge": "5.4.0.87.98~18.04.78",
            "linux-image-generic-lpae-hwe-18.04-edge": "5.4.0.87.98~18.04.78",
            "linux-image-generic-hwe-18.04": "5.4.0.87.98~18.04.78",
            "linux-cloud-tools-virtual-hwe-18.04": "5.4.0.87.98~18.04.78",
            "linux-image-virtual-hwe-18.04": "5.4.0.87.98~18.04.78",
            "linux-image-oem-osp1": "5.4.0.87.98~18.04.78",
            "linux-image-extra-virtual-hwe-18.04-edge": "5.4.0.87.98~18.04.78",
            "linux-buildinfo-5.4.0-87-generic": "5.4.0-87.98~18.04.1",
            "linux-buildinfo-5.4.0-87-lowlatency": "5.4.0-87.98~18.04.1",
            "linux-image-snapdragon-hwe-18.04": "5.4.0.87.98~18.04.78",
            "linux-headers-generic-lpae-hwe-18.04-edge": "5.4.0.87.98~18.04.78",
            "linux-tools-virtual-hwe-18.04": "5.4.0.87.98~18.04.78",
            "linux-tools-5.4.0-87-lowlatency": "5.4.0-87.98~18.04.1",
            "linux-tools-snapdragon-hwe-18.04": "5.4.0.87.98~18.04.78",
            "linux-tools-generic-hwe-18.04": "5.4.0.87.98~18.04.78",
            "linux-hwe-5.4-cloud-tools-5.4.0-87": "5.4.0-87.98~18.04.1",
            "linux-image-unsigned-5.4.0-87-lowlatency": "5.4.0-87.98~18.04.1",
            "linux-tools-lowlatency-hwe-18.04": "5.4.0.87.98~18.04.78",
            "linux-image-extra-virtual-hwe-18.04": "5.4.0.87.98~18.04.78"
        }
    ]
}

Ubuntu:18.04:LTS / linux-oracle-5.4

Package

Name
linux-oracle-5.4

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
5.4.0-1055.59~18.04.1

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "linux-modules-extra-5.4.0-1055-oracle": "5.4.0-1055.59~18.04.1",
            "linux-image-unsigned-5.4.0-1055-oracle": "5.4.0-1055.59~18.04.1",
            "linux-modules-extra-oracle-edge": "5.4.0.1055.59~18.04.35",
            "linux-headers-oracle-edge": "5.4.0.1055.59~18.04.35",
            "linux-oracle-5.4-tools-5.4.0-1055": "5.4.0-1055.59~18.04.1",
            "linux-image-5.4.0-1055-oracle": "5.4.0-1055.59~18.04.1",
            "linux-signed-oracle-edge": "5.4.0.1055.59~18.04.35",
            "linux-modules-5.4.0-1055-oracle": "5.4.0-1055.59~18.04.1",
            "linux-headers-5.4.0-1055-oracle": "5.4.0-1055.59~18.04.1",
            "linux-buildinfo-5.4.0-1055-oracle": "5.4.0-1055.59~18.04.1",
            "linux-tools-oracle-edge": "5.4.0.1055.59~18.04.35",
            "linux-signed-image-oracle": "5.4.0.1055.59~18.04.35",
            "linux-signed-oracle": "5.4.0.1055.59~18.04.35",
            "linux-oracle-5.4-headers-5.4.0-1055": "5.4.0-1055.59~18.04.1",
            "linux-oracle": "5.4.0.1055.59~18.04.35",
            "linux-headers-oracle": "5.4.0.1055.59~18.04.35",
            "linux-oracle-edge": "5.4.0.1055.59~18.04.35",
            "linux-image-oracle-edge": "5.4.0.1055.59~18.04.35",
            "linux-signed-image-oracle-edge": "5.4.0.1055.59~18.04.35",
            "linux-tools-5.4.0-1055-oracle": "5.4.0-1055.59~18.04.1",
            "linux-tools-oracle": "5.4.0.1055.59~18.04.35",
            "linux-image-oracle": "5.4.0.1055.59~18.04.35",
            "linux-modules-extra-oracle": "5.4.0.1055.59~18.04.35"
        }
    ]
}

Ubuntu:18.04:LTS / linux-aws-5.4

Package

Name
linux-aws-5.4

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
5.4.0-1057.60~18.04.1

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "linux-modules-5.4.0-1057-aws": "5.4.0-1057.60~18.04.1",
            "linux-aws-5.4-cloud-tools-5.4.0-1057": "5.4.0-1057.60~18.04.1",
            "linux-image-aws-edge": "5.4.0.1057.40",
            "linux-tools-5.4.0-1057-aws": "5.4.0-1057.60~18.04.1",
            "linux-headers-aws": "5.4.0.1057.40",
            "linux-cloud-tools-5.4.0-1057-aws": "5.4.0-1057.60~18.04.1",
            "linux-modules-extra-5.4.0-1057-aws": "5.4.0-1057.60~18.04.1",
            "linux-image-5.4.0-1057-aws": "5.4.0-1057.60~18.04.1",
            "linux-aws": "5.4.0.1057.40",
            "linux-image-aws": "5.4.0.1057.40",
            "linux-buildinfo-5.4.0-1057-aws": "5.4.0-1057.60~18.04.1",
            "linux-aws-5.4-tools-5.4.0-1057": "5.4.0-1057.60~18.04.1",
            "linux-headers-aws-edge": "5.4.0.1057.40",
            "linux-modules-extra-aws": "5.4.0.1057.40",
            "linux-aws-5.4-headers-5.4.0-1057": "5.4.0-1057.60~18.04.1",
            "linux-modules-extra-aws-edge": "5.4.0.1057.40",
            "linux-tools-aws-edge": "5.4.0.1057.40",
            "linux-headers-5.4.0-1057-aws": "5.4.0-1057.60~18.04.1",
            "linux-aws-edge": "5.4.0.1057.40",
            "linux-tools-aws": "5.4.0.1057.40"
        }
    ]
}

Ubuntu:20.04:LTS / linux-gkeop

Package

Name
linux-gkeop

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
5.4.0-1024.25

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "linux-headers-gkeop-5.4": "5.4.0.1024.27",
            "linux-gkeop-headers-5.4.0-1024": "5.4.0-1024.25",
            "linux-gkeop-5.4": "5.4.0.1024.27",
            "linux-image-gkeop-5.4": "5.4.0.1024.27",
            "linux-headers-5.4.0-1024-gkeop": "5.4.0-1024.25",
            "linux-image-5.4.0-1024-gkeop": "5.4.0-1024.25",
            "linux-gkeop": "5.4.0.1024.27",
            "linux-tools-gkeop": "5.4.0.1024.27",
            "linux-cloud-tools-gkeop": "5.4.0.1024.27",
            "linux-gkeop-cloud-tools-5.4.0-1024": "5.4.0-1024.25",
            "linux-modules-extra-gkeop": "5.4.0.1024.27",
            "linux-tools-5.4.0-1024-gkeop": "5.4.0-1024.25",
            "linux-cloud-tools-5.4.0-1024-gkeop": "5.4.0-1024.25",
            "linux-image-gkeop": "5.4.0.1024.27",
            "linux-modules-extra-5.4.0-1024-gkeop": "5.4.0-1024.25",
            "linux-modules-5.4.0-1024-gkeop": "5.4.0-1024.25",
            "linux-cloud-tools-gkeop-5.4": "5.4.0.1024.27",
            "linux-gkeop-source-5.4.0": "5.4.0-1024.25",
            "linux-modules-extra-gkeop-5.4": "5.4.0.1024.27",
            "linux-image-unsigned-5.4.0-1024-gkeop": "5.4.0-1024.25",
            "linux-gkeop-tools-5.4.0-1024": "5.4.0-1024.25",
            "linux-tools-gkeop-5.4": "5.4.0.1024.27",
            "linux-buildinfo-5.4.0-1024-gkeop": "5.4.0-1024.25",
            "linux-headers-gkeop": "5.4.0.1024.27"
        }
    ]
}

Ubuntu:20.04:LTS / linux-azure

Package

Name
linux-azure

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
5.4.0-1059.62

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "linux-tools-azure-lts-20.04": "5.4.0.1059.57",
            "linux-modules-extra-azure-lts-20.04": "5.4.0.1059.57",
            "linux-azure-cloud-tools-5.4.0-1059": "5.4.0-1059.62",
            "linux-buildinfo-5.4.0-1059-azure": "5.4.0-1059.62",
            "linux-cloud-tools-azure-lts-20.04": "5.4.0.1059.57",
            "linux-image-azure-lts-20.04": "5.4.0.1059.57",
            "linux-headers-azure-lts-20.04": "5.4.0.1059.57",
            "linux-modules-extra-5.4.0-1059-azure": "5.4.0-1059.62",
            "linux-azure-tools-5.4.0-1059": "5.4.0-1059.62",
            "linux-image-unsigned-5.4.0-1059-azure": "5.4.0-1059.62",
            "linux-tools-5.4.0-1059-azure": "5.4.0-1059.62",
            "linux-azure-lts-20.04": "5.4.0.1059.57",
            "linux-headers-5.4.0-1059-azure": "5.4.0-1059.62",
            "linux-modules-5.4.0-1059-azure": "5.4.0-1059.62",
            "linux-image-5.4.0-1059-azure": "5.4.0-1059.62",
            "linux-azure-headers-5.4.0-1059": "5.4.0-1059.62",
            "linux-cloud-tools-5.4.0-1059-azure": "5.4.0-1059.62"
        }
    ]
}

Ubuntu:20.04:LTS / linux-kvm

Package

Name
linux-kvm

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
5.4.0-1047.49

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "linux-headers-kvm": "5.4.0.1047.46",
            "linux-buildinfo-5.4.0-1047-kvm": "5.4.0-1047.49",
            "linux-kvm": "5.4.0.1047.46",
            "linux-image-5.4.0-1047-kvm": "5.4.0-1047.49",
            "linux-modules-5.4.0-1047-kvm": "5.4.0-1047.49",
            "linux-tools-kvm": "5.4.0.1047.46",
            "linux-kvm-tools-5.4.0-1047": "5.4.0-1047.49",
            "linux-headers-5.4.0-1047-kvm": "5.4.0-1047.49",
            "linux-kvm-headers-5.4.0-1047": "5.4.0-1047.49",
            "linux-image-unsigned-5.4.0-1047-kvm": "5.4.0-1047.49",
            "linux-tools-5.4.0-1047-kvm": "5.4.0-1047.49",
            "linux-image-kvm": "5.4.0.1047.46"
        }
    ]
}

Ubuntu:20.04:LTS / linux-aws

Package

Name
linux-aws

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
5.4.0-1057.60

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "linux-tools-5.4.0-1057-aws": "5.4.0-1057.60",
            "linux-modules-extra-aws-lts-20.04": "5.4.0.1057.60",
            "linux-cloud-tools-5.4.0-1057-aws": "5.4.0-1057.60",
            "linux-aws-lts-20.04": "5.4.0.1057.60",
            "linux-tools-aws-lts-20.04": "5.4.0.1057.60",
            "linux-image-5.4.0-1057-aws": "5.4.0-1057.60",
            "linux-aws-cloud-tools-5.4.0-1057": "5.4.0-1057.60",
            "linux-buildinfo-5.4.0-1057-aws": "5.4.0-1057.60",
            "linux-modules-extra-5.4.0-1057-aws": "5.4.0-1057.60",
            "linux-headers-aws-lts-20.04": "5.4.0.1057.60",
            "linux-aws-tools-5.4.0-1057": "5.4.0-1057.60",
            "linux-aws-headers-5.4.0-1057": "5.4.0-1057.60",
            "linux-headers-5.4.0-1057-aws": "5.4.0-1057.60",
            "linux-image-aws-lts-20.04": "5.4.0.1057.60",
            "linux-modules-5.4.0-1057-aws": "5.4.0-1057.60"
        }
    ]
}

Ubuntu:20.04:LTS / linux-gke

Package

Name
linux-gke

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
5.4.0-1053.56

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "linux-image-gke": "5.4.0.1053.63",
            "linux-modules-5.4.0-1053-gke": "5.4.0-1053.56",
            "linux-tools-5.4.0-1053-gke": "5.4.0-1053.56",
            "linux-buildinfo-5.4.0-1053-gke": "5.4.0-1053.56",
            "linux-headers-gke": "5.4.0.1053.63",
            "linux-gke-5.4": "5.4.0.1053.63",
            "linux-tools-gke-5.4": "5.4.0.1053.63",
            "linux-gke-headers-5.4.0-1053": "5.4.0-1053.56",
            "linux-headers-5.4.0-1053-gke": "5.4.0-1053.56",
            "linux-gke": "5.4.0.1053.63",
            "linux-image-unsigned-5.4.0-1053-gke": "5.4.0-1053.56",
            "linux-headers-gke-5.4": "5.4.0.1053.63",
            "linux-image-5.4.0-1053-gke": "5.4.0-1053.56",
            "linux-modules-extra-5.4.0-1053-gke": "5.4.0-1053.56",
            "linux-modules-extra-gke-5.4": "5.4.0.1053.63",
            "linux-modules-extra-gke": "5.4.0.1053.63",
            "linux-tools-gke": "5.4.0.1053.63",
            "linux-image-gke-5.4": "5.4.0.1053.63",
            "linux-gke-tools-5.4.0-1053": "5.4.0-1053.56"
        }
    ]
}

Ubuntu:20.04:LTS / linux-oracle

Package

Name
linux-oracle

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
5.4.0-1055.59

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "linux-modules-extra-5.4.0-1055-oracle": "5.4.0-1055.59",
            "linux-image-unsigned-5.4.0-1055-oracle": "5.4.0-1055.59",
            "linux-image-oracle-lts-20.04": "5.4.0.1055.55",
            "linux-oracle-lts-20.04": "5.4.0.1055.55",
            "linux-headers-oracle-lts-20.04": "5.4.0.1055.55",
            "linux-image-5.4.0-1055-oracle": "5.4.0-1055.59",
            "linux-oracle-headers-5.4.0-1055": "5.4.0-1055.59",
            "linux-modules-5.4.0-1055-oracle": "5.4.0-1055.59",
            "linux-headers-5.4.0-1055-oracle": "5.4.0-1055.59",
            "linux-oracle-tools-5.4.0-1055": "5.4.0-1055.59",
            "linux-tools-5.4.0-1055-oracle": "5.4.0-1055.59",
            "linux-tools-oracle-lts-20.04": "5.4.0.1055.55",
            "linux-buildinfo-5.4.0-1055-oracle": "5.4.0-1055.59"
        }
    ]
}

Ubuntu:20.04:LTS / linux

Package

Name
linux

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
5.4.0-88.99

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "linux-generic-hwe-18.04": "5.4.0.88.92",
            "linux-tools-5.4.0-88": "5.4.0-88.99",
            "linux-tools-virtual-hwe-18.04-edge": "5.4.0.88.92",
            "linux-headers-oem": "5.4.0.88.92",
            "linux-lowlatency-hwe-18.04": "5.4.0.88.92",
            "linux-cloud-tools-virtual": "5.4.0.88.92",
            "linux-image-5.4.0-88-generic-lpae": "5.4.0-88.99",
            "linux-lowlatency-hwe-18.04-edge": "5.4.0.88.92",
            "linux-image-5.4.0-88-lowlatency": "5.4.0-88.99",
            "linux-cloud-tools-5.4.0-88-generic": "5.4.0-88.99",
            "linux-generic-lpae-hwe-18.04": "5.4.0.88.92",
            "linux-headers-generic-hwe-18.04": "5.4.0.88.92",
            "linux-generic-lpae-hwe-18.04-edge": "5.4.0.88.92",
            "linux-tools-virtual": "5.4.0.88.92",
            "linux-oem-osp1-tools-host": "5.4.0.88.92",
            "linux-cloud-tools-generic-hwe-18.04": "5.4.0.88.92",
            "linux-modules-5.4.0-88-generic-lpae": "5.4.0-88.99",
            "linux-headers-lowlatency-hwe-18.04-edge": "5.4.0.88.92",
            "linux-source": "5.4.0.88.92",
            "linux-image-extra-virtual": "5.4.0.88.92",
            "linux-oem": "5.4.0.88.92",
            "linux-headers-5.4.0-88-generic-lpae": "5.4.0-88.99",
            "linux-cloud-tools-generic": "5.4.0.88.92",
            "linux-image-virtual": "5.4.0.88.92",
            "linux-modules-extra-5.4.0-88-generic": "5.4.0-88.99",
            "linux-buildinfo-5.4.0-88-lowlatency": "5.4.0-88.99",
            "linux-cloud-tools-5.4.0-88": "5.4.0-88.99",
            "linux-cloud-tools-5.4.0-88-lowlatency": "5.4.0-88.99",
            "linux-generic-lpae": "5.4.0.88.92",
            "linux-tools-generic": "5.4.0.88.92",
            "linux-virtual": "5.4.0.88.92",
            "linux-cloud-tools-lowlatency-hwe-18.04-edge": "5.4.0.88.92",
            "linux-image-unsigned-5.4.0-88-generic": "5.4.0-88.99",
            "linux-tools-generic-lpae-hwe-18.04": "5.4.0.88.92",
            "linux-buildinfo-5.4.0-88-generic": "5.4.0-88.99",
            "linux-cloud-tools-lowlatency": "5.4.0.88.92",
            "linux-modules-5.4.0-88-generic": "5.4.0-88.99",
            "linux-image-generic-hwe-18.04-edge": "5.4.0.88.92",
            "linux-image-generic-lpae-hwe-18.04": "5.4.0.88.92",
            "linux-crashdump": "5.4.0.88.92",
            "linux-cloud-tools-lowlatency-hwe-18.04": "5.4.0.88.92",
            "linux-generic": "5.4.0.88.92",
            "linux-headers-lowlatency-hwe-18.04": "5.4.0.88.92",
            "linux-headers-virtual-hwe-18.04-edge": "5.4.0.88.92",
            "linux-tools-generic-hwe-18.04-edge": "5.4.0.88.92",
            "linux-generic-hwe-18.04-edge": "5.4.0.88.92",
            "linux-headers-generic-lpae": "5.4.0.88.92",
            "linux-tools-lowlatency-hwe-18.04-edge": "5.4.0.88.92",
            "linux-image-generic-lpae": "5.4.0.88.92",
            "linux-image-unsigned-5.4.0-88-lowlatency": "5.4.0-88.99",
            "linux-tools-lowlatency": "5.4.0.88.92",
            "linux-headers-oem-osp1": "5.4.0.88.92",
            "linux-cloud-tools-common": "5.4.0-88.99",
            "linux-headers-5.4.0-88-generic": "5.4.0-88.99",
            "linux-image-lowlatency-hwe-18.04-edge": "5.4.0.88.92",
            "linux-headers-generic-lpae-hwe-18.04": "5.4.0.88.92",
            "linux-libc-dev": "5.4.0-88.99",
            "linux-source-5.4.0": "5.4.0-88.99",
            "linux-cloud-tools-generic-hwe-18.04-edge": "5.4.0.88.92",
            "linux-buildinfo-5.4.0-88-generic-lpae": "5.4.0-88.99",
            "linux-doc": "5.4.0-88.99",
            "linux-headers-virtual-hwe-18.04": "5.4.0.88.92",
            "linux-image-virtual-hwe-18.04-edge": "5.4.0.88.92",
            "linux-tools-oem-osp1": "5.4.0.88.92",
            "linux-oem-osp1": "5.4.0.88.92",
            "linux-image-lowlatency-hwe-18.04": "5.4.0.88.92",
            "linux-headers-generic-hwe-18.04-edge": "5.4.0.88.92",
            "linux-modules-5.4.0-88-lowlatency": "5.4.0-88.99",
            "linux-tools-oem": "5.4.0.88.92",
            "linux-headers-lowlatency": "5.4.0.88.92",
            "linux-oem-tools-host": "5.4.0.88.92",
            "linux-tools-generic-lpae-hwe-18.04-edge": "5.4.0.88.92",
            "linux-headers-virtual": "5.4.0.88.92",
            "linux-image-lowlatency": "5.4.0.88.92",
            "linux-virtual-hwe-18.04": "5.4.0.88.92",
            "linux-image-oem": "5.4.0.88.92",
            "linux-cloud-tools-virtual-hwe-18.04-edge": "5.4.0.88.92",
            "linux-headers-generic": "5.4.0.88.92",
            "linux-tools-host": "5.4.0-88.99",
            "linux-image-generic-lpae-hwe-18.04-edge": "5.4.0.88.92",
            "linux-tools-5.4.0-88-generic-lpae": "5.4.0-88.99",
            "linux-headers-5.4.0-88": "5.4.0-88.99",
            "linux-virtual-hwe-18.04-edge": "5.4.0.88.92",
            "linux-image-generic-hwe-18.04": "5.4.0.88.92",
            "linux-image-5.4.0-88-generic": "5.4.0-88.99",
            "linux-cloud-tools-virtual-hwe-18.04": "5.4.0.88.92",
            "linux-image-virtual-hwe-18.04": "5.4.0.88.92",
            "linux-tools-generic-lpae": "5.4.0.88.92",
            "linux-image-extra-virtual-hwe-18.04-edge": "5.4.0.88.92",
            "linux-image-oem-osp1": "5.4.0.88.92",
            "linux-headers-generic-lpae-hwe-18.04-edge": "5.4.0.88.92",
            "linux-tools-virtual-hwe-18.04": "5.4.0.88.92",
            "linux-tools-5.4.0-88-lowlatency": "5.4.0-88.99",
            "linux-headers-5.4.0-88-lowlatency": "5.4.0-88.99",
            "linux-tools-common": "5.4.0-88.99",
            "linux-tools-generic-hwe-18.04": "5.4.0.88.92",
            "linux-image-generic": "5.4.0.88.92",
            "linux-lowlatency": "5.4.0.88.92",
            "linux-tools-5.4.0-88-generic": "5.4.0-88.99",
            "linux-tools-lowlatency-hwe-18.04": "5.4.0.88.92",
            "linux-image-extra-virtual-hwe-18.04": "5.4.0.88.92"
        }
    ]
}

Ubuntu:20.04:LTS / linux-gcp

Package

Name
linux-gcp

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
5.4.0-1053.57

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "linux-image-5.4.0-1053-gcp": "5.4.0-1053.57",
            "linux-gcp-headers-5.4.0-1053": "5.4.0-1053.57",
            "linux-modules-extra-gcp-lts-20.04": "5.4.0.1053.63",
            "linux-image-gcp-lts-20.04": "5.4.0.1053.63",
            "linux-headers-5.4.0-1053-gcp": "5.4.0-1053.57",
            "linux-gcp-tools-5.4.0-1053": "5.4.0-1053.57",
            "linux-image-unsigned-5.4.0-1053-gcp": "5.4.0-1053.57",
            "linux-tools-gcp-lts-20.04": "5.4.0.1053.63",
            "linux-tools-5.4.0-1053-gcp": "5.4.0-1053.57",
            "linux-modules-5.4.0-1053-gcp": "5.4.0-1053.57",
            "linux-buildinfo-5.4.0-1053-gcp": "5.4.0-1053.57",
            "linux-headers-gcp-lts-20.04": "5.4.0.1053.63",
            "linux-modules-extra-5.4.0-1053-gcp": "5.4.0-1053.57",
            "linux-gcp-lts-20.04": "5.4.0.1053.63"
        }
    ]
}