USN-5131-1

See a problem?
Source
https://ubuntu.com/security/notices/USN-5131-1
Import Source
https://github.com/canonical/ubuntu-security-notices/blob/main/osv/USN-5131-1.json
JSON Data
https://api.osv.dev/v1/vulns/USN-5131-1
Related
  • CVE-2021-38503
  • CVE-2021-38504
  • CVE-2021-38506
  • CVE-2021-38507
  • CVE-2021-38508
  • CVE-2021-38509
Published
2021-11-03T20:09:06.136374Z
Modified
2021-11-03T20:09:06.136374Z
Summary
firefox vulnerabilities
Details

Multiple security issues were discovered in Firefox. If a user were tricked into opening a specially crafted website, an attacker could potentially exploit these to cause a denial of service, bypass security restrictions, spoof the browser UI, confuse the user, conduct phishing attacks, or execute arbitrary code. (CVE-2021-38503, CVE-2021-38504, CVE-2021-38506, CVE-2021-38507, CVE-2021-38508, CVE-2021-38509)

It was discovered that the 'Copy Image Link' context menu action would copy the final image URL after redirects. If a user were tricked into copying and pasting a link for an embedded image that triggered authentication flows back to the page, an attacker could potentially exploit this to steal authentication tokens.

References

Affected packages

Ubuntu:18.04:LTS / firefox

Package

Name
firefox

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
94.0+build3-0ubuntu0.18.04.1

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "firefox-locale-sl": "94.0+build3-0ubuntu0.18.04.1",
            "firefox-locale-nl": "94.0+build3-0ubuntu0.18.04.1",
            "firefox-locale-kn": "94.0+build3-0ubuntu0.18.04.1",
            "firefox-locale-gl": "94.0+build3-0ubuntu0.18.04.1",
            "firefox-locale-fy": "94.0+build3-0ubuntu0.18.04.1",
            "firefox-locale-kk": "94.0+build3-0ubuntu0.18.04.1",
            "firefox-locale-km": "94.0+build3-0ubuntu0.18.04.1",
            "firefox-locale-or": "94.0+build3-0ubuntu0.18.04.1",
            "firefox-locale-az": "94.0+build3-0ubuntu0.18.04.1",
            "firefox-locale-lt": "94.0+build3-0ubuntu0.18.04.1",
            "firefox-locale-hy": "94.0+build3-0ubuntu0.18.04.1",
            "firefox-locale-eo": "94.0+build3-0ubuntu0.18.04.1",
            "firefox-locale-sv": "94.0+build3-0ubuntu0.18.04.1",
            "firefox-locale-uk": "94.0+build3-0ubuntu0.18.04.1",
            "firefox-locale-sr": "94.0+build3-0ubuntu0.18.04.1",
            "firefox-locale-is": "94.0+build3-0ubuntu0.18.04.1",
            "firefox-locale-ca": "94.0+build3-0ubuntu0.18.04.1",
            "firefox-locale-ne": "94.0+build3-0ubuntu0.18.04.1",
            "firefox-locale-ga": "94.0+build3-0ubuntu0.18.04.1",
            "firefox-locale-ja": "94.0+build3-0ubuntu0.18.04.1",
            "firefox-locale-it": "94.0+build3-0ubuntu0.18.04.1",
            "firefox-locale-lg": "94.0+build3-0ubuntu0.18.04.1",
            "firefox-locale-ms": "94.0+build3-0ubuntu0.18.04.1",
            "firefox-locale-zh-hans": "94.0+build3-0ubuntu0.18.04.1",
            "firefox-locale-ia": "94.0+build3-0ubuntu0.18.04.1",
            "firefox-locale-ko": "94.0+build3-0ubuntu0.18.04.1",
            "firefox-locale-hr": "94.0+build3-0ubuntu0.18.04.1",
            "firefox-locale-mai": "94.0+build3-0ubuntu0.18.04.1",
            "firefox-locale-nb": "94.0+build3-0ubuntu0.18.04.1",
            "firefox-mozsymbols": "94.0+build3-0ubuntu0.18.04.1",
            "firefox-locale-vi": "94.0+build3-0ubuntu0.18.04.1",
            "firefox-dev": "94.0+build3-0ubuntu0.18.04.1",
            "firefox-locale-he": "94.0+build3-0ubuntu0.18.04.1",
            "firefox-locale-sw": "94.0+build3-0ubuntu0.18.04.1",
            "firefox-locale-el": "94.0+build3-0ubuntu0.18.04.1",
            "firefox-locale-oc": "94.0+build3-0ubuntu0.18.04.1",
            "firefox-locale-xh": "94.0+build3-0ubuntu0.18.04.1",
            "firefox-locale-nn": "94.0+build3-0ubuntu0.18.04.1",
            "firefox-geckodriver": "94.0+build3-0ubuntu0.18.04.1",
            "firefox-locale-ar": "94.0+build3-0ubuntu0.18.04.1",
            "firefox-locale-cs": "94.0+build3-0ubuntu0.18.04.1",
            "firefox-locale-gn": "94.0+build3-0ubuntu0.18.04.1",
            "firefox-locale-hsb": "94.0+build3-0ubuntu0.18.04.1",
            "firefox-locale-zu": "94.0+build3-0ubuntu0.18.04.1",
            "firefox-locale-my": "94.0+build3-0ubuntu0.18.04.1",
            "firefox-locale-ro": "94.0+build3-0ubuntu0.18.04.1",
            "firefox-locale-csb": "94.0+build3-0ubuntu0.18.04.1",
            "firefox-locale-nso": "94.0+build3-0ubuntu0.18.04.1",
            "firefox-locale-af": "94.0+build3-0ubuntu0.18.04.1",
            "firefox-locale-sk": "94.0+build3-0ubuntu0.18.04.1",
            "firefox-locale-szl": "94.0+build3-0ubuntu0.18.04.1",
            "firefox-locale-si": "94.0+build3-0ubuntu0.18.04.1",
            "firefox": "94.0+build3-0ubuntu0.18.04.1",
            "firefox-locale-cy": "94.0+build3-0ubuntu0.18.04.1",
            "firefox-locale-fa": "94.0+build3-0ubuntu0.18.04.1",
            "firefox-locale-cak": "94.0+build3-0ubuntu0.18.04.1",
            "firefox-locale-sq": "94.0+build3-0ubuntu0.18.04.1",
            "firefox-locale-en": "94.0+build3-0ubuntu0.18.04.1",
            "firefox-locale-tr": "94.0+build3-0ubuntu0.18.04.1",
            "firefox-locale-br": "94.0+build3-0ubuntu0.18.04.1",
            "firefox-locale-et": "94.0+build3-0ubuntu0.18.04.1",
            "firefox-locale-ast": "94.0+build3-0ubuntu0.18.04.1",
            "firefox-locale-th": "94.0+build3-0ubuntu0.18.04.1",
            "firefox-locale-da": "94.0+build3-0ubuntu0.18.04.1",
            "firefox-locale-fi": "94.0+build3-0ubuntu0.18.04.1",
            "firefox-locale-ku": "94.0+build3-0ubuntu0.18.04.1",
            "firefox-locale-mn": "94.0+build3-0ubuntu0.18.04.1",
            "firefox-locale-ru": "94.0+build3-0ubuntu0.18.04.1",
            "firefox-locale-mk": "94.0+build3-0ubuntu0.18.04.1",
            "firefox-locale-bg": "94.0+build3-0ubuntu0.18.04.1",
            "firefox-locale-hu": "94.0+build3-0ubuntu0.18.04.1",
            "firefox-locale-gu": "94.0+build3-0ubuntu0.18.04.1",
            "firefox-locale-bn": "94.0+build3-0ubuntu0.18.04.1",
            "firefox-locale-kab": "94.0+build3-0ubuntu0.18.04.1",
            "firefox-locale-ml": "94.0+build3-0ubuntu0.18.04.1",
            "firefox-locale-an": "94.0+build3-0ubuntu0.18.04.1",
            "firefox-locale-be": "94.0+build3-0ubuntu0.18.04.1",
            "firefox-locale-eu": "94.0+build3-0ubuntu0.18.04.1",
            "firefox-locale-fr": "94.0+build3-0ubuntu0.18.04.1",
            "firefox-locale-pa": "94.0+build3-0ubuntu0.18.04.1",
            "firefox-locale-as": "94.0+build3-0ubuntu0.18.04.1",
            "firefox-locale-id": "94.0+build3-0ubuntu0.18.04.1",
            "firefox-locale-pl": "94.0+build3-0ubuntu0.18.04.1",
            "firefox-locale-gd": "94.0+build3-0ubuntu0.18.04.1",
            "firefox-locale-te": "94.0+build3-0ubuntu0.18.04.1",
            "firefox-locale-lv": "94.0+build3-0ubuntu0.18.04.1",
            "firefox-locale-ka": "94.0+build3-0ubuntu0.18.04.1",
            "firefox-locale-ta": "94.0+build3-0ubuntu0.18.04.1",
            "firefox-locale-bs": "94.0+build3-0ubuntu0.18.04.1",
            "firefox-locale-uz": "94.0+build3-0ubuntu0.18.04.1",
            "firefox-locale-hi": "94.0+build3-0ubuntu0.18.04.1",
            "firefox-locale-zh-hant": "94.0+build3-0ubuntu0.18.04.1",
            "firefox-locale-es": "94.0+build3-0ubuntu0.18.04.1",
            "firefox-locale-ur": "94.0+build3-0ubuntu0.18.04.1",
            "firefox-locale-mr": "94.0+build3-0ubuntu0.18.04.1",
            "firefox-locale-pt": "94.0+build3-0ubuntu0.18.04.1",
            "firefox-locale-de": "94.0+build3-0ubuntu0.18.04.1"
        }
    ]
}

Ubuntu:20.04:LTS / firefox

Package

Name
firefox

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
94.0+build3-0ubuntu0.20.04.1

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "firefox-locale-sl": "94.0+build3-0ubuntu0.20.04.1",
            "firefox-locale-nl": "94.0+build3-0ubuntu0.20.04.1",
            "firefox-locale-kn": "94.0+build3-0ubuntu0.20.04.1",
            "firefox-locale-gl": "94.0+build3-0ubuntu0.20.04.1",
            "firefox-locale-fy": "94.0+build3-0ubuntu0.20.04.1",
            "firefox-locale-kk": "94.0+build3-0ubuntu0.20.04.1",
            "firefox-locale-km": "94.0+build3-0ubuntu0.20.04.1",
            "firefox-locale-or": "94.0+build3-0ubuntu0.20.04.1",
            "firefox-locale-az": "94.0+build3-0ubuntu0.20.04.1",
            "firefox-locale-lt": "94.0+build3-0ubuntu0.20.04.1",
            "firefox-locale-hy": "94.0+build3-0ubuntu0.20.04.1",
            "firefox-locale-eo": "94.0+build3-0ubuntu0.20.04.1",
            "firefox-locale-sv": "94.0+build3-0ubuntu0.20.04.1",
            "firefox-locale-uk": "94.0+build3-0ubuntu0.20.04.1",
            "firefox-locale-sr": "94.0+build3-0ubuntu0.20.04.1",
            "firefox-locale-is": "94.0+build3-0ubuntu0.20.04.1",
            "firefox-locale-ca": "94.0+build3-0ubuntu0.20.04.1",
            "firefox-locale-ne": "94.0+build3-0ubuntu0.20.04.1",
            "firefox-locale-ga": "94.0+build3-0ubuntu0.20.04.1",
            "firefox-locale-ja": "94.0+build3-0ubuntu0.20.04.1",
            "firefox-locale-it": "94.0+build3-0ubuntu0.20.04.1",
            "firefox-locale-lg": "94.0+build3-0ubuntu0.20.04.1",
            "firefox-locale-ms": "94.0+build3-0ubuntu0.20.04.1",
            "firefox-locale-zh-hans": "94.0+build3-0ubuntu0.20.04.1",
            "firefox-locale-ia": "94.0+build3-0ubuntu0.20.04.1",
            "firefox-locale-ko": "94.0+build3-0ubuntu0.20.04.1",
            "firefox-locale-hr": "94.0+build3-0ubuntu0.20.04.1",
            "firefox-locale-mai": "94.0+build3-0ubuntu0.20.04.1",
            "firefox-locale-nb": "94.0+build3-0ubuntu0.20.04.1",
            "firefox-mozsymbols": "94.0+build3-0ubuntu0.20.04.1",
            "firefox-locale-vi": "94.0+build3-0ubuntu0.20.04.1",
            "firefox-dev": "94.0+build3-0ubuntu0.20.04.1",
            "firefox-locale-he": "94.0+build3-0ubuntu0.20.04.1",
            "firefox-locale-sw": "94.0+build3-0ubuntu0.20.04.1",
            "firefox-locale-el": "94.0+build3-0ubuntu0.20.04.1",
            "firefox-locale-oc": "94.0+build3-0ubuntu0.20.04.1",
            "firefox-locale-xh": "94.0+build3-0ubuntu0.20.04.1",
            "firefox-locale-nn": "94.0+build3-0ubuntu0.20.04.1",
            "firefox-geckodriver": "94.0+build3-0ubuntu0.20.04.1",
            "firefox-locale-ar": "94.0+build3-0ubuntu0.20.04.1",
            "firefox-locale-cs": "94.0+build3-0ubuntu0.20.04.1",
            "firefox-locale-gn": "94.0+build3-0ubuntu0.20.04.1",
            "firefox-locale-hsb": "94.0+build3-0ubuntu0.20.04.1",
            "firefox-locale-zu": "94.0+build3-0ubuntu0.20.04.1",
            "firefox-locale-my": "94.0+build3-0ubuntu0.20.04.1",
            "firefox-locale-ro": "94.0+build3-0ubuntu0.20.04.1",
            "firefox-locale-csb": "94.0+build3-0ubuntu0.20.04.1",
            "firefox-locale-nso": "94.0+build3-0ubuntu0.20.04.1",
            "firefox-locale-af": "94.0+build3-0ubuntu0.20.04.1",
            "firefox-locale-sk": "94.0+build3-0ubuntu0.20.04.1",
            "firefox-locale-szl": "94.0+build3-0ubuntu0.20.04.1",
            "firefox-locale-si": "94.0+build3-0ubuntu0.20.04.1",
            "firefox": "94.0+build3-0ubuntu0.20.04.1",
            "firefox-locale-cy": "94.0+build3-0ubuntu0.20.04.1",
            "firefox-locale-fa": "94.0+build3-0ubuntu0.20.04.1",
            "firefox-locale-cak": "94.0+build3-0ubuntu0.20.04.1",
            "firefox-locale-sq": "94.0+build3-0ubuntu0.20.04.1",
            "firefox-locale-en": "94.0+build3-0ubuntu0.20.04.1",
            "firefox-locale-tr": "94.0+build3-0ubuntu0.20.04.1",
            "firefox-locale-br": "94.0+build3-0ubuntu0.20.04.1",
            "firefox-locale-et": "94.0+build3-0ubuntu0.20.04.1",
            "firefox-locale-ast": "94.0+build3-0ubuntu0.20.04.1",
            "firefox-locale-th": "94.0+build3-0ubuntu0.20.04.1",
            "firefox-locale-da": "94.0+build3-0ubuntu0.20.04.1",
            "firefox-locale-fi": "94.0+build3-0ubuntu0.20.04.1",
            "firefox-locale-ku": "94.0+build3-0ubuntu0.20.04.1",
            "firefox-locale-mn": "94.0+build3-0ubuntu0.20.04.1",
            "firefox-locale-ru": "94.0+build3-0ubuntu0.20.04.1",
            "firefox-locale-mk": "94.0+build3-0ubuntu0.20.04.1",
            "firefox-locale-bg": "94.0+build3-0ubuntu0.20.04.1",
            "firefox-locale-hu": "94.0+build3-0ubuntu0.20.04.1",
            "firefox-locale-gu": "94.0+build3-0ubuntu0.20.04.1",
            "firefox-locale-bn": "94.0+build3-0ubuntu0.20.04.1",
            "firefox-locale-kab": "94.0+build3-0ubuntu0.20.04.1",
            "firefox-locale-ml": "94.0+build3-0ubuntu0.20.04.1",
            "firefox-locale-an": "94.0+build3-0ubuntu0.20.04.1",
            "firefox-locale-be": "94.0+build3-0ubuntu0.20.04.1",
            "firefox-locale-eu": "94.0+build3-0ubuntu0.20.04.1",
            "firefox-locale-fr": "94.0+build3-0ubuntu0.20.04.1",
            "firefox-locale-pa": "94.0+build3-0ubuntu0.20.04.1",
            "firefox-locale-as": "94.0+build3-0ubuntu0.20.04.1",
            "firefox-locale-id": "94.0+build3-0ubuntu0.20.04.1",
            "firefox-locale-pl": "94.0+build3-0ubuntu0.20.04.1",
            "firefox-locale-gd": "94.0+build3-0ubuntu0.20.04.1",
            "firefox-locale-te": "94.0+build3-0ubuntu0.20.04.1",
            "firefox-locale-lv": "94.0+build3-0ubuntu0.20.04.1",
            "firefox-locale-ka": "94.0+build3-0ubuntu0.20.04.1",
            "firefox-locale-ta": "94.0+build3-0ubuntu0.20.04.1",
            "firefox-locale-bs": "94.0+build3-0ubuntu0.20.04.1",
            "firefox-locale-uz": "94.0+build3-0ubuntu0.20.04.1",
            "firefox-locale-hi": "94.0+build3-0ubuntu0.20.04.1",
            "firefox-locale-zh-hant": "94.0+build3-0ubuntu0.20.04.1",
            "firefox-locale-es": "94.0+build3-0ubuntu0.20.04.1",
            "firefox-locale-ur": "94.0+build3-0ubuntu0.20.04.1",
            "firefox-locale-mr": "94.0+build3-0ubuntu0.20.04.1",
            "firefox-locale-pt": "94.0+build3-0ubuntu0.20.04.1",
            "firefox-locale-de": "94.0+build3-0ubuntu0.20.04.1"
        }
    ]
}