USN-5161-1

See a problem?
Source
https://ubuntu.com/security/notices/USN-5161-1
Import Source
https://github.com/canonical/ubuntu-security-notices/blob/main/osv/USN-5161-1.json
JSON Data
https://api.osv.dev/v1/vulns/USN-5161-1
Related
Published
2021-11-30T21:34:52.928261Z
Modified
2021-11-30T21:34:52.928261Z
Summary
linux, linux-aws, linux-aws-5.11, linux-azure, linux-azure-5.11, linux-gcp, linux-gcp-5.11, linux-hwe-5.11, linux-kvm, linux-oracle, linux-oracle-5.11, linux-raspi vulnerabilities
Details

Ilja Van Sprundel discovered that the SCTP implementation in the Linux kernel did not properly perform size validations on incoming packets in some situations. An attacker could possibly use this to expose sensitive information (kernel memory). (CVE-2021-3655)

It was discovered that the AMD Cryptographic Coprocessor (CCP) driver in the Linux kernel did not properly deallocate memory in some error conditions. A local attacker could use this to cause a denial of service (memory exhaustion). (CVE-2021-3744, CVE-2021-3764)

It was discovered that the Aspeed Low Pin Count (LPC) Bus Controller implementation in the Linux kernel did not properly perform boundary checks in some situations, allowing out-of-bounds write access. A local attacker could use this to cause a denial of service (system crash) or possibly execute arbitrary code. In Ubuntu, this issue only affected systems running armhf kernels. (CVE-2021-42252)

References

Affected packages

Ubuntu:20.04:LTS / linux-oracle-5.11

Package

Name
linux-oracle-5.11

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
5.11.0-1022.23~20.04.1

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "linux-image-unsigned-5.11.0-1022-oracle": "5.11.0-1022.23~20.04.1",
            "linux-modules-extra-5.11.0-1022-oracle": "5.11.0-1022.23~20.04.1",
            "linux-modules-5.11.0-1022-oracle": "5.11.0-1022.23~20.04.1",
            "linux-image-5.11.0-1022-oracle": "5.11.0-1022.23~20.04.1",
            "linux-oracle-5.11-headers-5.11.0-1022": "5.11.0-1022.23~20.04.1",
            "linux-buildinfo-5.11.0-1022-oracle": "5.11.0-1022.23~20.04.1",
            "linux-oracle-5.11-tools-5.11.0-1022": "5.11.0-1022.23~20.04.1",
            "linux-oracle": "5.11.0.1022.23~20.04.15",
            "linux-tools-5.11.0-1022-oracle": "5.11.0-1022.23~20.04.1",
            "linux-tools-oracle-edge": "5.11.0.1022.23~20.04.15",
            "linux-headers-oracle": "5.11.0.1022.23~20.04.15",
            "linux-headers-5.11.0-1022-oracle": "5.11.0-1022.23~20.04.1",
            "linux-oracle-edge": "5.11.0.1022.23~20.04.15",
            "linux-image-oracle-edge": "5.11.0.1022.23~20.04.15",
            "linux-headers-oracle-edge": "5.11.0.1022.23~20.04.15",
            "linux-tools-oracle": "5.11.0.1022.23~20.04.15",
            "linux-image-oracle": "5.11.0.1022.23~20.04.15"
        }
    ]
}

Ubuntu:20.04:LTS / linux-aws-5.11

Package

Name
linux-aws-5.11

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
5.11.0-1022.23~20.04.1

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "linux-buildinfo-5.11.0-1022-aws": "5.11.0-1022.23~20.04.1",
            "linux-image-aws-edge": "5.11.0.1022.23~20.04.21",
            "linux-modules-extra-5.11.0-1022-aws": "5.11.0-1022.23~20.04.1",
            "linux-aws-5.11-headers-5.11.0-1022": "5.11.0-1022.23~20.04.1",
            "linux-headers-5.11.0-1022-aws": "5.11.0-1022.23~20.04.1",
            "linux-headers-aws": "5.11.0.1022.23~20.04.21",
            "linux-image-5.11.0-1022-aws": "5.11.0-1022.23~20.04.1",
            "linux-tools-5.11.0-1022-aws": "5.11.0-1022.23~20.04.1",
            "linux-aws-5.11-tools-5.11.0-1022": "5.11.0-1022.23~20.04.1",
            "linux-aws-5.11-cloud-tools-5.11.0-1022": "5.11.0-1022.23~20.04.1",
            "linux-modules-5.11.0-1022-aws": "5.11.0-1022.23~20.04.1",
            "linux-image-aws": "5.11.0.1022.23~20.04.21",
            "linux-aws": "5.11.0.1022.23~20.04.21",
            "linux-cloud-tools-5.11.0-1022-aws": "5.11.0-1022.23~20.04.1",
            "linux-modules-extra-aws": "5.11.0.1022.23~20.04.21",
            "linux-modules-extra-aws-edge": "5.11.0.1022.23~20.04.21",
            "linux-tools-aws-edge": "5.11.0.1022.23~20.04.21",
            "linux-headers-aws-edge": "5.11.0.1022.23~20.04.21",
            "linux-aws-edge": "5.11.0.1022.23~20.04.21",
            "linux-tools-aws": "5.11.0.1022.23~20.04.21"
        }
    ]
}

Ubuntu:20.04:LTS / linux-gcp-5.11

Package

Name
linux-gcp-5.11

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
5.11.0-1023.25~20.04.1

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "linux-tools-gcp": "5.11.0.1023.25~20.04.22",
            "linux-modules-extra-5.11.0-1023-gcp": "5.11.0-1023.25~20.04.1",
            "linux-tools-5.11.0-1023-gcp": "5.11.0-1023.25~20.04.1",
            "linux-tools-gcp-edge": "5.11.0.1023.25~20.04.22",
            "linux-modules-5.11.0-1023-gcp": "5.11.0-1023.25~20.04.1",
            "linux-gcp-5.11-tools-5.11.0-1023": "5.11.0-1023.25~20.04.1",
            "linux-buildinfo-5.11.0-1023-gcp": "5.11.0-1023.25~20.04.1",
            "linux-image-gcp-edge": "5.11.0.1023.25~20.04.22",
            "linux-gcp": "5.11.0.1023.25~20.04.22",
            "linux-headers-gcp-edge": "5.11.0.1023.25~20.04.22",
            "linux-image-gcp": "5.11.0.1023.25~20.04.22",
            "linux-headers-gcp": "5.11.0.1023.25~20.04.22",
            "linux-modules-extra-gcp-edge": "5.11.0.1023.25~20.04.22",
            "linux-gcp-edge": "5.11.0.1023.25~20.04.22",
            "linux-modules-extra-gcp": "5.11.0.1023.25~20.04.22",
            "linux-image-unsigned-5.11.0-1023-gcp": "5.11.0-1023.25~20.04.1",
            "linux-gcp-5.11-headers-5.11.0-1023": "5.11.0-1023.25~20.04.1",
            "linux-image-5.11.0-1023-gcp": "5.11.0-1023.25~20.04.1",
            "linux-headers-5.11.0-1023-gcp": "5.11.0-1023.25~20.04.1"
        }
    ]
}

Ubuntu:20.04:LTS / linux-azure-5.11

Package

Name
linux-azure-5.11

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
5.11.0-1022.23~20.04.1

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "linux-azure-5.11-cloud-tools-5.11.0-1022": "5.11.0-1022.23~20.04.1",
            "linux-modules-extra-azure": "5.11.0.1022.23~20.04.22",
            "linux-azure-5.11-tools-5.11.0-1022": "5.11.0-1022.23~20.04.1",
            "linux-azure": "5.11.0.1022.23~20.04.22",
            "linux-headers-5.11.0-1022-azure": "5.11.0-1022.23~20.04.1",
            "linux-modules-5.11.0-1022-azure": "5.11.0-1022.23~20.04.1",
            "linux-azure-edge": "5.11.0.1022.23~20.04.22",
            "linux-headers-azure-edge": "5.11.0.1022.23~20.04.22",
            "linux-image-unsigned-5.11.0-1022-azure": "5.11.0-1022.23~20.04.1",
            "linux-headers-azure": "5.11.0.1022.23~20.04.22",
            "linux-tools-azure-edge": "5.11.0.1022.23~20.04.22",
            "linux-cloud-tools-azure": "5.11.0.1022.23~20.04.22",
            "linux-image-5.11.0-1022-azure": "5.11.0-1022.23~20.04.1",
            "linux-buildinfo-5.11.0-1022-azure": "5.11.0-1022.23~20.04.1",
            "linux-cloud-tools-azure-edge": "5.11.0.1022.23~20.04.22",
            "linux-tools-5.11.0-1022-azure": "5.11.0-1022.23~20.04.1",
            "linux-image-azure": "5.11.0.1022.23~20.04.22",
            "linux-azure-5.11-headers-5.11.0-1022": "5.11.0-1022.23~20.04.1",
            "linux-image-azure-edge": "5.11.0.1022.23~20.04.22",
            "linux-cloud-tools-5.11.0-1022-azure": "5.11.0-1022.23~20.04.1",
            "linux-tools-azure": "5.11.0.1022.23~20.04.22",
            "linux-modules-extra-5.11.0-1022-azure": "5.11.0-1022.23~20.04.1",
            "linux-modules-extra-azure-edge": "5.11.0.1022.23~20.04.22"
        }
    ]
}

Ubuntu:20.04:LTS / linux-hwe-5.11

Package

Name
linux-hwe-5.11

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
5.11.0-41.45~20.04.1

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "linux-image-5.11.0-41-lowlatency": "5.11.0-41.45~20.04.1",
            "linux-hwe-5.11-tools-host": "5.11.0-41.45~20.04.1",
            "linux-hwe-5.11-headers-5.11.0-41": "5.11.0-41.45~20.04.1",
            "linux-modules-extra-5.11.0-41-generic": "5.11.0-41.45~20.04.1",
            "linux-tools-generic-hwe-20.04": "5.11.0.41.45~20.04.19",
            "linux-image-generic-lpae-hwe-20.04": "5.11.0.41.45~20.04.19",
            "linux-headers-generic-hwe-20.04": "5.11.0.41.45~20.04.19",
            "linux-buildinfo-5.11.0-41-generic-64k": "5.11.0-41.45~20.04.1",
            "linux-hwe-5.11-source-5.11.0": "5.11.0-41.45~20.04.1",
            "linux-image-generic-hwe-20.04": "5.11.0.41.45~20.04.19",
            "linux-buildinfo-5.11.0-41-generic-lpae": "5.11.0-41.45~20.04.1",
            "linux-image-generic-64k-hwe-20.04": "5.11.0.41.45~20.04.19",
            "linux-modules-5.11.0-41-generic-64k": "5.11.0-41.45~20.04.1",
            "linux-headers-generic-lpae-hwe-20.04": "5.11.0.41.45~20.04.19",
            "linux-headers-5.11.0-41-lowlatency": "5.11.0-41.45~20.04.1",
            "linux-headers-5.11.0-41-generic": "5.11.0-41.45~20.04.1",
            "linux-image-5.11.0-41-generic-64k": "5.11.0-41.45~20.04.1",
            "linux-hwe-5.11-cloud-tools-5.11.0-41": "5.11.0-41.45~20.04.1",
            "linux-tools-5.11.0-41-generic-64k": "5.11.0-41.45~20.04.1",
            "linux-image-unsigned-5.11.0-41-generic": "5.11.0-41.45~20.04.1",
            "linux-tools-5.11.0-41-generic-lpae": "5.11.0-41.45~20.04.1",
            "linux-cloud-tools-5.11.0-41-lowlatency": "5.11.0-41.45~20.04.1",
            "linux-hwe-5.11-tools-5.11.0-41": "5.11.0-41.45~20.04.1",
            "linux-buildinfo-5.11.0-41-lowlatency": "5.11.0-41.45~20.04.1",
            "linux-image-unsigned-5.11.0-41-generic-64k": "5.11.0-41.45~20.04.1",
            "linux-image-unsigned-5.11.0-41-lowlatency": "5.11.0-41.45~20.04.1",
            "linux-generic-hwe-20.04": "5.11.0.41.45~20.04.19",
            "linux-lowlatency-hwe-20.04": "5.11.0.41.45~20.04.19",
            "linux-image-5.11.0-41-generic-lpae": "5.11.0-41.45~20.04.1",
            "linux-image-extra-virtual-hwe-20.04": "5.11.0.41.45~20.04.19",
            "linux-headers-5.11.0-41-generic-lpae": "5.11.0-41.45~20.04.1",
            "linux-tools-virtual-hwe-20.04": "5.11.0.41.45~20.04.19",
            "linux-generic-64k-hwe-20.04": "5.11.0.41.45~20.04.19",
            "linux-image-5.11.0-41-generic": "5.11.0-41.45~20.04.1",
            "linux-tools-generic-lpae-hwe-20.04": "5.11.0.41.45~20.04.19",
            "linux-headers-lowlatency-hwe-20.04": "5.11.0.41.45~20.04.19",
            "linux-cloud-tools-5.11.0-41-generic": "5.11.0-41.45~20.04.1",
            "linux-generic-lpae-hwe-20.04": "5.11.0.41.45~20.04.19",
            "linux-cloud-tools-generic-hwe-20.04": "5.11.0.41.45~20.04.19",
            "linux-virtual-hwe-20.04": "5.11.0.41.45~20.04.19",
            "linux-tools-5.11.0-41-generic": "5.11.0-41.45~20.04.1",
            "linux-hwe-5.11-cloud-tools-common": "5.11.0-41.45~20.04.1",
            "linux-image-lowlatency-hwe-20.04": "5.11.0.41.45~20.04.19",
            "linux-modules-5.11.0-41-generic-lpae": "5.11.0-41.45~20.04.1",
            "linux-cloud-tools-virtual-hwe-20.04": "5.11.0.41.45~20.04.19",
            "linux-buildinfo-5.11.0-41-generic": "5.11.0-41.45~20.04.1",
            "linux-headers-generic-64k-hwe-20.04": "5.11.0.41.45~20.04.19",
            "linux-tools-lowlatency-hwe-20.04": "5.11.0.41.45~20.04.19",
            "linux-modules-5.11.0-41-lowlatency": "5.11.0-41.45~20.04.1",
            "linux-modules-5.11.0-41-generic": "5.11.0-41.45~20.04.1",
            "linux-image-virtual-hwe-20.04": "5.11.0.41.45~20.04.19",
            "linux-headers-virtual-hwe-20.04": "5.11.0.41.45~20.04.19",
            "linux-headers-5.11.0-41-generic-64k": "5.11.0-41.45~20.04.1",
            "linux-cloud-tools-lowlatency-hwe-20.04": "5.11.0.41.45~20.04.19",
            "linux-tools-generic-64k-hwe-20.04": "5.11.0.41.45~20.04.19",
            "linux-tools-5.11.0-41-lowlatency": "5.11.0-41.45~20.04.1",
            "linux-hwe-5.11-tools-common": "5.11.0-41.45~20.04.1"
        }
    ]
}