USN-5168-1

See a problem?
Source
https://ubuntu.com/security/notices/USN-5168-1
Import Source
https://github.com/canonical/ubuntu-security-notices/blob/main/osv/USN-5168-1.json
JSON Data
https://api.osv.dev/v1/vulns/USN-5168-1
Related
Published
2021-12-01T16:49:18.280123Z
Modified
2021-12-01T16:49:18.280123Z
Summary
nss vulnerability
Details

Tavis Ormandy discovered that NSS incorrectly handled verifying DSA/RSA-PSS signatures. A remote attacker could use this issue to cause NSS to crash, resulting in a denial of service, or possibly execute arbitrary code.

References

Affected packages

Ubuntu:20.04:LTS / nss

Package

Name
nss

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
2:3.49.1-1ubuntu1.6

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "libnss3-tools": "2:3.49.1-1ubuntu1.6",
            "libnss3": "2:3.49.1-1ubuntu1.6",
            "libnss3-dev": "2:3.49.1-1ubuntu1.6"
        }
    ]
}

Ubuntu:18.04:LTS / nss

Package

Name
nss

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
2:3.35-2ubuntu2.13

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "libnss3-tools": "2:3.35-2ubuntu2.13",
            "libnss3": "2:3.35-2ubuntu2.13",
            "libnss3-dev": "2:3.35-2ubuntu2.13"
        }
    ]
}