USN-5168-4

See a problem?
Source
https://ubuntu.com/security/notices/USN-5168-4
Import Source
https://github.com/canonical/ubuntu-security-notices/blob/main/osv/USN-5168-4.json
JSON Data
https://api.osv.dev/v1/vulns/USN-5168-4
Related
Published
2021-12-07T19:35:28.149213Z
Modified
2021-12-07T19:35:28.149213Z
Summary
nss regression
Details

USN-5168-3 fixed a vulnerability in NSS. Unfortunately that update introduced a regression that could break SSL connections. This update fixes the problem.

We apologize for the inconvenience.

Original advisory details:

Tavis Ormandy discovered that NSS incorrectly handled verifying DSA/RSA-PSS signatures. A remote attacker could use this issue to cause NSS to crash, resulting in a denial of service, or possibly execute arbitrary code.

References

Affected packages

Ubuntu:Pro:14.04:LTS / nss

Package

Name
nss

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
2:3.28.4-0ubuntu0.14.04.5+esm10

Ecosystem specific

{
    "availability": "Available with Ubuntu Pro: https://ubuntu.com/pro",
    "binaries": [
        {
            "libnss3-1d": "2:3.28.4-0ubuntu0.14.04.5+esm10",
            "libnss3-tools": "2:3.28.4-0ubuntu0.14.04.5+esm10",
            "libnss3": "2:3.28.4-0ubuntu0.14.04.5+esm10",
            "libnss3-dev": "2:3.28.4-0ubuntu0.14.04.5+esm10",
            "libnss3-nssdb": "2:3.28.4-0ubuntu0.14.04.5+esm10"
        }
    ]
}

Ubuntu:Pro:16.04:LTS / nss

Package

Name
nss

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
2:3.28.4-0ubuntu0.16.04.14+esm2

Ecosystem specific

{
    "availability": "Available with Ubuntu Pro: https://ubuntu.com/pro",
    "binaries": [
        {
            "libnss3-1d": "2:3.28.4-0ubuntu0.16.04.14+esm2",
            "libnss3-tools": "2:3.28.4-0ubuntu0.16.04.14+esm2",
            "libnss3": "2:3.28.4-0ubuntu0.16.04.14+esm2",
            "libnss3-dev": "2:3.28.4-0ubuntu0.16.04.14+esm2",
            "libnss3-nssdb": "2:3.28.4-0ubuntu0.16.04.14+esm2"
        }
    ]
}