USN-5170-1

See a problem?
Source
https://ubuntu.com/security/notices/USN-5170-1
Import Source
https://github.com/canonical/ubuntu-security-notices/blob/main/osv/USN-5170-1.json
JSON Data
https://api.osv.dev/v1/vulns/USN-5170-1
Related
Published
2021-12-06T14:39:06.675074Z
Modified
2021-12-06T14:39:06.675074Z
Summary
mariadb-10.3, mariadb-10.5 vulnerability
Details

A security issue was discovered in MariaDB and this update includes new upstream MariaDB versions to fix the issue.

MariaDB has been updated to 10.3.32 in Ubuntu 20.04 LTS and to 10.5.13 in Ubuntu 21.04 and Ubuntu 21.10.

In addition to security fixes, the updated packages contain bug fixes, new features, and possibly incompatible changes.

References

Affected packages

Ubuntu:20.04:LTS / mariadb-10.3

Package

Name
mariadb-10.3

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
1:10.3.32-0ubuntu0.20.04.1

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "mariadb-server-core-10.3": "1:10.3.32-0ubuntu0.20.04.1",
            "mariadb-plugin-gssapi-client": "1:10.3.32-0ubuntu0.20.04.1",
            "libmariadb-dev-compat": "1:10.3.32-0ubuntu0.20.04.1",
            "mariadb-plugin-oqgraph": "1:10.3.32-0ubuntu0.20.04.1",
            "libmariadbclient-dev": "1:10.3.32-0ubuntu0.20.04.1",
            "libmariadbd19": "1:10.3.32-0ubuntu0.20.04.1",
            "mariadb-plugin-cracklib-password-check": "1:10.3.32-0ubuntu0.20.04.1",
            "mariadb-plugin-spider": "1:10.3.32-0ubuntu0.20.04.1",
            "mariadb-common": "1:10.3.32-0ubuntu0.20.04.1",
            "mariadb-plugin-mroonga": "1:10.3.32-0ubuntu0.20.04.1",
            "mariadb-client": "1:10.3.32-0ubuntu0.20.04.1",
            "libmariadb3": "1:10.3.32-0ubuntu0.20.04.1",
            "mariadb-plugin-connect": "1:10.3.32-0ubuntu0.20.04.1",
            "libmariadb-dev": "1:10.3.32-0ubuntu0.20.04.1",
            "mariadb-server": "1:10.3.32-0ubuntu0.20.04.1",
            "libmariadbd-dev": "1:10.3.32-0ubuntu0.20.04.1",
            "mariadb-client-10.3": "1:10.3.32-0ubuntu0.20.04.1",
            "mariadb-plugin-gssapi-server": "1:10.3.32-0ubuntu0.20.04.1",
            "mariadb-backup": "1:10.3.32-0ubuntu0.20.04.1",
            "mariadb-client-core-10.3": "1:10.3.32-0ubuntu0.20.04.1",
            "mariadb-server-10.3": "1:10.3.32-0ubuntu0.20.04.1",
            "mariadb-test": "1:10.3.32-0ubuntu0.20.04.1",
            "mariadb-plugin-rocksdb": "1:10.3.32-0ubuntu0.20.04.1",
            "mariadb-test-data": "1:10.3.32-0ubuntu0.20.04.1",
            "mariadb-plugin-tokudb": "1:10.3.32-0ubuntu0.20.04.1"
        }
    ]
}