USN-5183-1

See a problem?
Source
https://ubuntu.com/security/notices/USN-5183-1
Import Source
https://github.com/canonical/ubuntu-security-notices/blob/main/osv/USN-5183-1.json
JSON Data
https://api.osv.dev/v1/vulns/USN-5183-1
Related
Published
2021-12-08T18:16:42.804172Z
Modified
2021-12-08T18:16:42.804172Z
Summary
bluez vulnerability
Details

Julian Rauchberger discovered that BlueZ incorrectly handled memory when processing SDP attribute requests. A remote attacker could use this issue to cause BlueZ to crash, leading to a denial of service, or possibly execute arbitrary code.

References

Affected packages

Ubuntu:18.04:LTS / bluez

Package

Name
bluez

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
5.48-0ubuntu3.7

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "libbluetooth3": "5.48-0ubuntu3.7",
            "bluetooth": "5.48-0ubuntu3.7",
            "bluez-hcidump": "5.48-0ubuntu3.7",
            "bluez-cups": "5.48-0ubuntu3.7",
            "bluez-tests": "5.48-0ubuntu3.7",
            "libbluetooth-dev": "5.48-0ubuntu3.7",
            "bluez": "5.48-0ubuntu3.7",
            "bluez-obexd": "5.48-0ubuntu3.7"
        }
    ]
}