USN-5213-1

See a problem?
Source
https://ubuntu.com/security/notices/USN-5213-1
Import Source
https://github.com/canonical/ubuntu-security-notices/blob/main/osv/USN-5213-1.json
JSON Data
https://api.osv.dev/v1/vulns/USN-5213-1
Related
  • CVE-2021-30887
  • CVE-2021-30890
Published
2022-01-06T14:54:22.049789Z
Modified
2022-01-06T14:54:22.049789Z
Summary
webkit2gtk vulnerabilities
Details

A large number of security issues were discovered in the WebKitGTK Web and JavaScript engines. If a user were tricked into viewing a malicious website, a remote attacker could exploit a variety of issues related to web browser security, including cross-site scripting attacks, denial of service attacks, and arbitrary code execution.

References

Affected packages

Ubuntu:20.04:LTS / webkit2gtk

Package

Name
webkit2gtk

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
2.34.3-0ubuntu0.20.04.1

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "webkit2gtk-driver": "2.34.3-0ubuntu0.20.04.1",
            "gir1.2-webkit2-4.0": "2.34.3-0ubuntu0.20.04.1",
            "libwebkit2gtk-4.0-dev": "2.34.3-0ubuntu0.20.04.1",
            "libjavascriptcoregtk-4.0-dev": "2.34.3-0ubuntu0.20.04.1",
            "gir1.2-javascriptcoregtk-4.0": "2.34.3-0ubuntu0.20.04.1",
            "libwebkit2gtk-4.0-37-gtk2": "2.34.3-0ubuntu0.20.04.1",
            "libwebkit2gtk-4.0-37": "2.34.3-0ubuntu0.20.04.1",
            "libjavascriptcoregtk-4.0-18": "2.34.3-0ubuntu0.20.04.1",
            "libwebkit2gtk-4.0-doc": "2.34.3-0ubuntu0.20.04.1",
            "libjavascriptcoregtk-4.0-bin": "2.34.3-0ubuntu0.20.04.1"
        }
    ]
}