USN-5215-1

See a problem?
Source
https://ubuntu.com/security/notices/USN-5215-1
Import Source
https://github.com/canonical/ubuntu-security-notices/blob/main/osv/USN-5215-1.json
JSON Data
https://api.osv.dev/v1/vulns/USN-5215-1
Related
Published
2022-01-10T20:51:11.778907Z
Modified
2022-01-10T20:51:11.778907Z
Summary
nltk vulnerability
Details

Srikantha Prathi discovered that NLTK incorrectly handled specially crafted input. An attacker could use this vulnerability to cause a denial of service.

References

Affected packages

Ubuntu:Pro:20.04:LTS / nltk

Package

Name
nltk

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
3.4.5-2ubuntu0.1~esm1

Ecosystem specific

{
    "availability": "Available with Ubuntu Pro: https://ubuntu.com/pro",
    "binaries": [
        {
            "python3-nltk": "3.4.5-2ubuntu0.1~esm1"
        }
    ]
}

Ubuntu:Pro:18.04:LTS / nltk

Package

Name
nltk

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
3.2.5-1ubuntu0.1+esm1

Ecosystem specific

{
    "availability": "Available with Ubuntu Pro: https://ubuntu.com/pro",
    "binaries": [
        {
            "python-nltk": "3.2.5-1ubuntu0.1+esm1",
            "python3-nltk": "3.2.5-1ubuntu0.1+esm1"
        }
    ]
}

Ubuntu:Pro:16.04:LTS / nltk

Package

Name
nltk

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
3.1-1ubuntu0.1+esm1

Ecosystem specific

{
    "availability": "Available with Ubuntu Pro: https://ubuntu.com/pro",
    "binaries": [
        {
            "python-nltk": "3.1-1ubuntu0.1+esm1",
            "python3-nltk": "3.1-1ubuntu0.1+esm1"
        }
    ]
}