USN-5221-1

See a problem?
Source
https://ubuntu.com/security/notices/USN-5221-1
Import Source
https://github.com/canonical/ubuntu-security-notices/blob/main/osv/USN-5221-1.json
JSON Data
https://api.osv.dev/v1/vulns/USN-5221-1
Related
Published
2022-08-03T10:10:42.122540Z
Modified
2022-08-03T10:10:42.122540Z
Summary
redis vulnerabilities
Details

It was discovered that Redis incorrectly handled certain specially crafted Lua scripts. A remote attacker could possibly use this issue to cause a denial of service or execute arbitrary code. (CVE-2021-32626)

It was discovered that Redis incorrectly handled some malformed requests when using Redis Lua Debugger. A remote attacker could possibly use this issue to cause a denial of service or other unspecified impact. This issue only affected Ubuntu 18.04 ESM and Ubuntu 20.04 ESM. (CVE-2021-32672)

It was discovered that Redis incorrectly handled certain Redis Standard Protocol (RESP) requests. A remote attacker could possibly use this issue to cause a denial of service. (CVE-2021-32675)

It was discovered that Redis incorrectly handled some configuration parameters with specially crafted network payloads. A remote attacker could possibly use this issue to cause a denial of service or execute arbitrary code. Vulnerabilities CVE-2021-32627 and CVE-2021-41099 only affected Ubuntu 18.04 ESM and Ubuntu 20.04 ESM. (CVE-2021-32627, CVE-2021-32628, CVE-2021-32687, CVE-2021-41099).

It was discovered that Redis incorrectly handled memory when processing certain input in 32-bit systems. A remote attacker could possibly use this issue to cause a denial of service or execute arbitrary code. One vulnerability (CVE-2021-32761) only affected Ubuntu 14.04 ESM, Ubuntu 16.04 ESM and Ubuntu 18.04 ESM and another vulnerability (CVE-2021-21309) only affected Ubuntu 18.04 ESM. (CVE-2021-32761, CVE-2021-21309).

References

Affected packages

Ubuntu:Pro:20.04:LTS / redis

Package

Name
redis

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
5:5.0.7-2ubuntu0.1+esm1

Ecosystem specific

{
    "availability": "Available with Ubuntu Pro: https://ubuntu.com/pro",
    "binaries": [
        {
            "redis-server": "5:5.0.7-2ubuntu0.1+esm1",
            "redis-sentinel": "5:5.0.7-2ubuntu0.1+esm1",
            "redis": "5:5.0.7-2ubuntu0.1+esm1",
            "redis-tools": "5:5.0.7-2ubuntu0.1+esm1"
        }
    ]
}

Ubuntu:Pro:14.04:LTS / redis

Package

Name
redis

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
2:2.8.4-2ubuntu0.2+esm2

Ecosystem specific

{
    "availability": "Available with Ubuntu Pro: https://ubuntu.com/pro",
    "binaries": [
        {
            "redis-server": "2:2.8.4-2ubuntu0.2+esm2",
            "redis-tools": "2:2.8.4-2ubuntu0.2+esm2"
        }
    ]
}

Ubuntu:Pro:18.04:LTS / redis

Package

Name
redis

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
5:4.0.9-1ubuntu0.2+esm3

Ecosystem specific

{
    "availability": "Available with Ubuntu Pro: https://ubuntu.com/pro",
    "binaries": [
        {
            "redis-server": "5:4.0.9-1ubuntu0.2+esm3",
            "redis-sentinel": "5:4.0.9-1ubuntu0.2+esm3",
            "redis": "5:4.0.9-1ubuntu0.2+esm3",
            "redis-tools": "5:4.0.9-1ubuntu0.2+esm3"
        }
    ]
}

Ubuntu:Pro:16.04:LTS / redis

Package

Name
redis

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
2:3.0.6-1ubuntu0.4+esm1

Ecosystem specific

{
    "availability": "Available with Ubuntu Pro: https://ubuntu.com/pro",
    "binaries": [
        {
            "redis-tools": "2:3.0.6-1ubuntu0.4+esm1",
            "redis-sentinel": "2:3.0.6-1ubuntu0.4+esm1",
            "redis-server": "2:3.0.6-1ubuntu0.4+esm1"
        }
    ]
}