USN-5223-1

See a problem?
Source
https://ubuntu.com/security/notices/USN-5223-1
Import Source
https://github.com/canonical/ubuntu-security-notices/blob/main/osv/USN-5223-1.json
JSON Data
https://api.osv.dev/v1/vulns/USN-5223-1
Related
  • CVE-2021-4104
Published
2022-01-12T19:31:51.929102Z
Modified
2022-01-12T19:31:51.929102Z
Summary
apache-log4j1.2 vulnerability
Details

It was discovered that Apache Log4j 1.2 was vulnerable to deserialization of untrusted data if the configuration file was editable. An attacker could use this vulnerability to cause a DoS or possibly execute arbitrary code.

References

Affected packages

Ubuntu:20.04:LTS / apache-log4j1.2

Package

Name
apache-log4j1.2

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
1.2.17-9ubuntu0.1

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "liblog4j1.2-java-doc": "1.2.17-9ubuntu0.1",
            "liblog4j1.2-java": "1.2.17-9ubuntu0.1"
        }
    ]
}

Ubuntu:18.04:LTS / apache-log4j1.2

Package

Name
apache-log4j1.2

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
1.2.17-8+deb10u1ubuntu0.1

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "liblog4j1.2-java-doc": "1.2.17-8+deb10u1ubuntu0.1",
            "liblog4j1.2-java": "1.2.17-8+deb10u1ubuntu0.1"
        }
    ]
}