USN-5227-1

See a problem?
Source
https://ubuntu.com/security/notices/USN-5227-1
Import Source
https://github.com/canonical/ubuntu-security-notices/blob/main/osv/USN-5227-1.json
JSON Data
https://api.osv.dev/v1/vulns/USN-5227-1
Related
Published
2022-01-13T13:26:09.232893Z
Modified
2022-01-13T13:26:09.232893Z
Summary
pillow vulnerabilities
Details

It was discovered that Pillow incorrectly handled certain image files. If a user or automated system were tricked into opening a specially-crafted file, a remote attacker could cause Pillow to hang, resulting in a denial of service. (CVE-2021-23437)

It was discovered that Pillow incorrectly handled certain image files. If a user or automated system were tricked into opening a specially-crafted file, a remote attacker could cause Pillow to crash, resulting in a denial of service. This issue ony affected Ubuntu 18.04 LTS, Ubuntu 20.04 LTS, and Ubuntu 21.04. (CVE-2021-34552)

It was discovered that Pillow incorrectly handled certain image files. If a user or automated system were tricked into opening a specially-crafted file, a remote attacker could cause Pillow to crash, resulting in a denial of service, or possibly execute arbitrary code. (CVE-2022-22815)

It was discovered that Pillow incorrectly handled certain image files. If a user or automated system were tricked into opening a specially-crafted file, a remote attacker could cause Pillow to crash, resulting in a denial of service. (CVE-2022-22816)

It was discovered that Pillow incorrectly handled certain image files. If a user or automated system were tricked into opening a specially-crafted file, a remote attacker could cause Pillow to crash, resulting in a denial of service, or possibly execute arbitrary code. (CVE-2022-22817)

References

Affected packages

Ubuntu:20.04:LTS / pillow

Package

Name
pillow

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
7.0.0-4ubuntu0.5

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "python3-pil.imagetk": "7.0.0-4ubuntu0.5",
            "python-pil-doc": "7.0.0-4ubuntu0.5",
            "python3-pil": "7.0.0-4ubuntu0.5"
        }
    ]
}

Ubuntu:18.04:LTS / pillow

Package

Name
pillow

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
5.1.0-1ubuntu0.7

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "python3-pil.imagetk": "5.1.0-1ubuntu0.7",
            "python-pil-doc": "5.1.0-1ubuntu0.7",
            "python3-pil": "5.1.0-1ubuntu0.7",
            "python-pil.imagetk": "5.1.0-1ubuntu0.7",
            "python-pil": "5.1.0-1ubuntu0.7"
        }
    ]
}