USN-5235-1

See a problem?
Source
https://ubuntu.com/security/notices/USN-5235-1
Import Source
https://github.com/canonical/ubuntu-security-notices/blob/main/osv/USN-5235-1.json
JSON Data
https://api.osv.dev/v1/vulns/USN-5235-1
Related
Published
2022-01-18T17:13:18.983144Z
Modified
2022-01-18T17:13:18.983144Z
Summary
ruby2.3, ruby2.5, ruby2.7 vulnerabilities
Details

It was discovered that Ruby incorrectly handled certain HTML files. An attacker could possibly use this issue to cause a crash. This issue only affected Ubuntu 20.04 LTS, Ubuntu 21.04, and Ubuntu 21.10. (CVE-2021-41816)

It was discovered that Ruby incorrectly handled certain regular expressions. An attacker could possibly use this issue to cause a regular expression denial of service. (CVE-2021-41817)

It was discovered that Ruby incorrectly handled certain cookie names. An attacker could possibly use this issue to access or expose sensitive information. (CVE-2021-41819)

References

Affected packages

Ubuntu:18.04:LTS / ruby2.5

Package

Name
ruby2.5

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
2.5.1-1ubuntu1.11

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "ruby2.5": "2.5.1-1ubuntu1.11",
            "libruby2.5": "2.5.1-1ubuntu1.11",
            "ruby2.5-dev": "2.5.1-1ubuntu1.11",
            "ruby2.5-doc": "2.5.1-1ubuntu1.11"
        }
    ]
}

Ubuntu:20.04:LTS / ruby2.7

Package

Name
ruby2.7

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
2.7.0-5ubuntu1.6

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "ruby2.7-doc": "2.7.0-5ubuntu1.6",
            "ruby2.7": "2.7.0-5ubuntu1.6",
            "libruby2.7": "2.7.0-5ubuntu1.6",
            "ruby2.7-dev": "2.7.0-5ubuntu1.6"
        }
    ]
}

Ubuntu:Pro:16.04:LTS / ruby2.3

Package

Name
ruby2.3

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
2.3.1-2~ubuntu16.04.16+esm2

Ecosystem specific

{
    "availability": "Available with Ubuntu Pro: https://ubuntu.com/pro",
    "binaries": [
        {
            "ruby2.3-doc": "2.3.1-2~ubuntu16.04.16+esm2",
            "ruby2.3-dev": "2.3.1-2~ubuntu16.04.16+esm2",
            "ruby2.3-tcltk": "2.3.1-2~ubuntu16.04.16+esm2",
            "libruby2.3": "2.3.1-2~ubuntu16.04.16+esm2",
            "ruby2.3": "2.3.1-2~ubuntu16.04.16+esm2"
        }
    ]
}