USN-5256-2

See a problem?
Source
https://ubuntu.com/security/notices/USN-5256-2
Import Source
https://github.com/canonical/ubuntu-security-notices/blob/main/osv/USN-5256-2.json
JSON Data
https://api.osv.dev/v1/vulns/USN-5256-2
Related
Published
2022-07-18T11:55:10.014536Z
Modified
2022-07-18T11:55:10.014536Z
Summary
uriparser vulnerabilities
Details

USN-5256-1 fixed several vulnerabilities in uriparser. This update provides the corresponding update for Ubuntu 14.04 ESM, Ubuntu 16.04 ESM and Ubuntu 20.04 ESM.

Original advisory details:

It was discovered that uriparser incorrectly handled certain memory operations. An attacker could use this to cause a denial of service. (CVE-2021-46141, CVE-2021-46142)

References

Affected packages

Ubuntu:Pro:14.04:LTS / uriparser

Package

Name
uriparser

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
0.7.5-1ubuntu2+esm3

Ecosystem specific

{
    "availability": "Available with Ubuntu Pro: https://ubuntu.com/pro",
    "binaries": [
        {
            "liburiparser1": "0.7.5-1ubuntu2+esm3",
            "liburiparser-dev": "0.7.5-1ubuntu2+esm3"
        }
    ]
}

Ubuntu:Pro:20.04:LTS / uriparser

Package

Name
uriparser

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
0.9.3-2ubuntu0.1~esm2

Ecosystem specific

{
    "availability": "Available with Ubuntu Pro: https://ubuntu.com/pro",
    "binaries": [
        {
            "liburiparser1": "0.9.3-2ubuntu0.1~esm2",
            "liburiparser-dev": "0.9.3-2ubuntu0.1~esm2",
            "liburiparser-doc": "0.9.3-2ubuntu0.1~esm2"
        }
    ]
}

Ubuntu:Pro:16.04:LTS / uriparser

Package

Name
uriparser

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
0.8.4-1ubuntu0.16.04.1~esm3

Ecosystem specific

{
    "availability": "Available with Ubuntu Pro: https://ubuntu.com/pro",
    "binaries": [
        {
            "liburiparser1": "0.8.4-1ubuntu0.16.04.1~esm3",
            "liburiparser-dev": "0.8.4-1ubuntu0.16.04.1~esm3",
            "liburiparser-doc": "0.8.4-1ubuntu0.16.04.1~esm3"
        }
    ]
}