USN-5257-1

See a problem?
Source
https://ubuntu.com/security/notices/USN-5257-1
Import Source
https://github.com/canonical/ubuntu-security-notices/blob/main/osv/USN-5257-1.json
JSON Data
https://api.osv.dev/v1/vulns/USN-5257-1
Related
Published
2022-01-31T12:40:54.455915Z
Modified
2022-01-31T12:40:54.455915Z
Summary
ldns vulnerabilities
Details

It was discovered that ldns incorrectly handled certain inputs. An attacker could possibly use this issue to expose sensitive information. (CVE-2020-19860, CVE-2020-19861)

References

Affected packages

Ubuntu:18.04:LTS / ldns

Package

Name
ldns

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
1.7.0-3ubuntu4.1

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "python3-ldns": "1.7.0-3ubuntu4.1",
            "ldnsutils": "1.7.0-3ubuntu4.1",
            "libldns2": "1.7.0-3ubuntu4.1",
            "python-ldns": "1.7.0-3ubuntu4.1",
            "libldns-dev": "1.7.0-3ubuntu4.1"
        }
    ]
}

Ubuntu:Pro:16.04:LTS / ldns

Package

Name
ldns

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
1.6.17-8ubuntu0.1+esm1

Ecosystem specific

{
    "availability": "Available with Ubuntu Pro: https://ubuntu.com/pro",
    "binaries": [
        {
            "ldnsutils": "1.6.17-8ubuntu0.1+esm1",
            "libldns1": "1.6.17-8ubuntu0.1+esm1",
            "python-ldns": "1.6.17-8ubuntu0.1+esm1",
            "libldns-dev": "1.6.17-8ubuntu0.1+esm1"
        }
    ]
}