USN-5267-1

See a problem?
Source
https://ubuntu.com/security/notices/USN-5267-1
Import Source
https://github.com/canonical/ubuntu-security-notices/blob/main/osv/USN-5267-1.json
JSON Data
https://api.osv.dev/v1/vulns/USN-5267-1
Related
  • CVE-2021-3640
  • CVE-2021-3752
  • CVE-2021-42739
Published
2022-02-03T04:42:38Z
Modified
2022-02-03T04:42:38Z
Summary
linux, linux-aws, linux-aws-5.4, linux-azure, linux-azure-5.4, linux-bluefield, linux-gcp, linux-gcp-5.4, linux-gkeop, linux-gkeop-5.4, linux-hwe-5.4, linux-ibm, linux-kvm, linux-oracle, linux-oracle-5.4 vulnerabilities
Details

It was discovered that the Bluetooth subsystem in the Linux kernel contained a use-after-free vulnerability. A local attacker could use this to cause a denial of service (system crash) or possibly execute arbitrary code. (CVE-2021-3640)

Likang Luo discovered that a race condition existed in the Bluetooth subsystem of the Linux kernel, leading to a use-after-free vulnerability. A local attacker could use this to cause a denial of service (system crash) or possibly execute arbitrary code. (CVE-2021-3752)

Luo Likang discovered that the FireDTV Firewire driver in the Linux kernel did not properly perform bounds checking in some situations. A local attacker could use this to cause a denial of service (system crash) or possibly execute arbitrary code. (CVE-2021-42739)

References

Affected packages

Ubuntu:18.04:LTS / linux-gcp-5.4

Package

Name
linux-gcp-5.4

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
5.4.0-1063.67~18.04.1

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "linux-tools-gcp": "5.4.0.1063.48",
            "linux-gcp-5.4-headers-5.4.0-1063": "5.4.0-1063.67~18.04.1",
            "linux-image-unsigned-5.4.0-1063-gcp": "5.4.0-1063.67~18.04.1",
            "linux-image-5.4.0-1063-gcp": "5.4.0-1063.67~18.04.1",
            "linux-tools-gcp-edge": "5.4.0.1063.48",
            "linux-gcp": "5.4.0.1063.48",
            "linux-headers-gcp-edge": "5.4.0.1063.48",
            "linux-image-gcp-edge": "5.4.0.1063.48",
            "linux-tools-5.4.0-1063-gcp": "5.4.0-1063.67~18.04.1",
            "linux-image-gcp": "5.4.0.1063.48",
            "linux-headers-gcp": "5.4.0.1063.48",
            "linux-modules-extra-gcp": "5.4.0.1063.48",
            "linux-gcp-edge": "5.4.0.1063.48",
            "linux-gcp-5.4-tools-5.4.0-1063": "5.4.0-1063.67~18.04.1",
            "linux-modules-extra-5.4.0-1063-gcp": "5.4.0-1063.67~18.04.1",
            "linux-modules-5.4.0-1063-gcp": "5.4.0-1063.67~18.04.1",
            "linux-modules-extra-gcp-edge": "5.4.0.1063.48",
            "linux-buildinfo-5.4.0-1063-gcp": "5.4.0-1063.67~18.04.1",
            "linux-headers-5.4.0-1063-gcp": "5.4.0-1063.67~18.04.1"
        }
    ]
}

Ubuntu:18.04:LTS / linux-azure-5.4

Package

Name
linux-azure-5.4

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
5.4.0-1068.71~18.04.1

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "linux-modules-extra-azure-edge": "5.4.0.1068.47",
            "linux-modules-extra-azure": "5.4.0.1068.47",
            "linux-signed-image-azure": "5.4.0.1068.47",
            "linux-azure": "5.4.0.1068.47",
            "linux-headers-5.4.0-1068-azure": "5.4.0-1068.71~18.04.1",
            "linux-tools-5.4.0-1068-azure": "5.4.0-1068.71~18.04.1",
            "linux-azure-5.4-tools-5.4.0-1068": "5.4.0-1068.71~18.04.1",
            "linux-signed-azure": "5.4.0.1068.47",
            "linux-buildinfo-5.4.0-1068-azure": "5.4.0-1068.71~18.04.1",
            "linux-azure-edge": "5.4.0.1068.47",
            "linux-modules-extra-5.4.0-1068-azure": "5.4.0-1068.71~18.04.1",
            "linux-azure-5.4-headers-5.4.0-1068": "5.4.0-1068.71~18.04.1",
            "linux-headers-azure": "5.4.0.1068.47",
            "linux-tools-azure-edge": "5.4.0.1068.47",
            "linux-cloud-tools-azure": "5.4.0.1068.47",
            "linux-cloud-tools-azure-edge": "5.4.0.1068.47",
            "linux-image-5.4.0-1068-azure": "5.4.0-1068.71~18.04.1",
            "linux-tools-azure": "5.4.0.1068.47",
            "linux-image-unsigned-5.4.0-1068-azure": "5.4.0-1068.71~18.04.1",
            "linux-image-azure": "5.4.0.1068.47",
            "linux-headers-azure-edge": "5.4.0.1068.47",
            "linux-image-azure-edge": "5.4.0.1068.47",
            "linux-signed-azure-edge": "5.4.0.1068.47",
            "linux-signed-image-azure-edge": "5.4.0.1068.47",
            "linux-cloud-tools-5.4.0-1068-azure": "5.4.0-1068.71~18.04.1",
            "linux-azure-5.4-cloud-tools-5.4.0-1068": "5.4.0-1068.71~18.04.1",
            "linux-modules-5.4.0-1068-azure": "5.4.0-1068.71~18.04.1"
        }
    ]
}

Ubuntu:18.04:LTS / linux-gkeop-5.4

Package

Name
linux-gkeop-5.4

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
5.4.0-1032.33~18.04.1

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "linux-image-gkeop-5.4": "5.4.0.1032.33~18.04.32",
            "linux-buildinfo-5.4.0-1032-gkeop": "5.4.0-1032.33~18.04.1",
            "linux-gkeop-5.4": "5.4.0.1032.33~18.04.32",
            "linux-cloud-tools-5.4.0-1032-gkeop": "5.4.0-1032.33~18.04.1",
            "linux-headers-gkeop-5.4": "5.4.0.1032.33~18.04.32",
            "linux-modules-extra-5.4.0-1032-gkeop": "5.4.0-1032.33~18.04.1",
            "linux-headers-5.4.0-1032-gkeop": "5.4.0-1032.33~18.04.1",
            "linux-gkeop-5.4-headers-5.4.0-1032": "5.4.0-1032.33~18.04.1",
            "linux-image-unsigned-5.4.0-1032-gkeop": "5.4.0-1032.33~18.04.1",
            "linux-tools-5.4.0-1032-gkeop": "5.4.0-1032.33~18.04.1",
            "linux-cloud-tools-gkeop-5.4": "5.4.0.1032.33~18.04.32",
            "linux-gkeop-5.4-cloud-tools-5.4.0-1032": "5.4.0-1032.33~18.04.1",
            "linux-gkeop-5.4-tools-5.4.0-1032": "5.4.0-1032.33~18.04.1",
            "linux-modules-extra-gkeop-5.4": "5.4.0.1032.33~18.04.32",
            "linux-gkeop-5.4-source-5.4.0": "5.4.0-1032.33~18.04.1",
            "linux-modules-5.4.0-1032-gkeop": "5.4.0-1032.33~18.04.1",
            "linux-tools-gkeop-5.4": "5.4.0.1032.33~18.04.32",
            "linux-image-5.4.0-1032-gkeop": "5.4.0-1032.33~18.04.1"
        }
    ]
}

Ubuntu:18.04:LTS / linux-hwe-5.4

Package

Name
linux-hwe-5.4

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
5.4.0-97.110~18.04.1

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "linux-headers-snapdragon-hwe-18.04-edge": "5.4.0.97.110~18.04.85",
            "linux-headers-oem": "5.4.0.97.110~18.04.85",
            "linux-image-snapdragon-hwe-18.04-edge": "5.4.0.97.110~18.04.85",
            "linux-tools-virtual-hwe-18.04-edge": "5.4.0.97.110~18.04.85",
            "linux-generic-hwe-18.04": "5.4.0.97.110~18.04.85",
            "linux-lowlatency-hwe-18.04": "5.4.0.97.110~18.04.85",
            "linux-lowlatency-hwe-18.04-edge": "5.4.0.97.110~18.04.85",
            "linux-buildinfo-5.4.0-97-generic": "5.4.0-97.110~18.04.1",
            "linux-snapdragon-hwe-18.04": "5.4.0.97.110~18.04.85",
            "linux-tools-generic-lpae-hwe-18.04": "5.4.0.97.110~18.04.85",
            "linux-tools-snapdragon-hwe-18.04-edge": "5.4.0.97.110~18.04.85",
            "linux-generic-lpae-hwe-18.04": "5.4.0.97.110~18.04.85",
            "linux-headers-generic-hwe-18.04": "5.4.0.97.110~18.04.85",
            "linux-image-unsigned-5.4.0-97-lowlatency": "5.4.0-97.110~18.04.1",
            "linux-generic-lpae-hwe-18.04-edge": "5.4.0.97.110~18.04.85",
            "linux-headers-lowlatency-hwe-18.04-edge": "5.4.0.97.110~18.04.85",
            "linux-cloud-tools-generic-hwe-18.04": "5.4.0.97.110~18.04.85",
            "linux-snapdragon-hwe-18.04-edge": "5.4.0.97.110~18.04.85",
            "linux-oem": "5.4.0.97.110~18.04.85",
            "linux-modules-5.4.0-97-generic": "5.4.0-97.110~18.04.1",
            "linux-headers-5.4.0-97-generic-lpae": "5.4.0-97.110~18.04.1",
            "linux-modules-5.4.0-97-lowlatency": "5.4.0-97.110~18.04.1",
            "linux-cloud-tools-lowlatency-hwe-18.04-edge": "5.4.0.97.110~18.04.85",
            "linux-buildinfo-5.4.0-97-generic-lpae": "5.4.0-97.110~18.04.1",
            "linux-hwe-5.4-cloud-tools-common": "5.4.0-97.110~18.04.1",
            "linux-image-generic-hwe-18.04-edge": "5.4.0.97.110~18.04.85",
            "linux-image-generic-lpae-hwe-18.04": "5.4.0.97.110~18.04.85",
            "linux-cloud-tools-lowlatency-hwe-18.04": "5.4.0.97.110~18.04.85",
            "linux-headers-5.4.0-97-lowlatency": "5.4.0-97.110~18.04.1",
            "linux-headers-lowlatency-hwe-18.04": "5.4.0.97.110~18.04.85",
            "linux-headers-virtual-hwe-18.04-edge": "5.4.0.97.110~18.04.85",
            "linux-tools-generic-hwe-18.04-edge": "5.4.0.97.110~18.04.85",
            "linux-modules-extra-virtual-hwe-18.04": "5.4.0.97.110~18.04.85",
            "linux-image-5.4.0-97-generic": "5.4.0-97.110~18.04.1",
            "linux-generic-hwe-18.04-edge": "5.4.0.97.110~18.04.85",
            "linux-tools-lowlatency-hwe-18.04-edge": "5.4.0.97.110~18.04.85",
            "linux-headers-snapdragon-hwe-18.04": "5.4.0.97.110~18.04.85",
            "linux-headers-generic-hwe-18.04-edge": "5.4.0.97.110~18.04.85",
            "linux-headers-oem-osp1": "5.4.0.97.110~18.04.85",
            "linux-tools-5.4.0-97-generic": "5.4.0-97.110~18.04.1",
            "linux-image-unsigned-5.4.0-97-generic": "5.4.0-97.110~18.04.1",
            "linux-hwe-5.4-source-5.4.0": "5.4.0-97.110~18.04.1",
            "linux-hwe-5.4-headers-5.4.0-97": "5.4.0-97.110~18.04.1",
            "linux-image-lowlatency-hwe-18.04-edge": "5.4.0.97.110~18.04.85",
            "linux-cloud-tools-generic-hwe-18.04-edge": "5.4.0.97.110~18.04.85",
            "linux-headers-generic-lpae-hwe-18.04": "5.4.0.97.110~18.04.85",
            "linux-image-lowlatency-hwe-18.04": "5.4.0.97.110~18.04.85",
            "linux-headers-virtual-hwe-18.04": "5.4.0.97.110~18.04.85",
            "linux-headers-5.4.0-97-generic": "5.4.0-97.110~18.04.1",
            "linux-tools-oem-osp1": "5.4.0.97.110~18.04.85",
            "linux-modules-extra-virtual-hwe-18.04-edge": "5.4.0.97.110~18.04.85",
            "linux-image-5.4.0-97-generic-lpae": "5.4.0-97.110~18.04.1",
            "linux-oem-osp1": "5.4.0.97.110~18.04.85",
            "linux-image-virtual-hwe-18.04-edge": "5.4.0.97.110~18.04.85",
            "linux-cloud-tools-5.4.0-97-lowlatency": "5.4.0-97.110~18.04.1",
            "linux-tools-oem": "5.4.0.97.110~18.04.85",
            "linux-tools-generic-lpae-hwe-18.04-edge": "5.4.0.97.110~18.04.85",
            "linux-hwe-5.4-tools-common": "5.4.0-97.110~18.04.1",
            "linux-virtual-hwe-18.04": "5.4.0.97.110~18.04.85",
            "linux-image-oem": "5.4.0.97.110~18.04.85",
            "linux-cloud-tools-virtual-hwe-18.04-edge": "5.4.0.97.110~18.04.85",
            "linux-tools-5.4.0-97-lowlatency": "5.4.0-97.110~18.04.1",
            "linux-tools-5.4.0-97-generic-lpae": "5.4.0-97.110~18.04.1",
            "linux-image-5.4.0-97-lowlatency": "5.4.0-97.110~18.04.1",
            "linux-image-generic-lpae-hwe-18.04-edge": "5.4.0.97.110~18.04.85",
            "linux-cloud-tools-5.4.0-97-generic": "5.4.0-97.110~18.04.1",
            "linux-virtual-hwe-18.04-edge": "5.4.0.97.110~18.04.85",
            "linux-image-generic-hwe-18.04": "5.4.0.97.110~18.04.85",
            "linux-hwe-5.4-tools-5.4.0-97": "5.4.0-97.110~18.04.1",
            "linux-hwe-5.4-cloud-tools-5.4.0-97": "5.4.0-97.110~18.04.1",
            "linux-image-virtual-hwe-18.04": "5.4.0.97.110~18.04.85",
            "linux-modules-extra-5.4.0-97-generic": "5.4.0-97.110~18.04.1",
            "linux-tools-virtual-hwe-18.04": "5.4.0.97.110~18.04.85",
            "linux-image-oem-osp1": "5.4.0.97.110~18.04.85",
            "linux-image-extra-virtual-hwe-18.04-edge": "5.4.0.97.110~18.04.85",
            "linux-headers-generic-lpae-hwe-18.04-edge": "5.4.0.97.110~18.04.85",
            "linux-image-snapdragon-hwe-18.04": "5.4.0.97.110~18.04.85",
            "linux-cloud-tools-virtual-hwe-18.04": "5.4.0.97.110~18.04.85",
            "linux-buildinfo-5.4.0-97-lowlatency": "5.4.0-97.110~18.04.1",
            "linux-modules-5.4.0-97-generic-lpae": "5.4.0-97.110~18.04.1",
            "linux-tools-snapdragon-hwe-18.04": "5.4.0.97.110~18.04.85",
            "linux-tools-generic-hwe-18.04": "5.4.0.97.110~18.04.85",
            "linux-tools-lowlatency-hwe-18.04": "5.4.0.97.110~18.04.85",
            "linux-image-extra-virtual-hwe-18.04": "5.4.0.97.110~18.04.85"
        }
    ]
}

Ubuntu:18.04:LTS / linux-oracle-5.4

Package

Name
linux-oracle-5.4

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
5.4.0-1062.66~18.04.1

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "linux-modules-extra-oracle": "5.4.0.1062.66~18.04.41",
            "linux-image-oracle": "5.4.0.1062.66~18.04.41",
            "linux-image-5.4.0-1062-oracle": "5.4.0-1062.66~18.04.1",
            "linux-oracle-edge": "5.4.0.1062.66~18.04.41",
            "linux-tools-5.4.0-1062-oracle": "5.4.0-1062.66~18.04.1",
            "linux-signed-oracle-edge": "5.4.0.1062.66~18.04.41",
            "linux-image-unsigned-5.4.0-1062-oracle": "5.4.0-1062.66~18.04.1",
            "linux-headers-5.4.0-1062-oracle": "5.4.0-1062.66~18.04.1",
            "linux-buildinfo-5.4.0-1062-oracle": "5.4.0-1062.66~18.04.1",
            "linux-tools-oracle-edge": "5.4.0.1062.66~18.04.41",
            "linux-signed-image-oracle": "5.4.0.1062.66~18.04.41",
            "linux-signed-oracle": "5.4.0.1062.66~18.04.41",
            "linux-oracle": "5.4.0.1062.66~18.04.41",
            "linux-modules-extra-5.4.0-1062-oracle": "5.4.0-1062.66~18.04.1",
            "linux-headers-oracle": "5.4.0.1062.66~18.04.41",
            "linux-oracle-5.4-headers-5.4.0-1062": "5.4.0-1062.66~18.04.1",
            "linux-modules-5.4.0-1062-oracle": "5.4.0-1062.66~18.04.1",
            "linux-image-oracle-edge": "5.4.0.1062.66~18.04.41",
            "linux-signed-image-oracle-edge": "5.4.0.1062.66~18.04.41",
            "linux-headers-oracle-edge": "5.4.0.1062.66~18.04.41",
            "linux-tools-oracle": "5.4.0.1062.66~18.04.41",
            "linux-oracle-5.4-tools-5.4.0-1062": "5.4.0-1062.66~18.04.1",
            "linux-modules-extra-oracle-edge": "5.4.0.1062.66~18.04.41"
        }
    ]
}

Ubuntu:18.04:LTS / linux-aws-5.4

Package

Name
linux-aws-5.4

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
5.4.0-1064.67~18.04.1

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "linux-aws-5.4-headers-5.4.0-1064": "5.4.0-1064.67~18.04.1",
            "linux-image-aws-edge": "5.4.0.1064.46",
            "linux-headers-aws": "5.4.0.1064.46",
            "linux-headers-5.4.0-1064-aws": "5.4.0-1064.67~18.04.1",
            "linux-image-aws": "5.4.0.1064.46",
            "linux-aws": "5.4.0.1064.46",
            "linux-aws-5.4-tools-5.4.0-1064": "5.4.0-1064.67~18.04.1",
            "linux-image-unsigned-5.4.0-1064-aws": "5.4.0-1064.67~18.04.1",
            "linux-modules-extra-aws": "5.4.0.1064.46",
            "linux-modules-extra-aws-edge": "5.4.0.1064.46",
            "linux-tools-aws-edge": "5.4.0.1064.46",
            "linux-buildinfo-5.4.0-1064-aws": "5.4.0-1064.67~18.04.1",
            "linux-cloud-tools-5.4.0-1064-aws": "5.4.0-1064.67~18.04.1",
            "linux-headers-aws-edge": "5.4.0.1064.46",
            "linux-modules-5.4.0-1064-aws": "5.4.0-1064.67~18.04.1",
            "linux-aws-edge": "5.4.0.1064.46",
            "linux-aws-5.4-cloud-tools-5.4.0-1064": "5.4.0-1064.67~18.04.1",
            "linux-modules-extra-5.4.0-1064-aws": "5.4.0-1064.67~18.04.1",
            "linux-tools-5.4.0-1064-aws": "5.4.0-1064.67~18.04.1",
            "linux-tools-aws": "5.4.0.1064.46"
        }
    ]
}

Ubuntu:20.04:LTS / linux-gkeop

Package

Name
linux-gkeop

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
5.4.0-1032.33

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "linux-image-gkeop-5.4": "5.4.0.1032.35",
            "linux-buildinfo-5.4.0-1032-gkeop": "5.4.0-1032.33",
            "linux-gkeop-5.4": "5.4.0.1032.35",
            "linux-gkeop-headers-5.4.0-1032": "5.4.0-1032.33",
            "linux-cloud-tools-5.4.0-1032-gkeop": "5.4.0-1032.33",
            "linux-tools-gkeop": "5.4.0.1032.35",
            "linux-cloud-tools-gkeop": "5.4.0.1032.35",
            "linux-gkeop": "5.4.0.1032.35",
            "linux-modules-extra-5.4.0-1032-gkeop": "5.4.0-1032.33",
            "linux-headers-gkeop-5.4": "5.4.0.1032.35",
            "linux-modules-extra-gkeop": "5.4.0.1032.35",
            "linux-headers-5.4.0-1032-gkeop": "5.4.0-1032.33",
            "linux-image-unsigned-5.4.0-1032-gkeop": "5.4.0-1032.33",
            "linux-image-gkeop": "5.4.0.1032.35",
            "linux-gkeop-tools-5.4.0-1032": "5.4.0-1032.33",
            "linux-tools-5.4.0-1032-gkeop": "5.4.0-1032.33",
            "linux-cloud-tools-gkeop-5.4": "5.4.0.1032.35",
            "linux-gkeop-source-5.4.0": "5.4.0-1032.33",
            "linux-modules-extra-gkeop-5.4": "5.4.0.1032.35",
            "linux-gkeop-cloud-tools-5.4.0-1032": "5.4.0-1032.33",
            "linux-modules-5.4.0-1032-gkeop": "5.4.0-1032.33",
            "linux-tools-gkeop-5.4": "5.4.0.1032.35",
            "linux-image-5.4.0-1032-gkeop": "5.4.0-1032.33",
            "linux-headers-gkeop": "5.4.0.1032.35"
        }
    ]
}

Ubuntu:20.04:LTS / linux-bluefield

Package

Name
linux-bluefield

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
5.4.0-1026.29

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "linux-bluefield-tools-5.4.0-1026": "5.4.0-1026.29",
            "linux-buildinfo-5.4.0-1026-bluefield": "5.4.0-1026.29",
            "linux-modules-5.4.0-1026-bluefield": "5.4.0-1026.29",
            "linux-image-5.4.0-1026-bluefield": "5.4.0-1026.29",
            "linux-tools-5.4.0-1026-bluefield": "5.4.0-1026.29",
            "linux-image-bluefield": "5.4.0.1026.27",
            "linux-headers-bluefield": "5.4.0.1026.27",
            "linux-tools-bluefield": "5.4.0.1026.27",
            "linux-headers-5.4.0-1026-bluefield": "5.4.0-1026.29",
            "linux-bluefield-headers-5.4.0-1026": "5.4.0-1026.29",
            "linux-image-unsigned-5.4.0-1026-bluefield": "5.4.0-1026.29",
            "linux-bluefield": "5.4.0.1026.27"
        }
    ]
}

Ubuntu:20.04:LTS / linux-azure

Package

Name
linux-azure

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
5.4.0-1068.71

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "linux-tools-azure-lts-20.04": "5.4.0.1068.66",
            "linux-headers-5.4.0-1068-azure": "5.4.0-1068.71",
            "linux-tools-5.4.0-1068-azure": "5.4.0-1068.71",
            "linux-buildinfo-5.4.0-1068-azure": "5.4.0-1068.71",
            "linux-azure-tools-5.4.0-1068": "5.4.0-1068.71",
            "linux-azure-cloud-tools-5.4.0-1068": "5.4.0-1068.71",
            "linux-modules-extra-azure-lts-20.04": "5.4.0.1068.66",
            "linux-modules-extra-5.4.0-1068-azure": "5.4.0-1068.71",
            "linux-image-unsigned-5.4.0-1068-azure": "5.4.0-1068.71",
            "linux-image-azure-lts-20.04": "5.4.0.1068.66",
            "linux-headers-azure-lts-20.04": "5.4.0.1068.66",
            "linux-image-5.4.0-1068-azure": "5.4.0-1068.71",
            "linux-cloud-tools-azure-lts-20.04": "5.4.0.1068.66",
            "linux-azure-headers-5.4.0-1068": "5.4.0-1068.71",
            "linux-azure-lts-20.04": "5.4.0.1068.66",
            "linux-cloud-tools-5.4.0-1068-azure": "5.4.0-1068.71",
            "linux-modules-5.4.0-1068-azure": "5.4.0-1068.71"
        }
    ]
}

Ubuntu:20.04:LTS / linux-kvm

Package

Name
linux-kvm

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
5.4.0-1054.56

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "linux-headers-kvm": "5.4.0.1054.53",
            "linux-tools-5.4.0-1054-kvm": "5.4.0-1054.56",
            "linux-kvm": "5.4.0.1054.53",
            "linux-kvm-tools-5.4.0-1054": "5.4.0-1054.56",
            "linux-image-5.4.0-1054-kvm": "5.4.0-1054.56",
            "linux-headers-5.4.0-1054-kvm": "5.4.0-1054.56",
            "linux-kvm-headers-5.4.0-1054": "5.4.0-1054.56",
            "linux-tools-kvm": "5.4.0.1054.53",
            "linux-buildinfo-5.4.0-1054-kvm": "5.4.0-1054.56",
            "linux-modules-5.4.0-1054-kvm": "5.4.0-1054.56",
            "linux-image-unsigned-5.4.0-1054-kvm": "5.4.0-1054.56",
            "linux-image-kvm": "5.4.0.1054.53"
        }
    ]
}

Ubuntu:20.04:LTS / linux-aws

Package

Name
linux-aws

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
5.4.0-1064.67

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "linux-modules-extra-aws-lts-20.04": "5.4.0.1064.66",
            "linux-aws-headers-5.4.0-1064": "5.4.0-1064.67",
            "linux-headers-5.4.0-1064-aws": "5.4.0-1064.67",
            "linux-image-5.4.0-1064-aws": "5.4.0-1064.67",
            "linux-aws-tools-5.4.0-1064": "5.4.0-1064.67",
            "linux-aws-lts-20.04": "5.4.0.1064.66",
            "linux-tools-aws-lts-20.04": "5.4.0.1064.66",
            "linux-aws-cloud-tools-5.4.0-1064": "5.4.0-1064.67",
            "linux-headers-aws-lts-20.04": "5.4.0.1064.66",
            "linux-image-unsigned-5.4.0-1064-aws": "5.4.0-1064.67",
            "linux-buildinfo-5.4.0-1064-aws": "5.4.0-1064.67",
            "linux-cloud-tools-5.4.0-1064-aws": "5.4.0-1064.67",
            "linux-modules-5.4.0-1064-aws": "5.4.0-1064.67",
            "linux-tools-5.4.0-1064-aws": "5.4.0-1064.67",
            "linux-modules-extra-5.4.0-1064-aws": "5.4.0-1064.67",
            "linux-image-aws-lts-20.04": "5.4.0.1064.66"
        }
    ]
}

Ubuntu:20.04:LTS / linux-oracle

Package

Name
linux-oracle

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
5.4.0-1062.66

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "linux-oracle-tools-5.4.0-1062": "5.4.0-1062.66",
            "linux-oracle-headers-5.4.0-1062": "5.4.0-1062.66",
            "linux-image-5.4.0-1062-oracle": "5.4.0-1062.66",
            "linux-oracle-lts-20.04": "5.4.0.1062.62",
            "linux-modules-extra-5.4.0-1062-oracle": "5.4.0-1062.66",
            "linux-headers-oracle-lts-20.04": "5.4.0.1062.62",
            "linux-tools-5.4.0-1062-oracle": "5.4.0-1062.66",
            "linux-image-oracle-lts-20.04": "5.4.0.1062.62",
            "linux-modules-5.4.0-1062-oracle": "5.4.0-1062.66",
            "linux-image-unsigned-5.4.0-1062-oracle": "5.4.0-1062.66",
            "linux-headers-5.4.0-1062-oracle": "5.4.0-1062.66",
            "linux-buildinfo-5.4.0-1062-oracle": "5.4.0-1062.66",
            "linux-tools-oracle-lts-20.04": "5.4.0.1062.62"
        }
    ]
}

Ubuntu:20.04:LTS / linux

Package

Name
linux

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
5.4.0-97.110

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "linux-generic-hwe-18.04": "5.4.0.97.101",
            "linux-headers-oem": "5.4.0.97.101",
            "linux-tools-virtual-hwe-18.04-edge": "5.4.0.97.101",
            "linux-cloud-tools-5.4.0-97": "5.4.0-97.110",
            "linux-lowlatency-hwe-18.04": "5.4.0.97.101",
            "linux-cloud-tools-virtual": "5.4.0.97.101",
            "linux-buildinfo-5.4.0-97-generic": "5.4.0-97.110",
            "linux-cloud-tools-lowlatency": "5.4.0.97.101",
            "linux-tools-generic-lpae-hwe-18.04": "5.4.0.97.101",
            "linux-headers-lowlatency-hwe-18.04-edge": "5.4.0.97.101",
            "linux-generic-lpae-hwe-18.04": "5.4.0.97.101",
            "linux-headers-generic-hwe-18.04": "5.4.0.97.101",
            "linux-generic-lpae-hwe-18.04-edge": "5.4.0.97.101",
            "linux-tools-virtual": "5.4.0.97.101",
            "linux-oem-osp1-tools-host": "5.4.0.97.101",
            "linux-cloud-tools-generic-hwe-18.04": "5.4.0.97.101",
            "linux-image-unsigned-5.4.0-97-lowlatency": "5.4.0-97.110",
            "linux-lowlatency-hwe-18.04-edge": "5.4.0.97.101",
            "linux-source": "5.4.0.97.101",
            "linux-image-extra-virtual": "5.4.0.97.101",
            "linux-oem": "5.4.0.97.101",
            "linux-cloud-tools-generic": "5.4.0.97.101",
            "linux-image-virtual": "5.4.0.97.101",
            "linux-modules-5.4.0-97-generic": "5.4.0-97.110",
            "linux-tools-generic": "5.4.0.97.101",
            "linux-headers-5.4.0-97-generic-lpae": "5.4.0-97.110",
            "linux-generic-lpae": "5.4.0.97.101",
            "linux-modules-5.4.0-97-lowlatency": "5.4.0-97.110",
            "linux-virtual": "5.4.0.97.101",
            "linux-cloud-tools-lowlatency-hwe-18.04-edge": "5.4.0.97.101",
            "linux-buildinfo-5.4.0-97-generic-lpae": "5.4.0-97.110",
            "linux-image-generic-hwe-18.04-edge": "5.4.0.97.101",
            "linux-image-generic-lpae-hwe-18.04": "5.4.0.97.101",
            "linux-crashdump": "5.4.0.97.101",
            "linux-cloud-tools-lowlatency-hwe-18.04": "5.4.0.97.101",
            "linux-headers-5.4.0-97-lowlatency": "5.4.0-97.110",
            "linux-generic": "5.4.0.97.101",
            "linux-headers-lowlatency-hwe-18.04": "5.4.0.97.101",
            "linux-headers-virtual-hwe-18.04-edge": "5.4.0.97.101",
            "linux-tools-generic-hwe-18.04-edge": "5.4.0.97.101",
            "linux-image-5.4.0-97-generic": "5.4.0-97.110",
            "linux-generic-hwe-18.04-edge": "5.4.0.97.101",
            "linux-headers-generic-lpae": "5.4.0.97.101",
            "linux-tools-lowlatency-hwe-18.04-edge": "5.4.0.97.101",
            "linux-image-generic-lpae": "5.4.0.97.101",
            "linux-tools-lowlatency": "5.4.0.97.101",
            "linux-headers-oem-osp1": "5.4.0.97.101",
            "linux-cloud-tools-common": "5.4.0-97.110",
            "linux-tools-5.4.0-97-generic": "5.4.0-97.110",
            "linux-image-unsigned-5.4.0-97-generic": "5.4.0-97.110",
            "linux-headers-generic-lpae-hwe-18.04": "5.4.0.97.101",
            "linux-libc-dev": "5.4.0-97.110",
            "linux-source-5.4.0": "5.4.0-97.110",
            "linux-cloud-tools-generic-hwe-18.04-edge": "5.4.0.97.101",
            "linux-image-lowlatency-hwe-18.04-edge": "5.4.0.97.101",
            "linux-doc": "5.4.0-97.110",
            "linux-headers-virtual-hwe-18.04": "5.4.0.97.101",
            "linux-headers-5.4.0-97-generic": "5.4.0-97.110",
            "linux-tools-oem-osp1": "5.4.0.97.101",
            "linux-oem-osp1": "5.4.0.97.101",
            "linux-image-5.4.0-97-generic-lpae": "5.4.0-97.110",
            "linux-image-lowlatency-hwe-18.04": "5.4.0.97.101",
            "linux-image-virtual-hwe-18.04-edge": "5.4.0.97.101",
            "linux-cloud-tools-5.4.0-97-lowlatency": "5.4.0-97.110",
            "linux-headers-generic": "5.4.0.97.101",
            "linux-tools-oem": "5.4.0.97.101",
            "linux-image-lowlatency": "5.4.0.97.101",
            "linux-oem-tools-host": "5.4.0.97.101",
            "linux-tools-generic-lpae-hwe-18.04-edge": "5.4.0.97.101",
            "linux-headers-virtual": "5.4.0.97.101",
            "linux-headers-lowlatency": "5.4.0.97.101",
            "linux-virtual-hwe-18.04": "5.4.0.97.101",
            "linux-image-oem": "5.4.0.97.101",
            "linux-cloud-tools-virtual-hwe-18.04-edge": "5.4.0.97.101",
            "linux-headers-generic-hwe-18.04-edge": "5.4.0.97.101",
            "linux-tools-5.4.0-97-lowlatency": "5.4.0-97.110",
            "linux-tools-host": "5.4.0-97.110",
            "linux-tools-5.4.0-97-generic-lpae": "5.4.0-97.110",
            "linux-image-5.4.0-97-lowlatency": "5.4.0-97.110",
            "linux-image-generic-lpae-hwe-18.04-edge": "5.4.0.97.101",
            "linux-cloud-tools-5.4.0-97-generic": "5.4.0-97.110",
            "linux-virtual-hwe-18.04-edge": "5.4.0.97.101",
            "linux-image-generic-hwe-18.04": "5.4.0.97.101",
            "linux-cloud-tools-virtual-hwe-18.04": "5.4.0.97.101",
            "linux-image-virtual-hwe-18.04": "5.4.0.97.101",
            "linux-modules-extra-5.4.0-97-generic": "5.4.0-97.110",
            "linux-image-oem-osp1": "5.4.0.97.101",
            "linux-tools-generic-lpae": "5.4.0.97.101",
            "linux-image-extra-virtual-hwe-18.04-edge": "5.4.0.97.101",
            "linux-headers-generic-lpae-hwe-18.04-edge": "5.4.0.97.101",
            "linux-tools-virtual-hwe-18.04": "5.4.0.97.101",
            "linux-tools-5.4.0-97": "5.4.0-97.110",
            "linux-buildinfo-5.4.0-97-lowlatency": "5.4.0-97.110",
            "linux-headers-5.4.0-97": "5.4.0-97.110",
            "linux-modules-5.4.0-97-generic-lpae": "5.4.0-97.110",
            "linux-tools-common": "5.4.0-97.110",
            "linux-tools-generic-hwe-18.04": "5.4.0.97.101",
            "linux-image-generic": "5.4.0.97.101",
            "linux-lowlatency": "5.4.0.97.101",
            "linux-tools-lowlatency-hwe-18.04": "5.4.0.97.101",
            "linux-image-extra-virtual-hwe-18.04": "5.4.0.97.101"
        }
    ]
}

Ubuntu:20.04:LTS / linux-gcp

Package

Name
linux-gcp

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
5.4.0-1063.67

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "linux-gcp-tools-5.4.0-1063": "5.4.0-1063.67",
            "linux-modules-extra-gcp-lts-20.04": "5.4.0.1063.73",
            "linux-image-gcp-lts-20.04": "5.4.0.1063.73",
            "linux-image-5.4.0-1063-gcp": "5.4.0-1063.67",
            "linux-image-unsigned-5.4.0-1063-gcp": "5.4.0-1063.67",
            "linux-tools-gcp-lts-20.04": "5.4.0.1063.73",
            "linux-tools-5.4.0-1063-gcp": "5.4.0-1063.67",
            "linux-gcp-headers-5.4.0-1063": "5.4.0-1063.67",
            "linux-modules-extra-5.4.0-1063-gcp": "5.4.0-1063.67",
            "linux-modules-5.4.0-1063-gcp": "5.4.0-1063.67",
            "linux-buildinfo-5.4.0-1063-gcp": "5.4.0-1063.67",
            "linux-headers-gcp-lts-20.04": "5.4.0.1063.73",
            "linux-headers-5.4.0-1063-gcp": "5.4.0-1063.67",
            "linux-gcp-lts-20.04": "5.4.0.1063.73"
        }
    ]
}

Ubuntu:20.04:LTS / linux-ibm

Package

Name
linux-ibm

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
5.4.0-1013.14

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "linux-image-unsigned-5.4.0-1013-ibm": "5.4.0-1013.14",
            "linux-headers-ibm-lts-20.04": "5.4.0.1013.14",
            "linux-tools-ibm-lts-20.04": "5.4.0.1013.14",
            "linux-image-5.4.0-1013-ibm": "5.4.0-1013.14",
            "linux-modules-extra-ibm": "5.4.0.1013.14",
            "linux-modules-extra-5.4.0-1013-ibm": "5.4.0-1013.14",
            "linux-ibm-tools-5.4.0-1013": "5.4.0-1013.14",
            "linux-modules-5.4.0-1013-ibm": "5.4.0-1013.14",
            "linux-ibm-lts-20.04": "5.4.0.1013.14",
            "linux-tools-ibm": "5.4.0.1013.14",
            "linux-ibm-tools-common": "5.4.0-1013.14",
            "linux-buildinfo-5.4.0-1013-ibm": "5.4.0-1013.14",
            "linux-headers-ibm": "5.4.0.1013.14",
            "linux-ibm": "5.4.0.1013.14",
            "linux-modules-extra-ibm-lts-20.04": "5.4.0.1013.14",
            "linux-headers-5.4.0-1013-ibm": "5.4.0-1013.14",
            "linux-tools-5.4.0-1013-ibm": "5.4.0-1013.14",
            "linux-image-ibm-lts-20.04": "5.4.0.1013.14",
            "linux-image-ibm": "5.4.0.1013.14",
            "linux-ibm-headers-5.4.0-1013": "5.4.0-1013.14",
            "linux-ibm-cloud-tools-common": "5.4.0-1013.14",
            "linux-ibm-source-5.4.0": "5.4.0-1013.14"
        }
    ]
}