USN-5312-1

See a problem?
Source
https://ubuntu.com/security/notices/USN-5312-1
Import Source
https://github.com/canonical/ubuntu-security-notices/blob/main/osv/USN-5312-1.json
JSON Data
https://api.osv.dev/v1/vulns/USN-5312-1
Related
Published
2022-03-03T13:18:40.080843Z
Modified
2022-03-03T13:18:40.080843Z
Summary
haproxy vulnerability
Details

It was discovered that HAProxy incorrectly handled certain headers. A remote attacker could possibly use this issue to cause HAProxy to stop responding, resulting in a denial of service.

References

Affected packages

Ubuntu:20.04:LTS / haproxy

Package

Name
haproxy

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
2.0.13-2ubuntu0.5

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "haproxy": "2.0.13-2ubuntu0.5",
            "haproxy-doc": "2.0.13-2ubuntu0.5",
            "vim-haproxy": "2.0.13-2ubuntu0.5"
        }
    ]
}