USN-5314-1

See a problem?
Source
https://ubuntu.com/security/notices/USN-5314-1
Import Source
https://github.com/canonical/ubuntu-security-notices/blob/main/osv/USN-5314-1.json
JSON Data
https://api.osv.dev/v1/vulns/USN-5314-1
Related
  • CVE-2022-26485
  • CVE-2022-26486
Published
2022-03-06T21:11:47.291232Z
Modified
2022-03-06T21:11:47.291232Z
Summary
firefox vulnerabilities
Details

A use-after-free was discovered when removing an XSLT parameter in some circumstances. If a user were tricked into opening a specially crafted website, an attacker could exploit this to cause a denial of service, or execute arbitrary code. (CVE-2022-26485)

A use-after-free was discovered in the WebGPU IPC framework. If a user were tricked into opening a specially crafted website, an attacker could exploit this to cause a denial of service, or execute arbitrary code. (CVE-2022-26486)

References

Affected packages

Ubuntu:18.04:LTS / firefox

Package

Name
firefox

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
97.0.2+build1-0ubuntu0.18.04.1

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "firefox-locale-sl": "97.0.2+build1-0ubuntu0.18.04.1",
            "firefox-locale-nl": "97.0.2+build1-0ubuntu0.18.04.1",
            "firefox-locale-kn": "97.0.2+build1-0ubuntu0.18.04.1",
            "firefox-locale-gl": "97.0.2+build1-0ubuntu0.18.04.1",
            "firefox-locale-fy": "97.0.2+build1-0ubuntu0.18.04.1",
            "firefox-locale-kk": "97.0.2+build1-0ubuntu0.18.04.1",
            "firefox-locale-km": "97.0.2+build1-0ubuntu0.18.04.1",
            "firefox-locale-or": "97.0.2+build1-0ubuntu0.18.04.1",
            "firefox-locale-az": "97.0.2+build1-0ubuntu0.18.04.1",
            "firefox-locale-lt": "97.0.2+build1-0ubuntu0.18.04.1",
            "firefox-locale-hy": "97.0.2+build1-0ubuntu0.18.04.1",
            "firefox-locale-eo": "97.0.2+build1-0ubuntu0.18.04.1",
            "firefox-locale-sv": "97.0.2+build1-0ubuntu0.18.04.1",
            "firefox-locale-uk": "97.0.2+build1-0ubuntu0.18.04.1",
            "firefox-locale-sr": "97.0.2+build1-0ubuntu0.18.04.1",
            "firefox-locale-is": "97.0.2+build1-0ubuntu0.18.04.1",
            "firefox-locale-ca": "97.0.2+build1-0ubuntu0.18.04.1",
            "firefox-locale-ne": "97.0.2+build1-0ubuntu0.18.04.1",
            "firefox-locale-ga": "97.0.2+build1-0ubuntu0.18.04.1",
            "firefox-locale-ja": "97.0.2+build1-0ubuntu0.18.04.1",
            "firefox-locale-it": "97.0.2+build1-0ubuntu0.18.04.1",
            "firefox-locale-lg": "97.0.2+build1-0ubuntu0.18.04.1",
            "firefox-locale-ms": "97.0.2+build1-0ubuntu0.18.04.1",
            "firefox-locale-zh-hans": "97.0.2+build1-0ubuntu0.18.04.1",
            "firefox-locale-ia": "97.0.2+build1-0ubuntu0.18.04.1",
            "firefox-locale-ko": "97.0.2+build1-0ubuntu0.18.04.1",
            "firefox-locale-hr": "97.0.2+build1-0ubuntu0.18.04.1",
            "firefox-locale-mai": "97.0.2+build1-0ubuntu0.18.04.1",
            "firefox-locale-nb": "97.0.2+build1-0ubuntu0.18.04.1",
            "firefox-mozsymbols": "97.0.2+build1-0ubuntu0.18.04.1",
            "firefox-locale-vi": "97.0.2+build1-0ubuntu0.18.04.1",
            "firefox-dev": "97.0.2+build1-0ubuntu0.18.04.1",
            "firefox-locale-he": "97.0.2+build1-0ubuntu0.18.04.1",
            "firefox-locale-sw": "97.0.2+build1-0ubuntu0.18.04.1",
            "firefox-locale-el": "97.0.2+build1-0ubuntu0.18.04.1",
            "firefox-locale-oc": "97.0.2+build1-0ubuntu0.18.04.1",
            "firefox-locale-xh": "97.0.2+build1-0ubuntu0.18.04.1",
            "firefox-locale-nn": "97.0.2+build1-0ubuntu0.18.04.1",
            "firefox-geckodriver": "97.0.2+build1-0ubuntu0.18.04.1",
            "firefox-locale-ar": "97.0.2+build1-0ubuntu0.18.04.1",
            "firefox-locale-cs": "97.0.2+build1-0ubuntu0.18.04.1",
            "firefox-locale-gn": "97.0.2+build1-0ubuntu0.18.04.1",
            "firefox-locale-hsb": "97.0.2+build1-0ubuntu0.18.04.1",
            "firefox-locale-zu": "97.0.2+build1-0ubuntu0.18.04.1",
            "firefox-locale-my": "97.0.2+build1-0ubuntu0.18.04.1",
            "firefox-locale-ro": "97.0.2+build1-0ubuntu0.18.04.1",
            "firefox-locale-csb": "97.0.2+build1-0ubuntu0.18.04.1",
            "firefox-locale-nso": "97.0.2+build1-0ubuntu0.18.04.1",
            "firefox-locale-af": "97.0.2+build1-0ubuntu0.18.04.1",
            "firefox-locale-sk": "97.0.2+build1-0ubuntu0.18.04.1",
            "firefox-locale-szl": "97.0.2+build1-0ubuntu0.18.04.1",
            "firefox-locale-si": "97.0.2+build1-0ubuntu0.18.04.1",
            "firefox": "97.0.2+build1-0ubuntu0.18.04.1",
            "firefox-locale-cy": "97.0.2+build1-0ubuntu0.18.04.1",
            "firefox-locale-fa": "97.0.2+build1-0ubuntu0.18.04.1",
            "firefox-locale-cak": "97.0.2+build1-0ubuntu0.18.04.1",
            "firefox-locale-sq": "97.0.2+build1-0ubuntu0.18.04.1",
            "firefox-locale-en": "97.0.2+build1-0ubuntu0.18.04.1",
            "firefox-locale-tr": "97.0.2+build1-0ubuntu0.18.04.1",
            "firefox-locale-br": "97.0.2+build1-0ubuntu0.18.04.1",
            "firefox-locale-et": "97.0.2+build1-0ubuntu0.18.04.1",
            "firefox-locale-ast": "97.0.2+build1-0ubuntu0.18.04.1",
            "firefox-locale-th": "97.0.2+build1-0ubuntu0.18.04.1",
            "firefox-locale-da": "97.0.2+build1-0ubuntu0.18.04.1",
            "firefox-locale-fi": "97.0.2+build1-0ubuntu0.18.04.1",
            "firefox-locale-ku": "97.0.2+build1-0ubuntu0.18.04.1",
            "firefox-locale-mn": "97.0.2+build1-0ubuntu0.18.04.1",
            "firefox-locale-ru": "97.0.2+build1-0ubuntu0.18.04.1",
            "firefox-locale-mk": "97.0.2+build1-0ubuntu0.18.04.1",
            "firefox-locale-bg": "97.0.2+build1-0ubuntu0.18.04.1",
            "firefox-locale-hu": "97.0.2+build1-0ubuntu0.18.04.1",
            "firefox-locale-gu": "97.0.2+build1-0ubuntu0.18.04.1",
            "firefox-locale-bn": "97.0.2+build1-0ubuntu0.18.04.1",
            "firefox-locale-kab": "97.0.2+build1-0ubuntu0.18.04.1",
            "firefox-locale-ml": "97.0.2+build1-0ubuntu0.18.04.1",
            "firefox-locale-an": "97.0.2+build1-0ubuntu0.18.04.1",
            "firefox-locale-be": "97.0.2+build1-0ubuntu0.18.04.1",
            "firefox-locale-eu": "97.0.2+build1-0ubuntu0.18.04.1",
            "firefox-locale-fr": "97.0.2+build1-0ubuntu0.18.04.1",
            "firefox-locale-pa": "97.0.2+build1-0ubuntu0.18.04.1",
            "firefox-locale-as": "97.0.2+build1-0ubuntu0.18.04.1",
            "firefox-locale-id": "97.0.2+build1-0ubuntu0.18.04.1",
            "firefox-locale-pl": "97.0.2+build1-0ubuntu0.18.04.1",
            "firefox-locale-gd": "97.0.2+build1-0ubuntu0.18.04.1",
            "firefox-locale-te": "97.0.2+build1-0ubuntu0.18.04.1",
            "firefox-locale-lv": "97.0.2+build1-0ubuntu0.18.04.1",
            "firefox-locale-ka": "97.0.2+build1-0ubuntu0.18.04.1",
            "firefox-locale-ta": "97.0.2+build1-0ubuntu0.18.04.1",
            "firefox-locale-bs": "97.0.2+build1-0ubuntu0.18.04.1",
            "firefox-locale-uz": "97.0.2+build1-0ubuntu0.18.04.1",
            "firefox-locale-hi": "97.0.2+build1-0ubuntu0.18.04.1",
            "firefox-locale-zh-hant": "97.0.2+build1-0ubuntu0.18.04.1",
            "firefox-locale-es": "97.0.2+build1-0ubuntu0.18.04.1",
            "firefox-locale-ur": "97.0.2+build1-0ubuntu0.18.04.1",
            "firefox-locale-mr": "97.0.2+build1-0ubuntu0.18.04.1",
            "firefox-locale-pt": "97.0.2+build1-0ubuntu0.18.04.1",
            "firefox-locale-de": "97.0.2+build1-0ubuntu0.18.04.1"
        }
    ]
}

Ubuntu:20.04:LTS / firefox

Package

Name
firefox

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
97.0.2+build1-0ubuntu0.20.04.1

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "firefox-locale-sl": "97.0.2+build1-0ubuntu0.20.04.1",
            "firefox-locale-nl": "97.0.2+build1-0ubuntu0.20.04.1",
            "firefox-locale-kn": "97.0.2+build1-0ubuntu0.20.04.1",
            "firefox-locale-gl": "97.0.2+build1-0ubuntu0.20.04.1",
            "firefox-locale-fy": "97.0.2+build1-0ubuntu0.20.04.1",
            "firefox-locale-kk": "97.0.2+build1-0ubuntu0.20.04.1",
            "firefox-locale-km": "97.0.2+build1-0ubuntu0.20.04.1",
            "firefox-locale-or": "97.0.2+build1-0ubuntu0.20.04.1",
            "firefox-locale-az": "97.0.2+build1-0ubuntu0.20.04.1",
            "firefox-locale-lt": "97.0.2+build1-0ubuntu0.20.04.1",
            "firefox-locale-hy": "97.0.2+build1-0ubuntu0.20.04.1",
            "firefox-locale-eo": "97.0.2+build1-0ubuntu0.20.04.1",
            "firefox-locale-sv": "97.0.2+build1-0ubuntu0.20.04.1",
            "firefox-locale-uk": "97.0.2+build1-0ubuntu0.20.04.1",
            "firefox-locale-sr": "97.0.2+build1-0ubuntu0.20.04.1",
            "firefox-locale-is": "97.0.2+build1-0ubuntu0.20.04.1",
            "firefox-locale-ca": "97.0.2+build1-0ubuntu0.20.04.1",
            "firefox-locale-ne": "97.0.2+build1-0ubuntu0.20.04.1",
            "firefox-locale-ga": "97.0.2+build1-0ubuntu0.20.04.1",
            "firefox-locale-ja": "97.0.2+build1-0ubuntu0.20.04.1",
            "firefox-locale-it": "97.0.2+build1-0ubuntu0.20.04.1",
            "firefox-locale-lg": "97.0.2+build1-0ubuntu0.20.04.1",
            "firefox-locale-ms": "97.0.2+build1-0ubuntu0.20.04.1",
            "firefox-locale-zh-hans": "97.0.2+build1-0ubuntu0.20.04.1",
            "firefox-locale-ia": "97.0.2+build1-0ubuntu0.20.04.1",
            "firefox-locale-ko": "97.0.2+build1-0ubuntu0.20.04.1",
            "firefox-locale-hr": "97.0.2+build1-0ubuntu0.20.04.1",
            "firefox-locale-mai": "97.0.2+build1-0ubuntu0.20.04.1",
            "firefox-locale-nb": "97.0.2+build1-0ubuntu0.20.04.1",
            "firefox-mozsymbols": "97.0.2+build1-0ubuntu0.20.04.1",
            "firefox-locale-vi": "97.0.2+build1-0ubuntu0.20.04.1",
            "firefox-dev": "97.0.2+build1-0ubuntu0.20.04.1",
            "firefox-locale-he": "97.0.2+build1-0ubuntu0.20.04.1",
            "firefox-locale-sw": "97.0.2+build1-0ubuntu0.20.04.1",
            "firefox-locale-el": "97.0.2+build1-0ubuntu0.20.04.1",
            "firefox-locale-oc": "97.0.2+build1-0ubuntu0.20.04.1",
            "firefox-locale-xh": "97.0.2+build1-0ubuntu0.20.04.1",
            "firefox-locale-nn": "97.0.2+build1-0ubuntu0.20.04.1",
            "firefox-geckodriver": "97.0.2+build1-0ubuntu0.20.04.1",
            "firefox-locale-ar": "97.0.2+build1-0ubuntu0.20.04.1",
            "firefox-locale-cs": "97.0.2+build1-0ubuntu0.20.04.1",
            "firefox-locale-gn": "97.0.2+build1-0ubuntu0.20.04.1",
            "firefox-locale-hsb": "97.0.2+build1-0ubuntu0.20.04.1",
            "firefox-locale-zu": "97.0.2+build1-0ubuntu0.20.04.1",
            "firefox-locale-my": "97.0.2+build1-0ubuntu0.20.04.1",
            "firefox-locale-ro": "97.0.2+build1-0ubuntu0.20.04.1",
            "firefox-locale-csb": "97.0.2+build1-0ubuntu0.20.04.1",
            "firefox-locale-nso": "97.0.2+build1-0ubuntu0.20.04.1",
            "firefox-locale-af": "97.0.2+build1-0ubuntu0.20.04.1",
            "firefox-locale-sk": "97.0.2+build1-0ubuntu0.20.04.1",
            "firefox-locale-szl": "97.0.2+build1-0ubuntu0.20.04.1",
            "firefox-locale-si": "97.0.2+build1-0ubuntu0.20.04.1",
            "firefox": "97.0.2+build1-0ubuntu0.20.04.1",
            "firefox-locale-cy": "97.0.2+build1-0ubuntu0.20.04.1",
            "firefox-locale-fa": "97.0.2+build1-0ubuntu0.20.04.1",
            "firefox-locale-cak": "97.0.2+build1-0ubuntu0.20.04.1",
            "firefox-locale-sq": "97.0.2+build1-0ubuntu0.20.04.1",
            "firefox-locale-en": "97.0.2+build1-0ubuntu0.20.04.1",
            "firefox-locale-tr": "97.0.2+build1-0ubuntu0.20.04.1",
            "firefox-locale-br": "97.0.2+build1-0ubuntu0.20.04.1",
            "firefox-locale-et": "97.0.2+build1-0ubuntu0.20.04.1",
            "firefox-locale-ast": "97.0.2+build1-0ubuntu0.20.04.1",
            "firefox-locale-th": "97.0.2+build1-0ubuntu0.20.04.1",
            "firefox-locale-da": "97.0.2+build1-0ubuntu0.20.04.1",
            "firefox-locale-fi": "97.0.2+build1-0ubuntu0.20.04.1",
            "firefox-locale-ku": "97.0.2+build1-0ubuntu0.20.04.1",
            "firefox-locale-mn": "97.0.2+build1-0ubuntu0.20.04.1",
            "firefox-locale-ru": "97.0.2+build1-0ubuntu0.20.04.1",
            "firefox-locale-mk": "97.0.2+build1-0ubuntu0.20.04.1",
            "firefox-locale-bg": "97.0.2+build1-0ubuntu0.20.04.1",
            "firefox-locale-hu": "97.0.2+build1-0ubuntu0.20.04.1",
            "firefox-locale-gu": "97.0.2+build1-0ubuntu0.20.04.1",
            "firefox-locale-bn": "97.0.2+build1-0ubuntu0.20.04.1",
            "firefox-locale-kab": "97.0.2+build1-0ubuntu0.20.04.1",
            "firefox-locale-ml": "97.0.2+build1-0ubuntu0.20.04.1",
            "firefox-locale-an": "97.0.2+build1-0ubuntu0.20.04.1",
            "firefox-locale-be": "97.0.2+build1-0ubuntu0.20.04.1",
            "firefox-locale-eu": "97.0.2+build1-0ubuntu0.20.04.1",
            "firefox-locale-fr": "97.0.2+build1-0ubuntu0.20.04.1",
            "firefox-locale-pa": "97.0.2+build1-0ubuntu0.20.04.1",
            "firefox-locale-as": "97.0.2+build1-0ubuntu0.20.04.1",
            "firefox-locale-id": "97.0.2+build1-0ubuntu0.20.04.1",
            "firefox-locale-pl": "97.0.2+build1-0ubuntu0.20.04.1",
            "firefox-locale-gd": "97.0.2+build1-0ubuntu0.20.04.1",
            "firefox-locale-te": "97.0.2+build1-0ubuntu0.20.04.1",
            "firefox-locale-lv": "97.0.2+build1-0ubuntu0.20.04.1",
            "firefox-locale-ka": "97.0.2+build1-0ubuntu0.20.04.1",
            "firefox-locale-ta": "97.0.2+build1-0ubuntu0.20.04.1",
            "firefox-locale-bs": "97.0.2+build1-0ubuntu0.20.04.1",
            "firefox-locale-uz": "97.0.2+build1-0ubuntu0.20.04.1",
            "firefox-locale-hi": "97.0.2+build1-0ubuntu0.20.04.1",
            "firefox-locale-zh-hant": "97.0.2+build1-0ubuntu0.20.04.1",
            "firefox-locale-es": "97.0.2+build1-0ubuntu0.20.04.1",
            "firefox-locale-ur": "97.0.2+build1-0ubuntu0.20.04.1",
            "firefox-locale-mr": "97.0.2+build1-0ubuntu0.20.04.1",
            "firefox-locale-pt": "97.0.2+build1-0ubuntu0.20.04.1",
            "firefox-locale-de": "97.0.2+build1-0ubuntu0.20.04.1"
        }
    ]
}