USN-5321-2

See a problem?
Source
https://ubuntu.com/security/notices/USN-5321-2
Import Source
https://github.com/canonical/ubuntu-security-notices/blob/main/osv/USN-5321-2.json
JSON Data
https://api.osv.dev/v1/vulns/USN-5321-2
Related
  • CVE-2022-0843
  • CVE-2022-26381
  • CVE-2022-26382
  • CVE-2022-26383
  • CVE-2022-26384
  • CVE-2022-26385
  • CVE-2022-26387
Published
2022-03-17T12:47:30.942033Z
Modified
2022-03-17T12:47:30.942033Z
Summary
firefox vulnerabilities
Details

USN-5321-1 fixed vulnerabilities in Firefox. The update didn't include arm64 because of a regression. This update provides the corresponding update for arm64.

This update also removes Yandex and Mail.ru as optional search providers in the drop-down search menu.

Original advisory details:

Multiple security issues were discovered in Firefox. If a user were tricked into opening a specially crafted website, an attacker could potentially exploit these to cause a denial of service, spoof the browser UI, bypass security restrictions, obtain sensitive information, or execute arbitrary code. (CVE-2022-0843, CVE-2022-26381, CVE-2022-26382, CVE-2022-26383, CVE-2022-26384, CVE-2022-26385)

A TOCTOU bug was discovered when verifying addon signatures during install. A local attacker could potentially exploit this to trick a user into installing an addon with an invalid signature. (CVE-2022-26387)

References

Affected packages

Ubuntu:20.04:LTS / firefox

Package

Name
firefox

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
98.0.1+build2-0ubuntu0.20.04.1

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "firefox-locale-sl": "98.0.1+build2-0ubuntu0.20.04.1",
            "firefox-locale-nl": "98.0.1+build2-0ubuntu0.20.04.1",
            "firefox-locale-kn": "98.0.1+build2-0ubuntu0.20.04.1",
            "firefox-locale-gl": "98.0.1+build2-0ubuntu0.20.04.1",
            "firefox-locale-fy": "98.0.1+build2-0ubuntu0.20.04.1",
            "firefox-locale-kk": "98.0.1+build2-0ubuntu0.20.04.1",
            "firefox-locale-km": "98.0.1+build2-0ubuntu0.20.04.1",
            "firefox-locale-or": "98.0.1+build2-0ubuntu0.20.04.1",
            "firefox-locale-az": "98.0.1+build2-0ubuntu0.20.04.1",
            "firefox-locale-lt": "98.0.1+build2-0ubuntu0.20.04.1",
            "firefox-locale-hy": "98.0.1+build2-0ubuntu0.20.04.1",
            "firefox-locale-eo": "98.0.1+build2-0ubuntu0.20.04.1",
            "firefox-locale-sv": "98.0.1+build2-0ubuntu0.20.04.1",
            "firefox-locale-uk": "98.0.1+build2-0ubuntu0.20.04.1",
            "firefox-locale-sr": "98.0.1+build2-0ubuntu0.20.04.1",
            "firefox-locale-is": "98.0.1+build2-0ubuntu0.20.04.1",
            "firefox-locale-ca": "98.0.1+build2-0ubuntu0.20.04.1",
            "firefox-locale-ne": "98.0.1+build2-0ubuntu0.20.04.1",
            "firefox-locale-ga": "98.0.1+build2-0ubuntu0.20.04.1",
            "firefox-locale-it": "98.0.1+build2-0ubuntu0.20.04.1",
            "firefox-locale-ja": "98.0.1+build2-0ubuntu0.20.04.1",
            "firefox-locale-lg": "98.0.1+build2-0ubuntu0.20.04.1",
            "firefox-locale-ms": "98.0.1+build2-0ubuntu0.20.04.1",
            "firefox-locale-zh-hans": "98.0.1+build2-0ubuntu0.20.04.1",
            "firefox-locale-ia": "98.0.1+build2-0ubuntu0.20.04.1",
            "firefox-locale-ko": "98.0.1+build2-0ubuntu0.20.04.1",
            "firefox-locale-hr": "98.0.1+build2-0ubuntu0.20.04.1",
            "firefox-locale-mai": "98.0.1+build2-0ubuntu0.20.04.1",
            "firefox-locale-nb": "98.0.1+build2-0ubuntu0.20.04.1",
            "firefox-mozsymbols": "98.0.1+build2-0ubuntu0.20.04.1",
            "firefox-locale-vi": "98.0.1+build2-0ubuntu0.20.04.1",
            "firefox-dev": "98.0.1+build2-0ubuntu0.20.04.1",
            "firefox-locale-he": "98.0.1+build2-0ubuntu0.20.04.1",
            "firefox-locale-sw": "98.0.1+build2-0ubuntu0.20.04.1",
            "firefox-locale-el": "98.0.1+build2-0ubuntu0.20.04.1",
            "firefox-locale-oc": "98.0.1+build2-0ubuntu0.20.04.1",
            "firefox-locale-xh": "98.0.1+build2-0ubuntu0.20.04.1",
            "firefox-locale-nn": "98.0.1+build2-0ubuntu0.20.04.1",
            "firefox-geckodriver": "98.0.1+build2-0ubuntu0.20.04.1",
            "firefox-locale-ar": "98.0.1+build2-0ubuntu0.20.04.1",
            "firefox-locale-cs": "98.0.1+build2-0ubuntu0.20.04.1",
            "firefox-locale-gn": "98.0.1+build2-0ubuntu0.20.04.1",
            "firefox-locale-hsb": "98.0.1+build2-0ubuntu0.20.04.1",
            "firefox-locale-zu": "98.0.1+build2-0ubuntu0.20.04.1",
            "firefox-locale-my": "98.0.1+build2-0ubuntu0.20.04.1",
            "firefox-locale-ro": "98.0.1+build2-0ubuntu0.20.04.1",
            "firefox-locale-csb": "98.0.1+build2-0ubuntu0.20.04.1",
            "firefox-locale-nso": "98.0.1+build2-0ubuntu0.20.04.1",
            "firefox-locale-af": "98.0.1+build2-0ubuntu0.20.04.1",
            "firefox-locale-sk": "98.0.1+build2-0ubuntu0.20.04.1",
            "firefox-locale-szl": "98.0.1+build2-0ubuntu0.20.04.1",
            "firefox-locale-si": "98.0.1+build2-0ubuntu0.20.04.1",
            "firefox": "98.0.1+build2-0ubuntu0.20.04.1",
            "firefox-locale-cy": "98.0.1+build2-0ubuntu0.20.04.1",
            "firefox-locale-fa": "98.0.1+build2-0ubuntu0.20.04.1",
            "firefox-locale-cak": "98.0.1+build2-0ubuntu0.20.04.1",
            "firefox-locale-sq": "98.0.1+build2-0ubuntu0.20.04.1",
            "firefox-locale-en": "98.0.1+build2-0ubuntu0.20.04.1",
            "firefox-locale-tr": "98.0.1+build2-0ubuntu0.20.04.1",
            "firefox-locale-br": "98.0.1+build2-0ubuntu0.20.04.1",
            "firefox-locale-et": "98.0.1+build2-0ubuntu0.20.04.1",
            "firefox-locale-ast": "98.0.1+build2-0ubuntu0.20.04.1",
            "firefox-locale-th": "98.0.1+build2-0ubuntu0.20.04.1",
            "firefox-locale-da": "98.0.1+build2-0ubuntu0.20.04.1",
            "firefox-locale-fi": "98.0.1+build2-0ubuntu0.20.04.1",
            "firefox-locale-ku": "98.0.1+build2-0ubuntu0.20.04.1",
            "firefox-locale-mn": "98.0.1+build2-0ubuntu0.20.04.1",
            "firefox-locale-ru": "98.0.1+build2-0ubuntu0.20.04.1",
            "firefox-locale-mk": "98.0.1+build2-0ubuntu0.20.04.1",
            "firefox-locale-bg": "98.0.1+build2-0ubuntu0.20.04.1",
            "firefox-locale-hu": "98.0.1+build2-0ubuntu0.20.04.1",
            "firefox-locale-gu": "98.0.1+build2-0ubuntu0.20.04.1",
            "firefox-locale-bn": "98.0.1+build2-0ubuntu0.20.04.1",
            "firefox-locale-kab": "98.0.1+build2-0ubuntu0.20.04.1",
            "firefox-locale-ml": "98.0.1+build2-0ubuntu0.20.04.1",
            "firefox-locale-an": "98.0.1+build2-0ubuntu0.20.04.1",
            "firefox-locale-be": "98.0.1+build2-0ubuntu0.20.04.1",
            "firefox-locale-eu": "98.0.1+build2-0ubuntu0.20.04.1",
            "firefox-locale-fr": "98.0.1+build2-0ubuntu0.20.04.1",
            "firefox-locale-pa": "98.0.1+build2-0ubuntu0.20.04.1",
            "firefox-locale-as": "98.0.1+build2-0ubuntu0.20.04.1",
            "firefox-locale-id": "98.0.1+build2-0ubuntu0.20.04.1",
            "firefox-locale-pl": "98.0.1+build2-0ubuntu0.20.04.1",
            "firefox-locale-gd": "98.0.1+build2-0ubuntu0.20.04.1",
            "firefox-locale-te": "98.0.1+build2-0ubuntu0.20.04.1",
            "firefox-locale-lv": "98.0.1+build2-0ubuntu0.20.04.1",
            "firefox-locale-ka": "98.0.1+build2-0ubuntu0.20.04.1",
            "firefox-locale-ta": "98.0.1+build2-0ubuntu0.20.04.1",
            "firefox-locale-bs": "98.0.1+build2-0ubuntu0.20.04.1",
            "firefox-locale-uz": "98.0.1+build2-0ubuntu0.20.04.1",
            "firefox-locale-hi": "98.0.1+build2-0ubuntu0.20.04.1",
            "firefox-locale-zh-hant": "98.0.1+build2-0ubuntu0.20.04.1",
            "firefox-locale-es": "98.0.1+build2-0ubuntu0.20.04.1",
            "firefox-locale-ur": "98.0.1+build2-0ubuntu0.20.04.1",
            "firefox-locale-mr": "98.0.1+build2-0ubuntu0.20.04.1",
            "firefox-locale-pt": "98.0.1+build2-0ubuntu0.20.04.1",
            "firefox-locale-de": "98.0.1+build2-0ubuntu0.20.04.1"
        }
    ]
}

Ubuntu:18.04:LTS / firefox

Package

Name
firefox

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
98.0.1+build2-0ubuntu0.18.04.1

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "firefox-locale-sl": "98.0.1+build2-0ubuntu0.18.04.1",
            "firefox-locale-nl": "98.0.1+build2-0ubuntu0.18.04.1",
            "firefox-locale-kn": "98.0.1+build2-0ubuntu0.18.04.1",
            "firefox-locale-gl": "98.0.1+build2-0ubuntu0.18.04.1",
            "firefox-locale-fy": "98.0.1+build2-0ubuntu0.18.04.1",
            "firefox-locale-kk": "98.0.1+build2-0ubuntu0.18.04.1",
            "firefox-locale-km": "98.0.1+build2-0ubuntu0.18.04.1",
            "firefox-locale-or": "98.0.1+build2-0ubuntu0.18.04.1",
            "firefox-locale-az": "98.0.1+build2-0ubuntu0.18.04.1",
            "firefox-locale-lt": "98.0.1+build2-0ubuntu0.18.04.1",
            "firefox-locale-hy": "98.0.1+build2-0ubuntu0.18.04.1",
            "firefox-locale-eo": "98.0.1+build2-0ubuntu0.18.04.1",
            "firefox-locale-sv": "98.0.1+build2-0ubuntu0.18.04.1",
            "firefox-locale-uk": "98.0.1+build2-0ubuntu0.18.04.1",
            "firefox-locale-sr": "98.0.1+build2-0ubuntu0.18.04.1",
            "firefox-locale-is": "98.0.1+build2-0ubuntu0.18.04.1",
            "firefox-locale-ca": "98.0.1+build2-0ubuntu0.18.04.1",
            "firefox-locale-ne": "98.0.1+build2-0ubuntu0.18.04.1",
            "firefox-locale-ga": "98.0.1+build2-0ubuntu0.18.04.1",
            "firefox-locale-it": "98.0.1+build2-0ubuntu0.18.04.1",
            "firefox-locale-ja": "98.0.1+build2-0ubuntu0.18.04.1",
            "firefox-locale-lg": "98.0.1+build2-0ubuntu0.18.04.1",
            "firefox-locale-ms": "98.0.1+build2-0ubuntu0.18.04.1",
            "firefox-locale-zh-hans": "98.0.1+build2-0ubuntu0.18.04.1",
            "firefox-locale-ia": "98.0.1+build2-0ubuntu0.18.04.1",
            "firefox-locale-ko": "98.0.1+build2-0ubuntu0.18.04.1",
            "firefox-locale-hr": "98.0.1+build2-0ubuntu0.18.04.1",
            "firefox-locale-mai": "98.0.1+build2-0ubuntu0.18.04.1",
            "firefox-locale-nb": "98.0.1+build2-0ubuntu0.18.04.1",
            "firefox-mozsymbols": "98.0.1+build2-0ubuntu0.18.04.1",
            "firefox-locale-vi": "98.0.1+build2-0ubuntu0.18.04.1",
            "firefox-dev": "98.0.1+build2-0ubuntu0.18.04.1",
            "firefox-locale-he": "98.0.1+build2-0ubuntu0.18.04.1",
            "firefox-locale-sw": "98.0.1+build2-0ubuntu0.18.04.1",
            "firefox-locale-el": "98.0.1+build2-0ubuntu0.18.04.1",
            "firefox-locale-oc": "98.0.1+build2-0ubuntu0.18.04.1",
            "firefox-locale-xh": "98.0.1+build2-0ubuntu0.18.04.1",
            "firefox-locale-nn": "98.0.1+build2-0ubuntu0.18.04.1",
            "firefox-geckodriver": "98.0.1+build2-0ubuntu0.18.04.1",
            "firefox-locale-ar": "98.0.1+build2-0ubuntu0.18.04.1",
            "firefox-locale-cs": "98.0.1+build2-0ubuntu0.18.04.1",
            "firefox-locale-gn": "98.0.1+build2-0ubuntu0.18.04.1",
            "firefox-locale-hsb": "98.0.1+build2-0ubuntu0.18.04.1",
            "firefox-locale-zu": "98.0.1+build2-0ubuntu0.18.04.1",
            "firefox-locale-my": "98.0.1+build2-0ubuntu0.18.04.1",
            "firefox-locale-ro": "98.0.1+build2-0ubuntu0.18.04.1",
            "firefox-locale-csb": "98.0.1+build2-0ubuntu0.18.04.1",
            "firefox-locale-nso": "98.0.1+build2-0ubuntu0.18.04.1",
            "firefox-locale-af": "98.0.1+build2-0ubuntu0.18.04.1",
            "firefox-locale-sk": "98.0.1+build2-0ubuntu0.18.04.1",
            "firefox-locale-szl": "98.0.1+build2-0ubuntu0.18.04.1",
            "firefox-locale-si": "98.0.1+build2-0ubuntu0.18.04.1",
            "firefox": "98.0.1+build2-0ubuntu0.18.04.1",
            "firefox-locale-cy": "98.0.1+build2-0ubuntu0.18.04.1",
            "firefox-locale-fa": "98.0.1+build2-0ubuntu0.18.04.1",
            "firefox-locale-cak": "98.0.1+build2-0ubuntu0.18.04.1",
            "firefox-locale-sq": "98.0.1+build2-0ubuntu0.18.04.1",
            "firefox-locale-en": "98.0.1+build2-0ubuntu0.18.04.1",
            "firefox-locale-tr": "98.0.1+build2-0ubuntu0.18.04.1",
            "firefox-locale-br": "98.0.1+build2-0ubuntu0.18.04.1",
            "firefox-locale-et": "98.0.1+build2-0ubuntu0.18.04.1",
            "firefox-locale-ast": "98.0.1+build2-0ubuntu0.18.04.1",
            "firefox-locale-th": "98.0.1+build2-0ubuntu0.18.04.1",
            "firefox-locale-da": "98.0.1+build2-0ubuntu0.18.04.1",
            "firefox-locale-fi": "98.0.1+build2-0ubuntu0.18.04.1",
            "firefox-locale-ku": "98.0.1+build2-0ubuntu0.18.04.1",
            "firefox-locale-mn": "98.0.1+build2-0ubuntu0.18.04.1",
            "firefox-locale-ru": "98.0.1+build2-0ubuntu0.18.04.1",
            "firefox-locale-mk": "98.0.1+build2-0ubuntu0.18.04.1",
            "firefox-locale-bg": "98.0.1+build2-0ubuntu0.18.04.1",
            "firefox-locale-hu": "98.0.1+build2-0ubuntu0.18.04.1",
            "firefox-locale-gu": "98.0.1+build2-0ubuntu0.18.04.1",
            "firefox-locale-bn": "98.0.1+build2-0ubuntu0.18.04.1",
            "firefox-locale-kab": "98.0.1+build2-0ubuntu0.18.04.1",
            "firefox-locale-ml": "98.0.1+build2-0ubuntu0.18.04.1",
            "firefox-locale-an": "98.0.1+build2-0ubuntu0.18.04.1",
            "firefox-locale-be": "98.0.1+build2-0ubuntu0.18.04.1",
            "firefox-locale-eu": "98.0.1+build2-0ubuntu0.18.04.1",
            "firefox-locale-fr": "98.0.1+build2-0ubuntu0.18.04.1",
            "firefox-locale-pa": "98.0.1+build2-0ubuntu0.18.04.1",
            "firefox-locale-as": "98.0.1+build2-0ubuntu0.18.04.1",
            "firefox-locale-id": "98.0.1+build2-0ubuntu0.18.04.1",
            "firefox-locale-pl": "98.0.1+build2-0ubuntu0.18.04.1",
            "firefox-locale-gd": "98.0.1+build2-0ubuntu0.18.04.1",
            "firefox-locale-te": "98.0.1+build2-0ubuntu0.18.04.1",
            "firefox-locale-lv": "98.0.1+build2-0ubuntu0.18.04.1",
            "firefox-locale-ka": "98.0.1+build2-0ubuntu0.18.04.1",
            "firefox-locale-ta": "98.0.1+build2-0ubuntu0.18.04.1",
            "firefox-locale-bs": "98.0.1+build2-0ubuntu0.18.04.1",
            "firefox-locale-uz": "98.0.1+build2-0ubuntu0.18.04.1",
            "firefox-locale-hi": "98.0.1+build2-0ubuntu0.18.04.1",
            "firefox-locale-zh-hant": "98.0.1+build2-0ubuntu0.18.04.1",
            "firefox-locale-es": "98.0.1+build2-0ubuntu0.18.04.1",
            "firefox-locale-ur": "98.0.1+build2-0ubuntu0.18.04.1",
            "firefox-locale-mr": "98.0.1+build2-0ubuntu0.18.04.1",
            "firefox-locale-pt": "98.0.1+build2-0ubuntu0.18.04.1",
            "firefox-locale-de": "98.0.1+build2-0ubuntu0.18.04.1"
        }
    ]
}