USN-5324-1

See a problem?
Source
https://ubuntu.com/security/notices/USN-5324-1
Import Source
https://github.com/canonical/ubuntu-security-notices/blob/main/osv/USN-5324-1.json
JSON Data
https://api.osv.dev/v1/vulns/USN-5324-1
Related
Published
2022-03-14T11:01:02.318947Z
Modified
2022-03-14T11:01:02.318947Z
Summary
libxml2 vulnerability
Details

It was discovered that libxml2 incorrectly handled certain XML files. An attacker could use this issue to cause libxml2 to crash, resulting in a denial of service, or possibly execute arbitrary code.

References

Affected packages

Ubuntu:20.04:LTS / libxml2

Package

Name
libxml2

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
2.9.10+dfsg-5ubuntu0.20.04.2

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "libxml2": "2.9.10+dfsg-5ubuntu0.20.04.2",
            "python3-libxml2": "2.9.10+dfsg-5ubuntu0.20.04.2",
            "libxml2-dev": "2.9.10+dfsg-5ubuntu0.20.04.2",
            "libxml2-doc": "2.9.10+dfsg-5ubuntu0.20.04.2",
            "libxml2-utils": "2.9.10+dfsg-5ubuntu0.20.04.2",
            "python-libxml2": "2.9.10+dfsg-5ubuntu0.20.04.2"
        }
    ]
}

Ubuntu:18.04:LTS / libxml2

Package

Name
libxml2

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
2.9.4+dfsg1-6.1ubuntu1.5

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "libxml2": "2.9.4+dfsg1-6.1ubuntu1.5",
            "python3-libxml2": "2.9.4+dfsg1-6.1ubuntu1.5",
            "libxml2-dev": "2.9.4+dfsg1-6.1ubuntu1.5",
            "libxml2-doc": "2.9.4+dfsg1-6.1ubuntu1.5",
            "libxml2-utils": "2.9.4+dfsg1-6.1ubuntu1.5",
            "python-libxml2": "2.9.4+dfsg1-6.1ubuntu1.5"
        }
    ]
}