USN-5331-2

See a problem?
Source
https://ubuntu.com/security/notices/USN-5331-2
Import Source
https://github.com/canonical/ubuntu-security-notices/blob/main/osv/USN-5331-2.json
JSON Data
https://api.osv.dev/v1/vulns/USN-5331-2
Related
Published
2022-04-11T07:44:40.225690Z
Modified
2022-04-11T07:44:40.225690Z
Summary
tcpdump vulnerabilities
Details

USN-5331-1 fixed several vulnerabilities in tcpdump. This update provides the corresponding update for Ubuntu 18.04 LTS and Ubuntu 20.04 LTS.

Original advisory details: It was discovered that tcpdump incorrectly handled certain inputs. An attacker could possibly use this issue to cause a denial of service, or possibly execute arbitrary code. (CVE-2018-16301)

It was discovered that tcpdump incorrectly handled certain captured data. An attacker could possibly use this issue to cause a denial of service. (CVE-2020-8037)

References

Affected packages

Ubuntu:18.04:LTS / tcpdump

Package

Name
tcpdump

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
4.9.3-0ubuntu0.18.04.2

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "tcpdump": "4.9.3-0ubuntu0.18.04.2"
        }
    ]
}

Ubuntu:20.04:LTS / tcpdump

Package

Name
tcpdump

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
4.9.3-4ubuntu0.1

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "tcpdump": "4.9.3-4ubuntu0.1"
        }
    ]
}