USN-5369-1

See a problem?
Source
https://ubuntu.com/security/notices/USN-5369-1
Import Source
https://github.com/canonical/ubuntu-security-notices/blob/main/osv/USN-5369-1.json
JSON Data
https://api.osv.dev/v1/vulns/USN-5369-1
Related
Published
2022-04-07T13:30:53.175144Z
Modified
2022-04-07T13:30:53.175144Z
Summary
python-oslo.utils vulnerability
Details

It was discovered that oslo.utils incorrectly handled certain inputs. An attacker could possibly use this issue to expose sensitive information.

References

Affected packages

Ubuntu:20.04:LTS / python-oslo.utils

Package

Name
python-oslo.utils

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
4.1.1-0ubuntu1.1

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "python-oslo.utils-doc": "4.1.1-0ubuntu1.1",
            "python3-oslo.utils": "4.1.1-0ubuntu1.1"
        }
    ]
}

Ubuntu:18.04:LTS / python-oslo.utils

Package

Name
python-oslo.utils

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
3.35.0-0ubuntu1.1

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "python-oslo.utils": "3.35.0-0ubuntu1.1",
            "python-oslo.utils-doc": "3.35.0-0ubuntu1.1",
            "python3-oslo.utils": "3.35.0-0ubuntu1.1"
        }
    ]
}

Ubuntu:Pro:16.04:LTS / python-oslo.utils

Package

Name
python-oslo.utils

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
3.8.0-2ubuntu0.1~esm1

Ecosystem specific

{
    "availability": "Available with Ubuntu Pro: https://ubuntu.com/pro",
    "binaries": [
        {
            "python-oslo-utils": "3.8.0-2ubuntu0.1~esm1",
            "python3-oslo.utils": "3.8.0-2ubuntu0.1~esm1",
            "python-oslo.utils": "3.8.0-2ubuntu0.1~esm1",
            "python-oslo.utils-doc": "3.8.0-2ubuntu0.1~esm1",
            "python-oslo-utils-doc": "3.8.0-2ubuntu0.1~esm1",
            "python3-oslo-utils": "3.8.0-2ubuntu0.1~esm1"
        }
    ]
}