USN-5378-2

See a problem?
Source
https://ubuntu.com/security/notices/USN-5378-2
Import Source
https://github.com/canonical/ubuntu-security-notices/blob/main/osv/USN-5378-2.json
JSON Data
https://api.osv.dev/v1/vulns/USN-5378-2
Related
Published
2022-04-13T12:45:29.955642Z
Modified
2022-04-13T12:45:29.955642Z
Summary
xz-utils vulnerability
Details

Cleemy Desu Wayo discovered that XZ Utils incorrectly handled certain filenames. If a user or automated system were tricked into performing xzgrep operations with specially crafted filenames, a remote attacker could overwrite arbitrary files.

References

Affected packages

Ubuntu:18.04:LTS / xz-utils

Package

Name
xz-utils

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
5.2.2-1.3ubuntu0.1

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "liblzma5": "5.2.2-1.3ubuntu0.1",
            "xzdec": "5.2.2-1.3ubuntu0.1",
            "liblzma-doc": "5.2.2-1.3ubuntu0.1",
            "xz-utils": "5.2.2-1.3ubuntu0.1",
            "liblzma-dev": "5.2.2-1.3ubuntu0.1"
        }
    ]
}

Ubuntu:20.04:LTS / xz-utils

Package

Name
xz-utils

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
5.2.4-1ubuntu1.1

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "liblzma5": "5.2.4-1ubuntu1.1",
            "xzdec": "5.2.4-1ubuntu1.1",
            "liblzma-doc": "5.2.4-1ubuntu1.1",
            "xz-utils": "5.2.4-1ubuntu1.1",
            "liblzma-dev": "5.2.4-1ubuntu1.1"
        }
    ]
}