USN-5395-1

See a problem?
Source
https://ubuntu.com/security/notices/USN-5395-1
Import Source
https://github.com/canonical/ubuntu-security-notices/blob/main/osv/USN-5395-1.json
JSON Data
https://api.osv.dev/v1/vulns/USN-5395-1
Related
Published
2022-04-28T16:16:19.847454Z
Modified
2022-04-28T16:16:19.847454Z
Summary
networkd-dispatcher vulnerabilities
Details

It was discovered that networkd-dispatcher incorrectly handled internal scripts. A local attacker could possibly use this issue to cause a race condition, escalate privileges and execute arbitrary code. (CVE-2022-29799, CVE-2022-29800)

References

Affected packages

Ubuntu:22.04:LTS / networkd-dispatcher

Package

Name
networkd-dispatcher

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
2.1-2ubuntu0.22.04.1

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "networkd-dispatcher": "2.1-2ubuntu0.22.04.1"
        }
    ]
}

Ubuntu:20.04:LTS / networkd-dispatcher

Package

Name
networkd-dispatcher

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
2.1-2~ubuntu20.04.2

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "networkd-dispatcher": "2.1-2~ubuntu20.04.2"
        }
    ]
}

Ubuntu:18.04:LTS / networkd-dispatcher

Package

Name
networkd-dispatcher

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
1.7-0ubuntu3.4

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "networkd-dispatcher": "1.7-0ubuntu3.4"
        }
    ]
}