USN-5401-1

See a problem?
Source
https://ubuntu.com/security/notices/USN-5401-1
Import Source
https://github.com/canonical/ubuntu-security-notices/blob/main/osv/USN-5401-1.json
JSON Data
https://api.osv.dev/v1/vulns/USN-5401-1
Related
Published
2022-05-04T12:17:01.358495Z
Modified
2022-05-04T12:17:01.358495Z
Summary
dpdk vulnerabilities
Details

Wenxiang Qian discovered that DPDK incorrectly checked certain payloads. An attacker could use this issue to cause DPDK to crash, resulting in a denial of service, or possibly execute arbitrary code. (CVE-2021-3839)

It was discovered that DPDK incorrectly handled inflight type messages. An attacker could possibly use this issue to cause DPDK to consume resources, leading to a denial of service. (CVE-2022-0669)

References

Affected packages

Ubuntu:22.04:LTS / dpdk

Package

Name
dpdk

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
21.11.1-0ubuntu0.3

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "librte-ip-frag22": "21.11.1-0ubuntu0.3",
            "librte-graph22": "21.11.1-0ubuntu0.3",
            "librte-common-octeontx22": "21.11.1-0ubuntu0.3",
            "librte-baseband-la12xx22": "21.11.1-0ubuntu0.3",
            "librte-baseband-null22": "21.11.1-0ubuntu0.3",
            "librte-net-e1000-22": "21.11.1-0ubuntu0.3",
            "librte-efd22": "21.11.1-0ubuntu0.3",
            "librte-mempool-dpaa22": "21.11.1-0ubuntu0.3",
            "librte-common-octeontx2-22": "21.11.1-0ubuntu0.3",
            "librte-timer22": "21.11.1-0ubuntu0.3",
            "librte-net-axgbe22": "21.11.1-0ubuntu0.3",
            "librte-net-pcap22": "21.11.1-0ubuntu0.3",
            "librte-vdpa-mlx5-22": "21.11.1-0ubuntu0.3",
            "librte-bitratestats22": "21.11.1-0ubuntu0.3",
            "librte-net-hinic22": "21.11.1-0ubuntu0.3",
            "librte-net-bnx2x22": "21.11.1-0ubuntu0.3",
            "librte-dma-ioat22": "21.11.1-0ubuntu0.3",
            "librte-dma-skeleton22": "21.11.1-0ubuntu0.3",
            "librte-meter22": "21.11.1-0ubuntu0.3",
            "librte-stack22": "21.11.1-0ubuntu0.3",
            "librte-crypto-dpaa-sec22": "21.11.1-0ubuntu0.3",
            "librte-crypto-ipsec-mb22": "21.11.1-0ubuntu0.3",
            "librte-bus-dpaa22": "21.11.1-0ubuntu0.3",
            "librte-net-i40e22": "21.11.1-0ubuntu0.3",
            "librte-net-thunderx22": "21.11.1-0ubuntu0.3",
            "librte-event-dsw22": "21.11.1-0ubuntu0.3",
            "librte-crypto-mlx5-22": "21.11.1-0ubuntu0.3",
            "librte-mempool-dpaa2-22": "21.11.1-0ubuntu0.3",
            "librte-dma-cnxk22": "21.11.1-0ubuntu0.3",
            "librte-vdpa-sfc22": "21.11.1-0ubuntu0.3",
            "librte-net-octeontx-ep22": "21.11.1-0ubuntu0.3",
            "librte-meta-crypto": "21.11.1-0ubuntu0.3",
            "librte-bus-ifpga22": "21.11.1-0ubuntu0.3",
            "librte-pdump22": "21.11.1-0ubuntu0.3",
            "librte-member22": "21.11.1-0ubuntu0.3",
            "librte-regex-octeontx2-22": "21.11.1-0ubuntu0.3",
            "librte-net-ngbe22": "21.11.1-0ubuntu0.3",
            "librte-net-atlantic22": "21.11.1-0ubuntu0.3",
            "librte-net-ipn3ke22": "21.11.1-0ubuntu0.3",
            "librte-net-cxgbe22": "21.11.1-0ubuntu0.3",
            "librte-port22": "21.11.1-0ubuntu0.3",
            "librte-compress-zlib22": "21.11.1-0ubuntu0.3",
            "librte-raw-ifpga22": "21.11.1-0ubuntu0.3",
            "librte-net-ixgbe22": "21.11.1-0ubuntu0.3",
            "librte-fib22": "21.11.1-0ubuntu0.3",
            "librte-rib22": "21.11.1-0ubuntu0.3",
            "librte-meta-raw": "21.11.1-0ubuntu0.3",
            "librte-event-dpaa22": "21.11.1-0ubuntu0.3",
            "librte-cryptodev22": "21.11.1-0ubuntu0.3",
            "librte-net-pfe22": "21.11.1-0ubuntu0.3",
            "librte-net-enic22": "21.11.1-0ubuntu0.3",
            "librte-regexdev22": "21.11.1-0ubuntu0.3",
            "librte-common-cnxk22": "21.11.1-0ubuntu0.3",
            "librte-meta-mempool": "21.11.1-0ubuntu0.3",
            "librte-power22": "21.11.1-0ubuntu0.3",
            "librte-bus-pci22": "21.11.1-0ubuntu0.3",
            "librte-common-dpaax22": "21.11.1-0ubuntu0.3",
            "librte-bus-fslmc22": "21.11.1-0ubuntu0.3",
            "librte-crypto-scheduler22": "21.11.1-0ubuntu0.3",
            "librte-kvargs22": "21.11.1-0ubuntu0.3",
            "librte-event-skeleton22": "21.11.1-0ubuntu0.3",
            "dpdk-dev": "21.11.1-0ubuntu0.3",
            "librte-net-virtio22": "21.11.1-0ubuntu0.3",
            "librte-meta-all": "21.11.1-0ubuntu0.3",
            "librte-net-igc22": "21.11.1-0ubuntu0.3",
            "librte-net-netvsc22": "21.11.1-0ubuntu0.3",
            "librte-net-tap22": "21.11.1-0ubuntu0.3",
            "librte-mempool-bucket22": "21.11.1-0ubuntu0.3",
            "librte-common-mlx5-22": "21.11.1-0ubuntu0.3",
            "librte-common-qat22": "21.11.1-0ubuntu0.3",
            "librte-lpm22": "21.11.1-0ubuntu0.3",
            "librte-acl22": "21.11.1-0ubuntu0.3",
            "librte-raw-ntb22": "21.11.1-0ubuntu0.3",
            "librte-bus-auxiliary22": "21.11.1-0ubuntu0.3",
            "librte-net-failsafe22": "21.11.1-0ubuntu0.3",
            "librte-common-cpt22": "21.11.1-0ubuntu0.3",
            "librte-net-enetfec22": "21.11.1-0ubuntu0.3",
            "librte-pci22": "21.11.1-0ubuntu0.3",
            "librte-net-ice22": "21.11.1-0ubuntu0.3",
            "librte-meta-bus": "21.11.1-0ubuntu0.3",
            "librte-net-fm10k22": "21.11.1-0ubuntu0.3",
            "librte-metrics22": "21.11.1-0ubuntu0.3",
            "librte-net-ark22": "21.11.1-0ubuntu0.3",
            "librte-cmdline22": "21.11.1-0ubuntu0.3",
            "librte-bpf22": "21.11.1-0ubuntu0.3",
            "librte-common-sfc-efx22": "21.11.1-0ubuntu0.3",
            "librte-dma-hisilicon22": "21.11.1-0ubuntu0.3",
            "librte-meta-allpmds": "21.11.1-0ubuntu0.3",
            "librte-net-enetc22": "21.11.1-0ubuntu0.3",
            "librte-net-softnic22": "21.11.1-0ubuntu0.3",
            "dpdk": "21.11.1-0ubuntu0.3",
            "librte-net-af-xdp22": "21.11.1-0ubuntu0.3",
            "librte-net-hns3-22": "21.11.1-0ubuntu0.3",
            "librte-net-octeontx22": "21.11.1-0ubuntu0.3",
            "librte-flow-classify22": "21.11.1-0ubuntu0.3",
            "librte-meta-compress": "21.11.1-0ubuntu0.3",
            "librte-raw-cnxk-bphy22": "21.11.1-0ubuntu0.3",
            "librte-gso22": "21.11.1-0ubuntu0.3",
            "librte-net-af-packet22": "21.11.1-0ubuntu0.3",
            "librte-net-dpaa22": "21.11.1-0ubuntu0.3",
            "librte-event-octeontx22": "21.11.1-0ubuntu0.3",
            "librte-regex-mlx5-22": "21.11.1-0ubuntu0.3",
            "dpdk-doc": "21.11.1-0ubuntu0.3",
            "librte-net-memif22": "21.11.1-0ubuntu0.3",
            "librte-net22": "21.11.1-0ubuntu0.3",
            "librte-ipsec22": "21.11.1-0ubuntu0.3",
            "librte-event-opdl22": "21.11.1-0ubuntu0.3",
            "librte-crypto-ccp22": "21.11.1-0ubuntu0.3",
            "librte-net-ionic22": "21.11.1-0ubuntu0.3",
            "librte-net-nfp22": "21.11.1-0ubuntu0.3",
            "librte-compressdev22": "21.11.1-0ubuntu0.3",
            "librte-kni22": "21.11.1-0ubuntu0.3",
            "librte-baseband-acc100-22": "21.11.1-0ubuntu0.3",
            "librte-dma-dpaa22": "21.11.1-0ubuntu0.3",
            "librte-node22": "21.11.1-0ubuntu0.3",
            "librte-net-vmxnet3-22": "21.11.1-0ubuntu0.3",
            "librte-crypto-octeontx2-22": "21.11.1-0ubuntu0.3",
            "librte-mbuf22": "21.11.1-0ubuntu0.3",
            "librte-vhost22": "21.11.1-0ubuntu0.3",
            "librte-dma-idxd22": "21.11.1-0ubuntu0.3",
            "librte-common-iavf22": "21.11.1-0ubuntu0.3",
            "librte-net-sfc22": "21.11.1-0ubuntu0.3",
            "librte-event-octeontx2-22": "21.11.1-0ubuntu0.3",
            "librte-pipeline22": "21.11.1-0ubuntu0.3",
            "librte-crypto-dpaa2-sec22": "21.11.1-0ubuntu0.3",
            "librte-gro22": "21.11.1-0ubuntu0.3",
            "librte-meta-dma": "21.11.1-0ubuntu0.3",
            "librte-crypto-bcmfs22": "21.11.1-0ubuntu0.3",
            "librte-net-avp22": "21.11.1-0ubuntu0.3",
            "librte-reorder22": "21.11.1-0ubuntu0.3",
            "librte-hash22": "21.11.1-0ubuntu0.3",
            "librte-ethdev22": "21.11.1-0ubuntu0.3",
            "librte-bus-vdev22": "21.11.1-0ubuntu0.3",
            "librte-security22": "21.11.1-0ubuntu0.3",
            "librte-net-iavf22": "21.11.1-0ubuntu0.3",
            "librte-net-vhost22": "21.11.1-0ubuntu0.3",
            "librte-net-ring22": "21.11.1-0ubuntu0.3",
            "librte-ring22": "21.11.1-0ubuntu0.3",
            "librte-telemetry22": "21.11.1-0ubuntu0.3",
            "librte-cfgfile22": "21.11.1-0ubuntu0.3",
            "librte-bbdev22": "21.11.1-0ubuntu0.3",
            "librte-baseband-turbo-sw22": "21.11.1-0ubuntu0.3",
            "libdpdk-dev": "21.11.1-0ubuntu0.3",
            "librte-raw-dpaa2-cmdif22": "21.11.1-0ubuntu0.3",
            "librte-raw-skeleton22": "21.11.1-0ubuntu0.3",
            "librte-crypto-cnxk22": "21.11.1-0ubuntu0.3",
            "librte-dmadev22": "21.11.1-0ubuntu0.3",
            "librte-meta-baseband": "21.11.1-0ubuntu0.3",
            "librte-crypto-octeontx22": "21.11.1-0ubuntu0.3",
            "librte-event-cnxk22": "21.11.1-0ubuntu0.3",
            "librte-net-dpaa2-22": "21.11.1-0ubuntu0.3",
            "librte-bus-vmbus22": "21.11.1-0ubuntu0.3",
            "librte-net-vdev-netvsc22": "21.11.1-0ubuntu0.3",
            "librte-latencystats22": "21.11.1-0ubuntu0.3",
            "librte-raw-dpaa2-qdma22": "21.11.1-0ubuntu0.3",
            "librte-eal22": "21.11.1-0ubuntu0.3",
            "librte-pcapng22": "21.11.1-0ubuntu0.3",
            "librte-meta-net": "21.11.1-0ubuntu0.3",
            "librte-baseband-fpga-lte-fec22": "21.11.1-0ubuntu0.3",
            "librte-table22": "21.11.1-0ubuntu0.3",
            "librte-jobstats22": "21.11.1-0ubuntu0.3",
            "librte-crypto-caam-jr22": "21.11.1-0ubuntu0.3",
            "librte-event-dpaa2-22": "21.11.1-0ubuntu0.3",
            "librte-net-mlx5-22": "21.11.1-0ubuntu0.3",
            "librte-net-liquidio22": "21.11.1-0ubuntu0.3",
            "librte-eventdev22": "21.11.1-0ubuntu0.3",
            "librte-mempool-octeontx22": "21.11.1-0ubuntu0.3",
            "librte-mempool-ring22": "21.11.1-0ubuntu0.3",
            "librte-distributor22": "21.11.1-0ubuntu0.3",
            "librte-sched22": "21.11.1-0ubuntu0.3",
            "librte-net-bnxt22": "21.11.1-0ubuntu0.3",
            "librte-mempool-stack22": "21.11.1-0ubuntu0.3",
            "librte-net-ena22": "21.11.1-0ubuntu0.3",
            "librte-crypto-openssl22": "21.11.1-0ubuntu0.3",
            "librte-net-bond22": "21.11.1-0ubuntu0.3",
            "librte-gpudev22": "21.11.1-0ubuntu0.3",
            "librte-crypto-null22": "21.11.1-0ubuntu0.3",
            "librte-net-mlx4-22": "21.11.1-0ubuntu0.3",
            "librte-compress-octeontx22": "21.11.1-0ubuntu0.3",
            "librte-net-txgbe22": "21.11.1-0ubuntu0.3",
            "librte-mempool-octeontx2-22": "21.11.1-0ubuntu0.3",
            "librte-compress-isal22": "21.11.1-0ubuntu0.3",
            "librte-crypto-virtio22": "21.11.1-0ubuntu0.3",
            "librte-net-null22": "21.11.1-0ubuntu0.3",
            "librte-meta-event": "21.11.1-0ubuntu0.3",
            "librte-net-kni22": "21.11.1-0ubuntu0.3",
            "librte-rawdev22": "21.11.1-0ubuntu0.3",
            "librte-mempool-cnxk22": "21.11.1-0ubuntu0.3",
            "librte-event-sw22": "21.11.1-0ubuntu0.3",
            "librte-net-octeontx2-22": "21.11.1-0ubuntu0.3",
            "librte-net-cnxk22": "21.11.1-0ubuntu0.3",
            "librte-mempool22": "21.11.1-0ubuntu0.3",
            "librte-crypto-nitrox22": "21.11.1-0ubuntu0.3",
            "librte-compress-mlx5-22": "21.11.1-0ubuntu0.3",
            "librte-event-dlb2-22": "21.11.1-0ubuntu0.3",
            "librte-vdpa-ifc22": "21.11.1-0ubuntu0.3",
            "librte-baseband-fpga-5gnr-fec22": "21.11.1-0ubuntu0.3",
            "librte-net-qede22": "21.11.1-0ubuntu0.3",
            "librte-rcu22": "21.11.1-0ubuntu0.3"
        }
    ]
}

Ubuntu:20.04:LTS / dpdk

Package

Name
dpdk

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
19.11.12-0ubuntu0.20.04.1

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "librte-security20.0": "19.11.12-0ubuntu0.20.04.1",
            "librte-rawdev-octeontx2-dma20.0": "19.11.12-0ubuntu0.20.04.1",
            "librte-port20.0": "19.11.12-0ubuntu0.20.04.1",
            "librte-rcu0.200": "19.11.12-0ubuntu0.20.04.1",
            "librte-pmd-axgbe20.0": "19.11.12-0ubuntu0.20.04.1",
            "librte-pmd-dsw-event20.0": "19.11.12-0ubuntu0.20.04.1",
            "librte-pmd-cxgbe20.0": "19.11.12-0ubuntu0.20.04.1",
            "librte-pmd-caam-jr20.0": "19.11.12-0ubuntu0.20.04.1",
            "librte-pmd-i40e20.0": "19.11.12-0ubuntu0.20.04.1",
            "librte-pmd-ccp20.0": "19.11.12-0ubuntu0.20.04.1",
            "librte-pmd-vdev-netvsc20.0": "19.11.12-0ubuntu0.20.04.1",
            "librte-compressdev0.200": "19.11.12-0ubuntu0.20.04.1",
            "librte-vhost20.0": "19.11.12-0ubuntu0.20.04.1",
            "librte-pmd-bbdev-turbo-sw20.0": "19.11.12-0ubuntu0.20.04.1",
            "librte-pmd-netvsc20.0": "19.11.12-0ubuntu0.20.04.1",
            "librte-bus-pci20.0": "19.11.12-0ubuntu0.20.04.1",
            "librte-pmd-af-packet20.0": "19.11.12-0ubuntu0.20.04.1",
            "librte-pmd-liquidio20.0": "19.11.12-0ubuntu0.20.04.1",
            "librte-pmd-failsafe20.0": "19.11.12-0ubuntu0.20.04.1",
            "librte-pmd-vhost20.0": "19.11.12-0ubuntu0.20.04.1",
            "librte-pmd-mlx5-20.0": "19.11.12-0ubuntu0.20.04.1",
            "librte-cmdline20.0": "19.11.12-0ubuntu0.20.04.1",
            "librte-mempool-octeontx2-20.0": "19.11.12-0ubuntu0.20.04.1",
            "librte-cryptodev20.0": "19.11.12-0ubuntu0.20.04.1",
            "librte-kvargs20.0": "19.11.12-0ubuntu0.20.04.1",
            "librte-pmd-openssl20.0": "19.11.12-0ubuntu0.20.04.1",
            "librte-eal20.0": "19.11.12-0ubuntu0.20.04.1",
            "librte-pmd-tap20.0": "19.11.12-0ubuntu0.20.04.1",
            "librte-mempool-octeontx20.0": "19.11.12-0ubuntu0.20.04.1",
            "librte-pmd-ark20.0": "19.11.12-0ubuntu0.20.04.1",
            "librte-pmd-nfp20.0": "19.11.12-0ubuntu0.20.04.1",
            "librte-mempool-dpaa2-20.0": "19.11.12-0ubuntu0.20.04.1",
            "librte-pmd-opdl-event20.0": "19.11.12-0ubuntu0.20.04.1",
            "librte-rawdev-dpaa2-qdma20.0": "19.11.12-0ubuntu0.20.04.1",
            "librte-pmd-nitrox20.0": "19.11.12-0ubuntu0.20.04.1",
            "librte-pmd-dpaa-event20.0": "19.11.12-0ubuntu0.20.04.1",
            "librte-pmd-virtio-crypto20.0": "19.11.12-0ubuntu0.20.04.1",
            "dpdk-dev": "19.11.12-0ubuntu0.20.04.1",
            "librte-pdump20.0": "19.11.12-0ubuntu0.20.04.1",
            "librte-pmd-sw-event20.0": "19.11.12-0ubuntu0.20.04.1",
            "librte-bbdev0.200": "19.11.12-0ubuntu0.20.04.1",
            "librte-rawdev-ioat20.0": "19.11.12-0ubuntu0.20.04.1",
            "librte-pmd-dpaa2-20.0": "19.11.12-0ubuntu0.20.04.1",
            "librte-kni20.0": "19.11.12-0ubuntu0.20.04.1",
            "librte-pmd-sfc20.0": "19.11.12-0ubuntu0.20.04.1",
            "librte-pmd-octeontx-event20.0": "19.11.12-0ubuntu0.20.04.1",
            "librte-common-octeontx20.0": "19.11.12-0ubuntu0.20.04.1",
            "librte-pmd-pcap20.0": "19.11.12-0ubuntu0.20.04.1",
            "librte-pmd-avp20.0": "19.11.12-0ubuntu0.20.04.1",
            "librte-common-cpt20.0": "19.11.12-0ubuntu0.20.04.1",
            "librte-pmd-octeontx2-event20.0": "19.11.12-0ubuntu0.20.04.1",
            "librte-timer20.0": "19.11.12-0ubuntu0.20.04.1",
            "librte-mempool-stack20.0": "19.11.12-0ubuntu0.20.04.1",
            "librte-pmd-fm10k20.0": "19.11.12-0ubuntu0.20.04.1",
            "librte-jobstats20.0": "19.11.12-0ubuntu0.20.04.1",
            "librte-meter20.0": "19.11.12-0ubuntu0.20.04.1",
            "dpdk": "19.11.12-0ubuntu0.20.04.1",
            "librte-pmd-vmxnet3-20.0": "19.11.12-0ubuntu0.20.04.1",
            "librte-sched20.0": "19.11.12-0ubuntu0.20.04.1",
            "librte-eventdev20.0": "19.11.12-0ubuntu0.20.04.1",
            "librte-gso20.0": "19.11.12-0ubuntu0.20.04.1",
            "librte-pmd-iavf20.0": "19.11.12-0ubuntu0.20.04.1",
            "librte-pmd-qat20.0": "19.11.12-0ubuntu0.20.04.1",
            "librte-pmd-virtio20.0": "19.11.12-0ubuntu0.20.04.1",
            "librte-pmd-thunderx20.0": "19.11.12-0ubuntu0.20.04.1",
            "librte-pmd-enic20.0": "19.11.12-0ubuntu0.20.04.1",
            "librte-efd20.0": "19.11.12-0ubuntu0.20.04.1",
            "dpdk-doc": "19.11.12-0ubuntu0.20.04.1",
            "librte-pmd-octeontx-compress20.0": "19.11.12-0ubuntu0.20.04.1",
            "librte-pci20.0": "19.11.12-0ubuntu0.20.04.1",
            "librte-pmd-e1000-20.0": "19.11.12-0ubuntu0.20.04.1",
            "librte-bus-vdev20.0": "19.11.12-0ubuntu0.20.04.1",
            "librte-common-octeontx2-20.0": "19.11.12-0ubuntu0.20.04.1",
            "librte-telemetry0.200": "19.11.12-0ubuntu0.20.04.1",
            "librte-mempool-ring20.0": "19.11.12-0ubuntu0.20.04.1",
            "librte-pmd-dpaa2-sec20.0": "19.11.12-0ubuntu0.20.04.1",
            "librte-pmd-octeontx2-crypto20.0": "19.11.12-0ubuntu0.20.04.1",
            "librte-bitratestats20.0": "19.11.12-0ubuntu0.20.04.1",
            "librte-rib0.200": "19.11.12-0ubuntu0.20.04.1",
            "librte-latencystats20.0": "19.11.12-0ubuntu0.20.04.1",
            "librte-reorder20.0": "19.11.12-0ubuntu0.20.04.1",
            "librte-pmd-skeleton-event20.0": "19.11.12-0ubuntu0.20.04.1",
            "librte-pmd-null-crypto20.0": "19.11.12-0ubuntu0.20.04.1",
            "librte-pmd-crypto-scheduler20.0": "19.11.12-0ubuntu0.20.04.1",
            "librte-pmd-mlx4-20.0": "19.11.12-0ubuntu0.20.04.1",
            "librte-pmd-bbdev-fpga-lte-fec20.0": "19.11.12-0ubuntu0.20.04.1",
            "librte-pmd-zlib20.0": "19.11.12-0ubuntu0.20.04.1",
            "librte-pmd-memif20.0": "19.11.12-0ubuntu0.20.04.1",
            "librte-ipsec0.200": "19.11.12-0ubuntu0.20.04.1",
            "librte-pmd-bnxt20.0": "19.11.12-0ubuntu0.20.04.1",
            "librte-pmd-hinic20.0": "19.11.12-0ubuntu0.20.04.1",
            "librte-pmd-ixgbe20.0": "19.11.12-0ubuntu0.20.04.1",
            "librte-metrics20.0": "19.11.12-0ubuntu0.20.04.1",
            "librte-pmd-null20.0": "19.11.12-0ubuntu0.20.04.1",
            "librte-bus-vmbus20.0": "19.11.12-0ubuntu0.20.04.1",
            "librte-pmd-pfe20.0": "19.11.12-0ubuntu0.20.04.1",
            "librte-pmd-dpaa20.0": "19.11.12-0ubuntu0.20.04.1",
            "librte-pmd-ice20.0": "19.11.12-0ubuntu0.20.04.1",
            "librte-pmd-ena20.0": "19.11.12-0ubuntu0.20.04.1",
            "librte-ethdev20.0": "19.11.12-0ubuntu0.20.04.1",
            "libdpdk-dev": "19.11.12-0ubuntu0.20.04.1",
            "librte-acl20.0": "19.11.12-0ubuntu0.20.04.1",
            "librte-bus-ifpga20.0": "19.11.12-0ubuntu0.20.04.1",
            "librte-rawdev-dpaa2-cmdif20.0": "19.11.12-0ubuntu0.20.04.1",
            "librte-pmd-aesni-mb20.0": "19.11.12-0ubuntu0.20.04.1",
            "librte-mempool-dpaa20.0": "19.11.12-0ubuntu0.20.04.1",
            "librte-stack0.200": "19.11.12-0ubuntu0.20.04.1",
            "librte-pmd-ring20.0": "19.11.12-0ubuntu0.20.04.1",
            "librte-pmd-hns3-20.0": "19.11.12-0ubuntu0.20.04.1",
            "librte-pmd-octeontx2-20.0": "19.11.12-0ubuntu0.20.04.1",
            "librte-common-dpaax20.0": "19.11.12-0ubuntu0.20.04.1",
            "librte-cfgfile20.0": "19.11.12-0ubuntu0.20.04.1",
            "librte-pmd-qede20.0": "19.11.12-0ubuntu0.20.04.1",
            "librte-rawdev20.0": "19.11.12-0ubuntu0.20.04.1",
            "librte-power20.0": "19.11.12-0ubuntu0.20.04.1",
            "librte-pmd-octeontx-crypto20.0": "19.11.12-0ubuntu0.20.04.1",
            "librte-distributor20.0": "19.11.12-0ubuntu0.20.04.1",
            "dpdk-igb-uio-dkms": "19.11.12-0ubuntu0.20.04.1",
            "librte-pmd-atlantic20.0": "19.11.12-0ubuntu0.20.04.1",
            "librte-fib0.200": "19.11.12-0ubuntu0.20.04.1",
            "librte-pmd-octeontx20.0": "19.11.12-0ubuntu0.20.04.1",
            "librte-pmd-bbdev-null20.0": "19.11.12-0ubuntu0.20.04.1",
            "librte-ip-frag20.0": "19.11.12-0ubuntu0.20.04.1",
            "librte-pmd-dpaa-sec20.0": "19.11.12-0ubuntu0.20.04.1",
            "librte-pmd-enetc20.0": "19.11.12-0ubuntu0.20.04.1",
            "librte-bpf0.200": "19.11.12-0ubuntu0.20.04.1",
            "librte-pmd-bnx2x20.0": "19.11.12-0ubuntu0.20.04.1",
            "librte-net20.0": "19.11.12-0ubuntu0.20.04.1",
            "librte-gro20.0": "19.11.12-0ubuntu0.20.04.1",
            "librte-member20.0": "19.11.12-0ubuntu0.20.04.1",
            "librte-pipeline20.0": "19.11.12-0ubuntu0.20.04.1",
            "librte-pmd-kni20.0": "19.11.12-0ubuntu0.20.04.1",
            "librte-bus-fslmc20.0": "19.11.12-0ubuntu0.20.04.1",
            "librte-mbuf20.0": "19.11.12-0ubuntu0.20.04.1",
            "librte-flow-classify0.200": "19.11.12-0ubuntu0.20.04.1",
            "librte-rawdev-skeleton20.0": "19.11.12-0ubuntu0.20.04.1",
            "librte-mempool-bucket20.0": "19.11.12-0ubuntu0.20.04.1",
            "librte-mempool20.0": "19.11.12-0ubuntu0.20.04.1",
            "librte-pmd-ifc20.0": "19.11.12-0ubuntu0.20.04.1",
            "librte-pmd-dpaa2-event20.0": "19.11.12-0ubuntu0.20.04.1",
            "librte-pmd-aesni-gcm20.0": "19.11.12-0ubuntu0.20.04.1",
            "librte-lpm20.0": "19.11.12-0ubuntu0.20.04.1",
            "librte-table20.0": "19.11.12-0ubuntu0.20.04.1",
            "librte-rawdev-ntb20.0": "19.11.12-0ubuntu0.20.04.1",
            "librte-pmd-isal20.0": "19.11.12-0ubuntu0.20.04.1",
            "librte-pmd-bond20.0": "19.11.12-0ubuntu0.20.04.1",
            "librte-hash20.0": "19.11.12-0ubuntu0.20.04.1",
            "librte-bus-dpaa20.0": "19.11.12-0ubuntu0.20.04.1",
            "librte-pmd-softnic20.0": "19.11.12-0ubuntu0.20.04.1",
            "librte-ring20.0": "19.11.12-0ubuntu0.20.04.1"
        }
    ]
}