USN-5432-2

See a problem?
Source
https://ubuntu.com/security/notices/USN-5432-2
Import Source
https://github.com/canonical/ubuntu-security-notices/blob/main/osv/USN-5432-2.json
JSON Data
https://api.osv.dev/v1/vulns/USN-5432-2
Related
Published
2022-05-24T14:21:04.187076Z
Modified
2022-05-24T14:21:04.187076Z
Summary
libpng1.6 vulnerabilities
Details

USN-5432-1 fixed vulnerabilities in libpng. This update provides the corresponding updates for libpng1.6.

Original advisory details:

It was discovered that libpng incorrectly handled memory when parsing certain PNG files. If a user or automated system were tricked into opening a specially crafted PNG file, an attacker could use this issue to cause libpng to crash, resulting in a denial of service, or possibly execute arbitrary code. (CVE-2017-12652)

Zhengxiong Luo discovered that libpng incorrectly handled memory when parsing certain PNG files. If a user or automated system were tricked into opening a specially crafted PNG file, an attacker could use this issue to cause libpng to crash, resulting in a denial of service, or possibly execute arbitrary code. (CVE-2018-14048)

References

Affected packages

Ubuntu:Pro:16.04:LTS / libpng1.6

Package

Name
libpng1.6

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
1.6.20-2ubuntu0.1~esm1

Ecosystem specific

{
    "availability": "Available with Ubuntu Pro: https://ubuntu.com/pro",
    "binaries": [
        {
            "libpng16-16": "1.6.20-2ubuntu0.1~esm1",
            "libpng16-dev": "1.6.20-2ubuntu0.1~esm1"
        }
    ]
}