USN-5463-1

See a problem?
Source
https://ubuntu.com/security/notices/USN-5463-1
Import Source
https://github.com/canonical/ubuntu-security-notices/blob/main/osv/USN-5463-1.json
JSON Data
https://api.osv.dev/v1/vulns/USN-5463-1
Related
Published
2022-06-07T14:15:00.644336Z
Modified
2022-06-07T14:15:00.644336Z
Summary
ntfs-3g vulnerabilities
Details

It was discovered that NTFS-3G incorrectly handled the ntfsck tool. If a user or automated system were tricked into using ntfsck on a specially crafted disk image, a remote attacker could possibly use this issue to execute arbitrary code. (CVE-2021-46790)

Roman Fiedler discovered that NTFS-3G incorrectly handled certain return codes. A local attacker could possibly use this issue to intercept protocol traffic between FUSE and the kernel. (CVE-2022-30783)

It was discovered that NTFS-3G incorrectly handled certain NTFS disk images. If a user or automated system were tricked into mounting a specially crafted disk image, a remote attacker could use this issue to cause a denial of service, or possibly execute arbitrary code. (CVE-2022-30784, CVE-2022-30786, CVE-2022-30788, CVE-2022-30789)

Roman Fiedler discovered that NTFS-3G incorrectly handled certain file handles. A local attacker could possibly use this issue to read and write arbitrary memory. (CVE-2022-30785, CVE-2022-30787)

References

Affected packages

Ubuntu:22.04:LTS / ntfs-3g

Package

Name
ntfs-3g

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
1:2021.8.22-3ubuntu1.1

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "ntfs-3g": "1:2021.8.22-3ubuntu1.1",
            "libntfs-3g89": "1:2021.8.22-3ubuntu1.1",
            "ntfs-3g-dev": "1:2021.8.22-3ubuntu1.1"
        }
    ]
}

Ubuntu:20.04:LTS / ntfs-3g

Package

Name
ntfs-3g

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
1:2017.3.23AR.3-3ubuntu1.2

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "ntfs-3g": "1:2017.3.23AR.3-3ubuntu1.2",
            "ntfs-3g-dev": "1:2017.3.23AR.3-3ubuntu1.2",
            "libntfs-3g883": "1:2017.3.23AR.3-3ubuntu1.2"
        }
    ]
}

Ubuntu:18.04:LTS / ntfs-3g

Package

Name
ntfs-3g

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
1:2017.3.23-2ubuntu0.18.04.4

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "ntfs-3g": "1:2017.3.23-2ubuntu0.18.04.4",
            "ntfs-3g-dev": "1:2017.3.23-2ubuntu0.18.04.4",
            "libntfs-3g88": "1:2017.3.23-2ubuntu0.18.04.4"
        }
    ]
}