USN-5474-1

See a problem?
Source
https://ubuntu.com/security/notices/USN-5474-1
Import Source
https://github.com/canonical/ubuntu-security-notices/blob/main/osv/USN-5474-1.json
JSON Data
https://api.osv.dev/v1/vulns/USN-5474-1
Related
Published
2022-06-08T19:20:14.335119Z
Modified
2022-06-08T19:20:14.335119Z
Summary
varnish vulnerabilities
Details

It was dicovered that Varnish Cache did not clear a pointer between the handling of one client request and the next request within the same connection. A remote attacker could possibly use this issue to obtain sensitive information. (CVE-2019-20637)

It was discovered that Varnish Cache could have an assertion failure when a TLS termination proxy uses PROXY version 2. A remote attacker could possibly use this issue to restart the daemon and cause a performance loss. (CVE-2020-11653)

It was discovered that Varnish Cache allowed request smuggling and VCL authorization bypass via a large Content-Length header for a POST request. A remote attacker could possibly use this issue to obtain sensitive information. (CVE-2021-36740)

It was discovered that Varnish Cache allowed request smuggling for HTTP/1 connections. A remote attacker could possibly use this issue to obtain sensitive information. (CVE-2022-23959)

References

Affected packages

Ubuntu:22.04:LTS / varnish

Package

Name
varnish

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
6.6.1-1ubuntu0.2

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "libvarnishapi-dev": "6.6.1-1ubuntu0.2",
            "varnish": "6.6.1-1ubuntu0.2",
            "varnish-doc": "6.6.1-1ubuntu0.2",
            "libvarnishapi2": "6.6.1-1ubuntu0.2"
        }
    ]
}

Ubuntu:20.04:LTS / varnish

Package

Name
varnish

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
6.2.1-2ubuntu0.1

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "libvarnishapi-dev": "6.2.1-2ubuntu0.1",
            "varnish": "6.2.1-2ubuntu0.1",
            "varnish-doc": "6.2.1-2ubuntu0.1",
            "libvarnishapi2": "6.2.1-2ubuntu0.1"
        }
    ]
}

Ubuntu:18.04:LTS / varnish

Package

Name
varnish

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
5.2.1-1ubuntu0.1

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "libvarnishapi-dev": "5.2.1-1ubuntu0.1",
            "libvarnishapi1": "5.2.1-1ubuntu0.1",
            "varnish-doc": "5.2.1-1ubuntu0.1",
            "varnish": "5.2.1-1ubuntu0.1"
        }
    ]
}