USN-5490-1

See a problem?
Source
https://ubuntu.com/security/notices/USN-5490-1
Import Source
https://github.com/canonical/ubuntu-security-notices/blob/main/osv/USN-5490-1.json
JSON Data
https://api.osv.dev/v1/vulns/USN-5490-1
Related
Published
2022-06-21T20:47:39.553383Z
Modified
2022-06-21T20:47:39.553383Z
Summary
protobuf vulnerability
Details

It was discovered that Protocol Buffers did not properly parse certain symbols. An attacker could possibly use this issue to cause a denial of service or other unspecified impact.

References

Affected packages

Ubuntu:Pro:16.04:LTS / protobuf

Package

Name
protobuf

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
2.6.1-1.3ubuntu0.1~esm1

Ecosystem specific

{
    "availability": "Available with Ubuntu Pro: https://ubuntu.com/pro",
    "binaries": [
        {
            "libprotobuf-java": "2.6.1-1.3ubuntu0.1~esm1",
            "python-protobuf": "2.6.1-1.3ubuntu0.1~esm1",
            "libprotoc-dev": "2.6.1-1.3ubuntu0.1~esm1",
            "protobuf-compiler": "2.6.1-1.3ubuntu0.1~esm1",
            "libprotobuf-dev": "2.6.1-1.3ubuntu0.1~esm1",
            "libprotobuf-lite9v5": "2.6.1-1.3ubuntu0.1~esm1",
            "libprotoc9v5": "2.6.1-1.3ubuntu0.1~esm1",
            "libprotobuf9v5": "2.6.1-1.3ubuntu0.1~esm1"
        }
    ]
}