USN-5502-1

See a problem?
Source
https://ubuntu.com/security/notices/USN-5502-1
Import Source
https://github.com/canonical/ubuntu-security-notices/blob/main/osv/USN-5502-1.json
JSON Data
https://api.osv.dev/v1/vulns/USN-5502-1
Related
Published
2022-07-05T13:03:48.818700Z
Modified
2022-07-05T13:03:48.818700Z
Summary
openssl vulnerability
Details

Alex Chernyakhovsky discovered that OpenSSL incorrectly handled AES OCB mode when using the AES-NI assembly optimized implementation on 32-bit x86 platforms. A remote attacker could possibly use this issue to obtain sensitive information.

References

Affected packages

Ubuntu:22.04:LTS / openssl

Package

Name
openssl

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
3.0.2-0ubuntu1.6

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "libssl3": "3.0.2-0ubuntu1.6",
            "libssl-dev": "3.0.2-0ubuntu1.6",
            "openssl": "3.0.2-0ubuntu1.6",
            "libssl-doc": "3.0.2-0ubuntu1.6"
        }
    ]
}

Ubuntu:20.04:LTS / openssl

Package

Name
openssl

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
1.1.1f-1ubuntu2.16

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "libssl1.1": "1.1.1f-1ubuntu2.16",
            "libssl-dev": "1.1.1f-1ubuntu2.16",
            "openssl": "1.1.1f-1ubuntu2.16",
            "libssl-doc": "1.1.1f-1ubuntu2.16"
        }
    ]
}

Ubuntu:18.04:LTS / openssl

Package

Name
openssl

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
1.1.1-1ubuntu2.1~18.04.20

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "libssl1.1": "1.1.1-1ubuntu2.1~18.04.20",
            "libssl-dev": "1.1.1-1ubuntu2.1~18.04.20",
            "openssl": "1.1.1-1ubuntu2.1~18.04.20",
            "libssl-doc": "1.1.1-1ubuntu2.1~18.04.20"
        }
    ]
}