USN-5533-1

See a problem?
Source
https://ubuntu.com/security/notices/USN-5533-1
Import Source
https://github.com/canonical/ubuntu-security-notices/blob/main/osv/USN-5533-1.json
JSON Data
https://api.osv.dev/v1/vulns/USN-5533-1
Related
Published
2022-07-26T15:22:59.047875Z
Modified
2022-07-26T15:22:59.047875Z
Summary
vim vulnerability
Details

It was discovered that Vim incorrectly handled memory access. If a user were tricked into opening a specially crafted file, an attacker could possibly use this issue to cause the corruption of sensitive information, a crash, or arbitrary code execution.

References

Affected packages

Ubuntu:Pro:16.04:LTS / vim

Package

Name
vim

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
2:7.4.1689-3ubuntu1.5+esm12

Ecosystem specific

{
    "availability": "Available with Ubuntu Pro: https://ubuntu.com/pro",
    "binaries": [
        {
            "vim-gui-common": "2:7.4.1689-3ubuntu1.5+esm12",
            "vim-gtk-py2": "2:7.4.1689-3ubuntu1.5+esm12",
            "vim-tiny": "2:7.4.1689-3ubuntu1.5+esm12",
            "vim-gtk": "2:7.4.1689-3ubuntu1.5+esm12",
            "vim-athena": "2:7.4.1689-3ubuntu1.5+esm12",
            "vim-nox": "2:7.4.1689-3ubuntu1.5+esm12",
            "vim-doc": "2:7.4.1689-3ubuntu1.5+esm12",
            "vim-gnome": "2:7.4.1689-3ubuntu1.5+esm12",
            "vim": "2:7.4.1689-3ubuntu1.5+esm12",
            "vim-gnome-py2": "2:7.4.1689-3ubuntu1.5+esm12",
            "vim-athena-py2": "2:7.4.1689-3ubuntu1.5+esm12",
            "vim-common": "2:7.4.1689-3ubuntu1.5+esm12",
            "vim-gtk3-py2": "2:7.4.1689-3ubuntu1.5+esm12",
            "vim-gtk3": "2:7.4.1689-3ubuntu1.5+esm12",
            "vim-nox-py2": "2:7.4.1689-3ubuntu1.5+esm12",
            "vim-runtime": "2:7.4.1689-3ubuntu1.5+esm12"
        }
    ]
}