USN-5563-1

See a problem?
Source
https://ubuntu.com/security/notices/USN-5563-1
Import Source
https://github.com/canonical/ubuntu-security-notices/blob/main/osv/USN-5563-1.json
JSON Data
https://api.osv.dev/v1/vulns/USN-5563-1
Related
Published
2022-08-10T16:32:52.465433Z
Modified
2022-08-10T16:32:52.465433Z
Summary
http-parser vulnerability
Details

It was discovered that http-parser incorrectly handled certain requests. An attacker could possibly use this issue to bypass security controls or gain unauthorized access to sensitive data.

References

Affected packages

Ubuntu:18.04:LTS / http-parser

Package

Name
http-parser

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
2.7.1-2ubuntu0.1

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "libhttp-parser-dev": "2.7.1-2ubuntu0.1",
            "libhttp-parser2.7.1": "2.7.1-2ubuntu0.1"
        }
    ]
}