USN-5572-2

See a problem?
Source
https://ubuntu.com/security/notices/USN-5572-2
Import Source
https://github.com/canonical/ubuntu-security-notices/blob/main/osv/USN-5572-2.json
JSON Data
https://api.osv.dev/v1/vulns/USN-5572-2
Related
Published
2022-08-30T13:48:13.608524Z
Modified
2022-08-30T13:48:13.608524Z
Summary
linux-aws vulnerabilities
Details

Roger Pau Monné discovered that the Xen virtual block driver in the Linux kernel did not properly initialize memory pages to be used for shared communication with the backend. A local attacker could use this to expose sensitive information (guest kernel memory). (CVE-2022-26365)

Roger Pau Monné discovered that the Xen paravirtualization frontend in the Linux kernel did not properly initialize memory pages to be used for shared communication with the backend. A local attacker could use this to expose sensitive information (guest kernel memory). (CVE-2022-33740)

It was discovered that the Xen paravirtualization frontend in the Linux kernel incorrectly shared unrelated data when communicating with certain backends. A local attacker could use this to cause a denial of service (guest crash) or expose sensitive information (guest kernel memory). (CVE-2022-33741)

References

Affected packages

Ubuntu:Pro:14.04:LTS / linux-aws

Package

Name
linux-aws

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
4.4.0-1112.118

Ecosystem specific

{
    "availability": "Available with Ubuntu Pro: https://ubuntu.com/pro",
    "binaries": [
        {
            "linux-image-4.4.0-1112-aws": "4.4.0-1112.118",
            "linux-cloud-tools-4.4.0-1112-aws": "4.4.0-1112.118",
            "linux-aws-tools-4.4.0-1112": "4.4.0-1112.118",
            "linux-buildinfo-4.4.0-1112-aws": "4.4.0-1112.118",
            "linux-aws-cloud-tools-4.4.0-1112": "4.4.0-1112.118",
            "linux-aws-headers-4.4.0-1112": "4.4.0-1112.118",
            "linux-aws": "4.4.0.1112.109",
            "linux-headers-aws": "4.4.0.1112.109",
            "linux-modules-4.4.0-1112-aws": "4.4.0-1112.118",
            "linux-tools-aws": "4.4.0.1112.109",
            "linux-headers-4.4.0-1112-aws": "4.4.0-1112.118",
            "linux-image-aws": "4.4.0.1112.109",
            "linux-tools-4.4.0-1112-aws": "4.4.0-1112.118"
        }
    ]
}