USN-5575-1

See a problem?
Source
https://ubuntu.com/security/notices/USN-5575-1
Import Source
https://github.com/canonical/ubuntu-security-notices/blob/main/osv/USN-5575-1.json
JSON Data
https://api.osv.dev/v1/vulns/USN-5575-1
Related
Published
2022-08-22T12:37:09.944305Z
Modified
2022-08-22T12:37:09.944305Z
Summary
libxslt vulnerabilities
Details

Nicolas Grégoire discovered that Libxslt incorrectly handled certain XML. An attacker could possibly use this issue to expose sensitive information or execute arbitrary code. This issue only affected Ubuntu 18.04 LTS. (CVE-2019-5815)

Alexey Neyman incorrectly handled certain HTML pages. An attacker could possibly use this issue to expose sensitive information or execute arbitrary code. (CVE-2021-30560)

References

Affected packages

Ubuntu:22.04:LTS / libxslt

Package

Name
libxslt

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
1.1.34-4ubuntu0.22.04.1

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "libxslt1-dev": "1.1.34-4ubuntu0.22.04.1",
            "xsltproc": "1.1.34-4ubuntu0.22.04.1",
            "libxslt1.1": "1.1.34-4ubuntu0.22.04.1"
        }
    ]
}

Ubuntu:20.04:LTS / libxslt

Package

Name
libxslt

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
1.1.34-4ubuntu0.20.04.1

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "libxslt1-dev": "1.1.34-4ubuntu0.20.04.1",
            "xsltproc": "1.1.34-4ubuntu0.20.04.1",
            "libxslt1.1": "1.1.34-4ubuntu0.20.04.1"
        }
    ]
}

Ubuntu:18.04:LTS / libxslt

Package

Name
libxslt

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
1.1.29-5ubuntu0.3

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "python-libxslt1": "1.1.29-5ubuntu0.3",
            "libxslt1-dev": "1.1.29-5ubuntu0.3",
            "xsltproc": "1.1.29-5ubuntu0.3",
            "libxslt1.1": "1.1.29-5ubuntu0.3"
        }
    ]
}