USN-5577-1

See a problem?
Source
https://ubuntu.com/security/notices/USN-5577-1
Import Source
https://github.com/canonical/ubuntu-security-notices/blob/main/osv/USN-5577-1.json
JSON Data
https://api.osv.dev/v1/vulns/USN-5577-1
Related
  • CVE-2021-33061
  • CVE-2021-33655
Published
2022-08-24T04:14:17.955908Z
Modified
2022-08-24T04:14:17.955908Z
Summary
linux-oem-5.14 vulnerabilities
Details

Asaf Modelevsky discovered that the Intel(R) 10GbE PCI Express (ixgbe) Ethernet driver for the Linux kernel performed insufficient control flow management. A local attacker could possibly use this to cause a denial of service. (CVE-2021-33061)

It was discovered that the framebuffer driver on the Linux kernel did not verify size limits when changing font or screen size, leading to an out-of- bounds write. A local attacker could use this to cause a denial of service (system crash) or possibly execute arbitrary code. (CVE-2021-33655)

References

Affected packages

Ubuntu:20.04:LTS / linux-oem-5.14

Package

Name
linux-oem-5.14

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
5.14.0-1049.56

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "linux-oem-20.04c": "5.14.0.1049.45",
            "linux-tools-oem-20.04c": "5.14.0.1049.45",
            "linux-oem-5.14-tools-5.14.0-1049": "5.14.0-1049.56",
            "linux-headers-oem-20.04b": "5.14.0.1049.45",
            "linux-image-oem-20.04": "5.14.0.1049.45",
            "linux-tools-5.14.0-1049-oem": "5.14.0-1049.56",
            "linux-headers-oem-20.04c": "5.14.0.1049.45",
            "linux-image-5.14.0-1049-oem": "5.14.0-1049.56",
            "linux-tools-oem-20.04": "5.14.0.1049.45",
            "linux-modules-iwlwifi-5.14.0-1049-oem": "5.14.0-1049.56",
            "linux-modules-iwlwifi-oem-20.04d": "5.14.0.1049.45",
            "linux-oem-20.04d": "5.14.0.1049.45",
            "linux-modules-iwlwifi-oem-20.04": "5.14.0.1049.45",
            "linux-oem-5.14-tools-host": "5.14.0-1049.56",
            "linux-oem-5.14-headers-5.14.0-1049": "5.14.0-1049.56",
            "linux-image-oem-20.04d": "5.14.0.1049.45",
            "linux-image-unsigned-5.14.0-1049-oem": "5.14.0-1049.56",
            "linux-oem-20.04b": "5.14.0.1049.45",
            "linux-headers-5.14.0-1049-oem": "5.14.0-1049.56",
            "linux-tools-oem-20.04d": "5.14.0.1049.45",
            "linux-image-oem-20.04c": "5.14.0.1049.45",
            "linux-oem-20.04": "5.14.0.1049.45",
            "linux-headers-oem-20.04": "5.14.0.1049.45",
            "linux-image-oem-20.04b": "5.14.0.1049.45",
            "linux-headers-oem-20.04d": "5.14.0.1049.45",
            "linux-tools-oem-20.04b": "5.14.0.1049.45",
            "linux-modules-5.14.0-1049-oem": "5.14.0-1049.56",
            "linux-buildinfo-5.14.0-1049-oem": "5.14.0-1049.56"
        }
    ]
}