USN-5584-1

See a problem?
Source
https://ubuntu.com/security/notices/USN-5584-1
Import Source
https://github.com/canonical/ubuntu-security-notices/blob/main/osv/USN-5584-1.json
JSON Data
https://api.osv.dev/v1/vulns/USN-5584-1
Related
  • CVE-2022-2787
Published
2022-08-29T10:12:41.778137Z
Modified
2022-08-29T10:12:41.778137Z
Summary
schroot vulnerability
Details

It was discovered that Schroot incorrectly handled certain Schroot names. An attacker could possibly use this issue to break schroot's internal state causing a denial of service.

References

Affected packages

Ubuntu:22.04:LTS / schroot

Package

Name
schroot

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
1.6.10-12ubuntu3.1

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "schroot": "1.6.10-12ubuntu3.1",
            "schroot-common": "1.6.10-12ubuntu3.1"
        }
    ]
}

Ubuntu:20.04:LTS / schroot

Package

Name
schroot

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
1.6.10-9ubuntu0.1

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "schroot": "1.6.10-9ubuntu0.1",
            "schroot-common": "1.6.10-9ubuntu0.1"
        }
    ]
}

Ubuntu:18.04:LTS / schroot

Package

Name
schroot

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
1.6.10-4ubuntu0.1

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "schroot": "1.6.10-4ubuntu0.1",
            "schroot-common": "1.6.10-4ubuntu0.1"
        }
    ]
}

Ubuntu:Pro:16.04:LTS / schroot

Package

Name
schroot

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
1.6.10-1ubuntu3+esm1

Ecosystem specific

{
    "availability": "Available with Ubuntu Pro: https://ubuntu.com/pro",
    "binaries": [
        {
            "schroot": "1.6.10-1ubuntu3+esm1",
            "dchroot": "1.6.10-1ubuntu3+esm1",
            "dchroot-dsa": "1.6.10-1ubuntu3+esm1",
            "libsbuild-doc": "1.6.10-1ubuntu3+esm1",
            "libsbuild-dev": "1.6.10-1ubuntu3+esm1",
            "schroot-common": "1.6.10-1ubuntu3+esm1"
        }
    ]
}