USN-5589-1

See a problem?
Source
https://ubuntu.com/security/notices/USN-5589-1
Import Source
https://github.com/canonical/ubuntu-security-notices/blob/main/osv/USN-5589-1.json
JSON Data
https://api.osv.dev/v1/vulns/USN-5589-1
Related
  • CVE-2021-33061
  • CVE-2021-33656
Published
2022-08-30T17:07:06.687217Z
Modified
2022-08-30T17:07:06.687217Z
Summary
linux, linux-raspi vulnerabilities
Details

Asaf Modelevsky discovered that the Intel(R) 10GbE PCI Express (ixgbe) Ethernet driver for the Linux kernel performed insufficient control flow management. A local attacker could possibly use this to cause a denial of service. (CVE-2021-33061)

It was discovered that the virtual terminal driver in the Linux kernel did not properly handle VGA console font changes, leading to an out-of-bounds write. A local attacker could use this to cause a denial of service (system crash) or possibly execute arbitrary code. (CVE-2021-33656)

References

Affected packages

Ubuntu:20.04:LTS / linux-raspi

Package

Name
linux-raspi

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
5.4.0-1069.79

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "linux-image-raspi2-hwe-18.04-edge": "5.4.0.1069.102",
            "linux-raspi-tools-5.4.0-1069": "5.4.0-1069.79",
            "linux-modules-5.4.0-1069-raspi": "5.4.0-1069.79",
            "linux-headers-raspi": "5.4.0.1069.102",
            "linux-tools-raspi-hwe-18.04-edge": "5.4.0.1069.102",
            "linux-image-raspi2": "5.4.0.1069.102",
            "linux-raspi-hwe-18.04-edge": "5.4.0.1069.102",
            "linux-raspi2-hwe-18.04-edge": "5.4.0.1069.102",
            "linux-headers-raspi-hwe-18.04": "5.4.0.1069.102",
            "linux-headers-raspi-hwe-18.04-edge": "5.4.0.1069.102",
            "linux-headers-raspi2-hwe-18.04": "5.4.0.1069.102",
            "linux-image-raspi": "5.4.0.1069.102",
            "linux-image-raspi2-hwe-18.04": "5.4.0.1069.102",
            "linux-image-raspi-hwe-18.04-edge": "5.4.0.1069.102",
            "linux-tools-raspi2-hwe-18.04-edge": "5.4.0.1069.102",
            "linux-headers-5.4.0-1069-raspi": "5.4.0-1069.79",
            "linux-headers-raspi2-hwe-18.04-edge": "5.4.0.1069.102",
            "linux-buildinfo-5.4.0-1069-raspi": "5.4.0-1069.79",
            "linux-raspi-headers-5.4.0-1069": "5.4.0-1069.79",
            "linux-tools-raspi": "5.4.0.1069.102",
            "linux-image-raspi-hwe-18.04": "5.4.0.1069.102",
            "linux-raspi2-hwe-18.04": "5.4.0.1069.102",
            "linux-raspi": "5.4.0.1069.102",
            "linux-raspi-hwe-18.04": "5.4.0.1069.102",
            "linux-headers-raspi2": "5.4.0.1069.102",
            "linux-tools-raspi2": "5.4.0.1069.102",
            "linux-tools-5.4.0-1069-raspi": "5.4.0-1069.79",
            "linux-raspi2": "5.4.0.1069.102",
            "linux-tools-raspi2-hwe-18.04": "5.4.0.1069.102",
            "linux-tools-raspi-hwe-18.04": "5.4.0.1069.102",
            "linux-image-5.4.0-1069-raspi": "5.4.0-1069.79"
        }
    ]
}

Ubuntu:20.04:LTS / linux

Package

Name
linux

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
5.4.0-125.141

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "linux-generic-hwe-18.04": "5.4.0.125.126",
            "linux-headers-oem": "5.4.0.125.126",
            "linux-tools-virtual-hwe-18.04-edge": "5.4.0.125.126",
            "linux-tools-5.4.0-125-generic-lpae": "5.4.0-125.141",
            "linux-lowlatency-hwe-18.04": "5.4.0.125.126",
            "linux-cloud-tools-5.4.0-125-generic": "5.4.0-125.141",
            "linux-cloud-tools-virtual": "5.4.0.125.126",
            "linux-tools-generic-lpae-hwe-18.04": "5.4.0.125.126",
            "linux-cloud-tools-lowlatency": "5.4.0.125.126",
            "linux-lowlatency-hwe-18.04-edge": "5.4.0.125.126",
            "linux-headers-lowlatency-hwe-18.04-edge": "5.4.0.125.126",
            "linux-generic-lpae-hwe-18.04": "5.4.0.125.126",
            "linux-headers-generic-hwe-18.04": "5.4.0.125.126",
            "linux-generic-lpae-hwe-18.04-edge": "5.4.0.125.126",
            "linux-modules-extra-5.4.0-125-generic": "5.4.0-125.141",
            "linux-oem-osp1-tools-host": "5.4.0.125.126",
            "linux-cloud-tools-generic-hwe-18.04": "5.4.0.125.126",
            "linux-image-5.4.0-125-lowlatency": "5.4.0-125.141",
            "linux-tools-5.4.0-125": "5.4.0-125.141",
            "linux-source": "5.4.0.125.126",
            "linux-image-extra-virtual": "5.4.0.125.126",
            "linux-oem": "5.4.0.125.126",
            "linux-tools-virtual": "5.4.0.125.126",
            "linux-cloud-tools-generic": "5.4.0.125.126",
            "linux-image-virtual": "5.4.0.125.126",
            "linux-tools-generic": "5.4.0.125.126",
            "linux-generic-lpae": "5.4.0.125.126",
            "linux-headers-5.4.0-125-generic-lpae": "5.4.0-125.141",
            "linux-buildinfo-5.4.0-125-generic": "5.4.0-125.141",
            "linux-cloud-tools-lowlatency-hwe-18.04-edge": "5.4.0.125.126",
            "linux-virtual": "5.4.0.125.126",
            "linux-image-unsigned-5.4.0-125-lowlatency": "5.4.0-125.141",
            "linux-image-generic-hwe-18.04-edge": "5.4.0.125.126",
            "linux-image-generic-lpae-hwe-18.04": "5.4.0.125.126",
            "linux-crashdump": "5.4.0.125.126",
            "linux-cloud-tools-lowlatency-hwe-18.04": "5.4.0.125.126",
            "linux-generic": "5.4.0.125.126",
            "linux-headers-lowlatency-hwe-18.04": "5.4.0.125.126",
            "linux-modules-5.4.0-125-generic-lpae": "5.4.0-125.141",
            "linux-tools-generic-hwe-18.04-edge": "5.4.0.125.126",
            "linux-headers-virtual-hwe-18.04-edge": "5.4.0.125.126",
            "linux-tools-5.4.0-125-lowlatency": "5.4.0-125.141",
            "linux-generic-hwe-18.04-edge": "5.4.0.125.126",
            "linux-buildinfo-5.4.0-125-generic-lpae": "5.4.0-125.141",
            "linux-cloud-tools-5.4.0-125-lowlatency": "5.4.0-125.141",
            "linux-image-unsigned-5.4.0-125-generic": "5.4.0-125.141",
            "linux-tools-lowlatency-hwe-18.04-edge": "5.4.0.125.126",
            "linux-image-generic-lpae": "5.4.0.125.126",
            "linux-headers-generic-lpae": "5.4.0.125.126",
            "linux-tools-lowlatency": "5.4.0.125.126",
            "linux-headers-5.4.0-125-lowlatency": "5.4.0-125.141",
            "linux-headers-oem-osp1": "5.4.0.125.126",
            "linux-cloud-tools-common": "5.4.0-125.141",
            "linux-headers-generic-hwe-18.04-edge": "5.4.0.125.126",
            "linux-image-lowlatency-hwe-18.04-edge": "5.4.0.125.126",
            "linux-headers-generic-lpae-hwe-18.04": "5.4.0.125.126",
            "linux-libc-dev": "5.4.0-125.141",
            "linux-source-5.4.0": "5.4.0-125.141",
            "linux-cloud-tools-generic-hwe-18.04-edge": "5.4.0.125.126",
            "linux-image-virtual-hwe-18.04-edge": "5.4.0.125.126",
            "linux-doc": "5.4.0-125.141",
            "linux-headers-virtual-hwe-18.04": "5.4.0.125.126",
            "linux-image-lowlatency-hwe-18.04": "5.4.0.125.126",
            "linux-tools-oem-osp1": "5.4.0.125.126",
            "linux-oem-osp1": "5.4.0.125.126",
            "linux-image-5.4.0-125-generic-lpae": "5.4.0-125.141",
            "linux-headers-generic": "5.4.0.125.126",
            "linux-tools-oem": "5.4.0.125.126",
            "linux-headers-lowlatency": "5.4.0.125.126",
            "linux-oem-tools-host": "5.4.0.125.126",
            "linux-tools-generic-lpae-hwe-18.04-edge": "5.4.0.125.126",
            "linux-headers-virtual": "5.4.0.125.126",
            "linux-image-lowlatency": "5.4.0.125.126",
            "linux-virtual-hwe-18.04": "5.4.0.125.126",
            "linux-image-oem": "5.4.0.125.126",
            "linux-cloud-tools-virtual-hwe-18.04-edge": "5.4.0.125.126",
            "linux-cloud-tools-5.4.0-125": "5.4.0-125.141",
            "linux-modules-5.4.0-125-generic": "5.4.0-125.141",
            "linux-tools-host": "5.4.0-125.141",
            "linux-image-generic-lpae-hwe-18.04-edge": "5.4.0.125.126",
            "linux-modules-5.4.0-125-lowlatency": "5.4.0-125.141",
            "linux-buildinfo-5.4.0-125-lowlatency": "5.4.0-125.141",
            "linux-virtual-hwe-18.04-edge": "5.4.0.125.126",
            "linux-image-generic-hwe-18.04": "5.4.0.125.126",
            "linux-cloud-tools-virtual-hwe-18.04": "5.4.0.125.126",
            "linux-headers-5.4.0-125": "5.4.0-125.141",
            "linux-image-5.4.0-125-generic": "5.4.0-125.141",
            "linux-tools-generic-lpae": "5.4.0.125.126",
            "linux-image-extra-virtual-hwe-18.04-edge": "5.4.0.125.126",
            "linux-image-oem-osp1": "5.4.0.125.126",
            "linux-headers-generic-lpae-hwe-18.04-edge": "5.4.0.125.126",
            "linux-tools-virtual-hwe-18.04": "5.4.0.125.126",
            "linux-image-virtual-hwe-18.04": "5.4.0.125.126",
            "linux-tools-5.4.0-125-generic": "5.4.0-125.141",
            "linux-tools-common": "5.4.0-125.141",
            "linux-tools-generic-hwe-18.04": "5.4.0.125.126",
            "linux-image-generic": "5.4.0.125.126",
            "linux-lowlatency": "5.4.0.125.126",
            "linux-headers-5.4.0-125-generic": "5.4.0-125.141",
            "linux-tools-lowlatency-hwe-18.04": "5.4.0.125.126",
            "linux-image-extra-virtual-hwe-18.04": "5.4.0.125.126"
        }
    ]
}