USN-5591-2

See a problem?
Source
https://ubuntu.com/security/notices/USN-5591-2
Import Source
https://github.com/canonical/ubuntu-security-notices/blob/main/osv/USN-5591-2.json
JSON Data
https://api.osv.dev/v1/vulns/USN-5591-2
Related
  • CVE-2021-33656
Published
2022-09-01T17:21:52.500437Z
Modified
2022-09-01T17:21:52.500437Z
Summary
linux-aws-hwe vulnerability
Details

It was discovered that the virtual terminal driver in the Linux kernel did not properly handle VGA console font changes, leading to an out-of-bounds write. A local attacker could use this to cause a denial of service (system crash) or possibly execute arbitrary code.

References

Affected packages

Ubuntu:Pro:16.04:LTS / linux-aws-hwe

Package

Name
linux-aws-hwe

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
4.15.0-1140.151~16.04.1

Ecosystem specific

{
    "availability": "Available with Ubuntu Pro: https://ubuntu.com/pro",
    "binaries": [
        {
            "linux-modules-extra-4.15.0-1140-aws": "4.15.0-1140.151~16.04.1",
            "linux-image-4.15.0-1140-aws-hwe": "4.15.0-1140.151~16.04.1",
            "linux-buildinfo-4.15.0-1140-aws": "4.15.0-1140.151~16.04.1",
            "linux-image-unsigned-4.15.0-1140-aws": "4.15.0-1140.151~16.04.1",
            "linux-modules-extra-aws-hwe": "4.15.0.1140.127",
            "linux-headers-4.15.0-1140-aws": "4.15.0-1140.151~16.04.1",
            "linux-aws-hwe": "4.15.0.1140.127",
            "linux-tools-4.15.0-1140-aws": "4.15.0-1140.151~16.04.1",
            "linux-aws-headers-4.15.0-1140": "4.15.0-1140.151~16.04.1",
            "linux-headers-aws-hwe": "4.15.0.1140.127",
            "linux-aws-hwe-cloud-tools-4.15.0-1140": "4.15.0-1140.151~16.04.1",
            "linux-image-aws-hwe": "4.15.0.1140.127",
            "linux-aws-edge": "4.15.0.1140.127",
            "linux-cloud-tools-4.15.0-1140-aws": "4.15.0-1140.151~16.04.1",
            "linux-modules-4.15.0-1140-aws": "4.15.0-1140.151~16.04.1",
            "linux-tools-aws-hwe": "4.15.0.1140.127",
            "linux-aws-hwe-tools-4.15.0-1140": "4.15.0-1140.151~16.04.1"
        }
    ]
}