USN-5613-2

See a problem?
Source
https://ubuntu.com/security/notices/USN-5613-2
Import Source
https://github.com/canonical/ubuntu-security-notices/blob/main/osv/USN-5613-2.json
JSON Data
https://api.osv.dev/v1/vulns/USN-5613-2
Related
Published
2022-09-19T12:53:35.629098Z
Modified
2022-09-19T12:53:35.629098Z
Summary
vim regression
Details

USN-5613-1 fixed vulnerabilities in Vim. Unfortunately that update failed to include binary packages for some architectures. This update fixes that regression.

We apologize for the inconvenience.

Original advisory details:

It was discovered that Vim was not properly performing bounds checks when executing spell suggestion commands. An attacker could possibly use this issue to cause a denial of service or execute arbitrary code. (CVE-2022-0943)

It was discovered that Vim was using freed memory when dealing with regular expressions through its old regular expression engine. If a user were tricked into opening a specially crafted file, an attacker could crash the application, leading to a denial of service, or possibly achieve code execution. (CVE-2022-1154)

It was discovered that Vim was not properly performing checks on name of lambda functions. An attacker could possibly use this issue to cause a denial of service. This issue affected only Ubuntu 22.04 LTS. (CVE-2022-1420)

It was discovered that Vim was incorrectly performing bounds checks when processing invalid commands with composing characters in Ex mode. An attacker could possibly use this issue to cause a denial of service or execute arbitrary code. (CVE-2022-1616)

It was discovered that Vim was not properly processing latin1 data when issuing Ex commands. An attacker could possibly use this issue to cause a denial of service or execute arbitrary code. (CVE-2022-1619)

It was discovered that Vim was not properly performing memory management when dealing with invalid regular expression patterns in buffers. An attacker could possibly use this issue to cause a denial of service. (CVE-2022-1620)

It was discovered that Vim was not properly processing invalid bytes when performing spell check operations. An attacker could possibly use this issue to cause a denial of service or execute arbitrary code. (CVE-2022-1621)

References

Affected packages

Ubuntu:20.04:LTS / vim

Package

Name
vim

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
2:8.1.2269-1ubuntu5.9

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "vim-doc": "2:8.1.2269-1ubuntu5.9",
            "vim-athena": "2:8.1.2269-1ubuntu5.9",
            "vim-gui-common": "2:8.1.2269-1ubuntu5.9",
            "vim": "2:8.1.2269-1ubuntu5.9",
            "vim-tiny": "2:8.1.2269-1ubuntu5.9",
            "vim-common": "2:8.1.2269-1ubuntu5.9",
            "vim-runtime": "2:8.1.2269-1ubuntu5.9",
            "vim-gtk3": "2:8.1.2269-1ubuntu5.9",
            "vim-gtk": "2:8.1.2269-1ubuntu5.9",
            "xxd": "2:8.1.2269-1ubuntu5.9",
            "vim-nox": "2:8.1.2269-1ubuntu5.9"
        }
    ]
}