USN-5672-1

See a problem?
Source
https://ubuntu.com/security/notices/USN-5672-1
Import Source
https://github.com/canonical/ubuntu-security-notices/blob/main/osv/USN-5672-1.json
JSON Data
https://api.osv.dev/v1/vulns/USN-5672-1
Related
Published
2022-10-12T12:54:58.792040Z
Modified
2022-10-12T12:54:58.792040Z
Summary
GMP vulnerability
Details

It was discovered that GMP did not properly manage memory on 32-bit platforms when processing a specially crafted input. An attacker could possibly use this issue to cause applications using GMP to crash, resulting in a denial of service.

References

Affected packages

Ubuntu:20.04:LTS / gmp

Package

Name
gmp

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
2:6.2.0+dfsg-4ubuntu0.1

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "libgmp10-doc": "2:6.2.0+dfsg-4ubuntu0.1",
            "libgmp-dev": "2:6.2.0+dfsg-4ubuntu0.1",
            "libgmp10": "2:6.2.0+dfsg-4ubuntu0.1",
            "libgmpxx4ldbl": "2:6.2.0+dfsg-4ubuntu0.1",
            "libgmp3-dev": "2:6.2.0+dfsg-4ubuntu0.1"
        }
    ]
}

Ubuntu:18.04:LTS / gmp

Package

Name
gmp

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
2:6.1.2+dfsg-2ubuntu0.1

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "libgmp10-doc": "2:6.1.2+dfsg-2ubuntu0.1",
            "libgmp-dev": "2:6.1.2+dfsg-2ubuntu0.1",
            "libgmp10": "2:6.1.2+dfsg-2ubuntu0.1",
            "libgmpxx4ldbl": "2:6.1.2+dfsg-2ubuntu0.1",
            "libgmp3-dev": "2:6.1.2+dfsg-2ubuntu0.1"
        }
    ]
}

Ubuntu:Pro:16.04:LTS / gmp

Package

Name
gmp

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
2:6.1.0+dfsg-2ubuntu0.1~esm1

Ecosystem specific

{
    "availability": "Available with Ubuntu Pro: https://ubuntu.com/pro",
    "binaries": [
        {
            "libgmp10-doc": "2:6.1.0+dfsg-2ubuntu0.1~esm1",
            "libgmp-dev": "2:6.1.0+dfsg-2ubuntu0.1~esm1",
            "libgmp10": "2:6.1.0+dfsg-2ubuntu0.1~esm1",
            "libgmpxx4ldbl": "2:6.1.0+dfsg-2ubuntu0.1~esm1",
            "libgmp3-dev": "2:6.1.0+dfsg-2ubuntu0.1~esm1"
        }
    ]
}